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DEXembed User’s Guide 
Jack Lyon & Ron Strauss 

 

All of the examples, tips, and tutorials in this Guide are based on the use of 

SKY Index indexing software to illustrate the process of embedding with 

DEXembed. To duplicate any of the described SKY Index functions in 

CINDEX or MACREX, please consult their documentation or technical sup-

port. 

This documentation and the DEXembed software are copyright © 2008 by 

the Editorium. All rights are reserved. DEXembed™, DEXter™, and Editori-

um™ are trademarks of the Editorium, LLC. 

Microsoft Word™, SKY Index™, CINDEX™, and MACREX™ are trade-

marks of their owners. Any other trademarks mentioned in this documentation 

or the program are also acknowledged as trademarks of their owners. 
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1 About DEXembed 

DEXembed is a Microsoft Word add-in created specifically to meet the needs 

of indexers who use standalone indexing programs (such as SKY Index, 

CINDEX, and MACREX), and who need to embed index tags in Microsoft 

Word documents. Originally part of its parent program, DEXter, it has been 

split off as a separate program and further developed to take into account the 

variety of workflow situations that arise in the real world of embedded indexing 

as required by different publishers. 

1.1 DEXter vs. DEXembed 

DEXter is a Word add-in that embeds index entries in a Word document after 

the indexer has created the entries in a customized table in Microsoft Word. 

(DEXter is analogous to IXgen for FrameMaker.) 

DEXembed is a Word add-in that embeds index entries in a Word document 

after the indexer has created the entries in a standalone indexing program such 

as SKY Index, CINDEX, or MACREX (or any other program that can export a 

tab-delimited text file). 

1.2 Special Features 

DEXembed was developed in an actual indexing environment. It was designed 

to accommodate the various workflows and processes employed by publishers 

who import embedded Microsoft Word documents into layout programs such 

as QuarkXPress, Framemaker, and InDesign. DEXembed accounts for the 

differences in these processes by incorporating a number of unique features: 

• Locator Variety. A document may be indexed using locators that cor-

respond to page numbers, paragraph numbers, or precise word placements. 

These locators are then used to embed the index tags. 

• Printed Pages or On-Screen. Indexing can be done from printed pages 

or exclusively on-screen. 

• Bookmarks Are Optional. Embedded tags can be produced with or 

without Microsoft Word bookmarks. (Bookmarks are used by Word to define 

ranges in index tags. In general, publishers do not want bookmarks in files that 

will be imported into a layout program.) 
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• Automated Coding of Ranges. Instead of bookmarks, ranges can be 

marked with codes chosen by the publisher or indexer. DEXembed automates 

the process of creating beginning and ending range entries, adding the codes to 

those entries, and then embedding the coded entries as Word index-entry 

fields—in one step. 

• Removal of Old Index Tags. DEXembed can strip out all previously 

embedded index-entry fields in a single automated action—often used when a 

final edit dictates re-embedding all the individual chapter files (if they are 

available) or removing old index-entry fields from a previous version of the 

book. 

• Automated Final Edit Cleanup. At the end of the indexing process, 

the indexer often receives a Quark- or Frame-generated index (as a Microsoft 

Word file) with final pagination, and must then carry out a final edit. DEXem-

bed provides two useful features to help with this editing process: 

1. The final generated index will usually contain range codes still appended 

to the tagged range entries. DEXembed will properly combine the range 

page locators and then delete the range codes. (Some publishers may 

have their own system to combine the locators and remove the range 

codes in the layout program prior to generating the index.) 

2. When the indexer receives the index (as a Word file) back from the pub-

lisher for editing, updating, or revising, DEXembed can properly style 

the index and convert it to a standalone table (.dat file) that can then be 

imported back into SKY Index, CINDEX, or MACREX for final editing. 
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2 Installing or Uninstalling 

DEXembed is a collection of macros in a template. You don’t use the template 

as you would an ordinary one by attaching it to a document. If you try to do 

that, you’ll run into problems. Instead, you “add” it to Microsoft Word as a 

global template or add-in (see the installation instructions below). 

Because the template contains macros, some virus-checking programs or 

even Word itself may warn you that the template could contain Word viruses. 

Please rest assured that it does not. The macros have been carefully checked 

and tested to make sure they are safe and usable. To ensure your security, you 

should download the program directly from the Editorium website at 

www.editorium.com. 

Please do not rename any of the DEXembed macros, copy them to another 

template, or remove them from the DEXembed template. DEXembed uses 

these macros in combination and won’t work properly if they have been copied 

to another template or renamed, or if some of the macros are no longer present. 

2.1 Installing DEXembed 

To install the program (please read carefully): 

1. Unzip (or unstuff) the program files so that they’re all together in a 

single folder or on your desktop. (If you need software to unzip or un-

stuff the program, you can download it from www.winzip.com or 

www.aladdinsys.com.) You cannot install the program by just opening 

the zip file and double-clicking one of the files. Most likely, however, 

you can open the zip file and drag the files out to your desktop. 

2. After the files are unzipped, open the file named “Install DEXem-

bed.dot” in Microsoft Word by clicking File > Open, selecting the file, 

and clicking the Open button. Do not open the file by double-clicking it 

outside of Microsoft Word. If you do, you’ll run into problems later. 

3. If Word asks if you want to “enable macros” when opening the file, your 

answer should be yes. Otherwise, the program won’t work. If Word tells 

you that the macros have been disabled, you’ll need to change your 

macro security settings and then restart Word before installing. Please 

see the “Troubleshooting” section at the end of this document for in-

structions. 

4. Double-click the large button that says “Double-Click here to Install.” 

This will install DEXembed as a global template or add-in, which 
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simply means that the program will be saved to Word’s Startup folder 

and will thus be available any time you start Word. 

5. Restart Word to activate the program and display the DEXembed menu 

at the top of your Word window. In Word 2007, the menu will be dis-

played under Word’s “Add-ins” menu. 

If that doesn’t  work, you can install DEXembed manually. With Microsoft 

Word closed: 

1. On your computer desktop, double-click My Computer. (On a Macin-

tosh, open your hard drive. Then continue with step 5, below.) 

2. At the top of the window that opens, you’ll see a “Tools” menu. Click 

that, and then click “Folder Options.” 

3. Click the “View” tab and make sure that “Show hidden files and fold-

ers” is selected. Then click the OK button. 

4. Back in the window for “My Computer,” double-click your local hard 

drive, probably “C.” 

5. Open the folders named, consecutively within each other, Documents 

and Settings > [your name] > Application Data > Microsoft > Word > 

Startup. (On a Macintosh, open Applications > Microsoft Office > Of-

fice > Startup > Word.) 

6. Put the file named “DEXembed.dot” into the Startup folder (on a Macin-

tosh, into the Startup > Word folder). 

7. Restart Microsoft Word. 

2.2 Uninstalling DEXembed 

To uninstall the program: 

1. Open the file named “Install DEXembed.dot” in Microsoft Word by 

clicking File > Open, selecting the template, and clicking the Open but-

ton. Do not open the file by double-clicking it outside of Microsoft Word. 

If you do, you’ll run into problems later. 

2. If Word asks if you want to “enable macros” when opening the file, your 

answer should be yes. Otherwise, the program won’t work. If Word tells 

you that the macros have been disabled, you’ll need to change your mac-

ro security settings in order to use the program. Please see the “Trouble-

shooting” section of this documentation for instructions. 

3. Double-click the large button that says “Double-Click here to Uninstall.” 
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If necessary, you can remove the template manually from Word’s Startup 

folder: 

1. On your computer desktop, double-click My Computer. (On a Macin-

tosh, open your hard drive. Then continue with step 5, below.) 

2. At the top of the window that opens, you’ll see a “Tools” menu. Click 

that, and then click “Folder Options.” 

3. Click the “View” tab and make sure that “Show hidden files and fold-

ers” is selected. Then click the OK button. 

4. Back in the window for “My Computer,” double-click your local hard 

drive, probably “C.” 

5. Open the folders named, consecutively within each other, Documents 

and Settings > [your name] > Application Data > Microsoft > Word > 

Startup. (On a Macintosh, open Applications > Microsoft Office > Of-

fice > Startup > Word.) 

6. Remove the file named “DEXembed.dot.” 

7. Restart Microsoft Word. 
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3 Quick-Start 

Here, in a nutshell, are the basic steps in embedding an index using DEXem-

bed. These are not the complete instructions, but they are included here to give 

you a quick idea of the overall process. You should try working through these 

steps with a short test document before trying DEXembed’s more advanced 

features. 

1. In Microsoft Word, click DEXembed > DEXembed Options. 

2. Under “For locators, use,” select “Paragraph numbers.” Then click the 

OK button. 

3. Open the document into which you want your entries to be embedded. 

4. Click DEXembed > Prepare Document > Add Paragraph numbers. 

5. Using the paragraph numbers as locators, create a brief test index in 

your standalone indexing program (SKY Index, CINDEX, or 

MACREX). 

6. Export the index (using File > Export) as a tab-delimited text (.txt) file 

(Be sure to uncheck “Enclose fields within quotes.”) 

7. In Microsoft Word, open the text file (using File > Open) that you ex-

ported from your indexing program. You should now have two docu-

ments open in Word: (1) your text file and (2) the document with para-

graph numbers. (Alternatively, you can use the original document with-

out paragraph numbers. If you do, skip step 8, just below.) The text file 

must be the active document—that is, the window on top where your 

cursor is placed. 

8. Click DEXembed > Prepare Document > Remove Paragraph num-

bers. 

9. Click DEXembed > Embed from Tab-Delimited File and respond to 

any prompts displayed on your screen. 

10. Click DEXembed > View > Show Index Tags to see the embedded tags 

in your Word document. 



 11 

4 Menus and Features 

After DEXembed is properly installed, you’ll see a DEXembed menu at the top 

of your Microsoft Word window (along with other menu items such as File, 

Edit, View, and so on). In Word 2007, it should appear on the Add-Ins tab. 

Click the DEXembed menu to see and use the features included with DEXem-

bed. These features are explained in this chapter. 

If some of the features aren’t visible on the menu, it’s because Microsoft 

Word is “helpfully” hiding them until you need them. You can get around this 

by double-clicking the DEXembed menu to open it, thus displaying all of the 

menu entries. 

4.1 Set DEXembed Options 

Set DEXembed Options is first on the menu because of its importance; you’ll 

use this feature to control how several other features work. DEXembed will 

remember the options you select as the default. 
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4.1.1 “For locators, use: . . .” 

For locators, you can use word numbers, paragraph numbers, or page numbers 

in your standalone indexing software, such as SKY Index. The type of locator 

you choose here will be reflected in other program features, such as “Get 

Locator,” “Find Locator,” and “Embed from Tab-Delimited File.” 

If you select “Add comment when getting locator,” and you use DEXembed 

to get a locator from selected text in your reference document, then a Microsoft 

Word comment showing the locator will be placed in the document. 

“Require chapter designators for multiple chapters” allows you to embed 

from a single SKY index file into multiple Word documents. If you want to do 

this, you must include a 2-digit chapter designator at the beginning of each 

locator or range in the Sky file, like this: 

Washington, George 03.250-257 

Here, “03” is the chapter designator. The index would also include entries for 

other chapters: 

Valley Forge 04.12-13, 05.17 

Cherry tree, story of 07.31-32 

For the embedding to work properly, the name of the file into which such an 

entry is to be embedded must also begin with the corresponding 2-digit chapter 

designator. In this example, the corresponding chapter files might be named 

like this: 

03.Early_Life.doc 

04.Valley_Forge.doc 

07.The_Presidency.doc 

The point of all this is that it allows you to build an index of the entire book 

in your standalone indexing program even though the Word chapters to be 

embedded are separate documents. 

Note: If you have an entire book in one document, you won’t need this fea-

ture and therefore should not include chapter designators in your locators or 

filenames. 

For more on locators, see the chapter titled “Locators.” 
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4.1.2 “Mark ranges automatically with: . . .” 

Use these options to have DEXembed mark ranges when it embeds your 

entries. 

4.1.2.1 Automatically Named Bookmarks 

The “Bookmark” option marks a range of text by applying an automatically 

named Microsoft Word bookmark to that text. Then if you or your client need 

to generate the index in Word, the word processor will display page ranges in 

the index. Bookmarks are, in fact, Microsoft Word’s way of determining page 

ranges. If the Word file and its entries will be imported into a typesetting 

program such as QuarkXPress, FrameMaker, or InDesign, you should not, in 

most cases, use this option.  

4.1.2.2 Codes 

If you mark ranges with codes, DEXembed will embed each entry twice, one 

with the beginning range code and the other with the ending range code you 

specified under  DEXembed > Set DEXembed Options, and in the locations 

indicated by your chosen locators (usually paragraph numbers). This is primar-

ily used when your embedded Word documents will be imported into a typeset-

ting program, such as QuarkXPress, InDesign, or FrameMaker, which do not 

easily accommodate page ranges. When the compositor finalizes the pagination 

and generates the index, it will (and should!) include all those doubled entries 

and range codes. (You’ll need to alert the compositor to this fact.) But never 

fear—you can then use DEXembed to remove the extraneous material from the 

final index, leaving single entries with their proper locator ranges (by clicking 

DEXembed > Modify Existing Index > Combine Coded Ranges).  

4.1.2.3 Nothing 

If you like, you can tell DEXembed not to mark ranges at all. In this case, the 

program will simply embed each entry at the location of the first specified 

locator. For example, this entry (using paragraph numbers) would be embedded 

in paragraph 230: 

Washington, Martha 230-232 

For more on ranges, see the chapter titled “Ranges.” 
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4.1.3 Mark Embedded Entries as Tracked Revisions 

Microsoft Word includes the ability to “track” revisions made to a file, usually 

marking additions in blue and deletions in struck-out red. Selecting this option 

means that all embedded entries will be marked as added revisions. This 

provides the advantage of showing the embedded entries in a different color 

than the surrounding text. However, part of the point of using DEXembed is to 

avoid having to deal with Word’s embedded XE (index) tags directly, so for 

much of your work you may not need this feature. 

4.2 Embed from Tab-delimited File 

This feature is DEXembed’s reason for being. The program first collects the 

entries from a tab-delimited text file exported from a standalone indexing 

program. Then it embeds those entries into Word documents based on the 

locators in the tab-delimited file and the locator specified under DEXembed > 

Set DEXembed Options. 

Each tab-delimited entry and its locator must be on a single line that ends in 

a carriage return. For example, entries must look like this: 

Apples 23 

Apples 109 

They must not look like this, with more than one locator on a line: 

Apples 23, 109 

That means you may need to turn off the “merge” facility in your indexing 

software before exporting your index as a tab-delimited file. 

4.3 Prepare Document 

Use these features to prepare a document for indexing: 

4.3.1 Add Paragraph Numbers 

This feature adds the paragraph number—in bold, red, underlined (dotted) 

text—at the beginning of each paragraph. This allows you to identify a para-

graph locator simply by looking at it, and you can then type that locator into 

your indexing program. If you like, you can print the document with the 
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locators and then work from paper as you index rather than working from an 

on-screen reference document. 

4.3.2 Remove Paragraph Numbers 

Don’t want those paragraph numbers anymore? Use this feature to remove 

them. 

4.3.3 Remove Embedded Entries 

Use this feature to remove index entries that were previously embedded in a 

document. 

4.3.4 Remove DEXembed Bookmarks 

If you’ve marked ranges with Word bookmarks using DEXembed, this feature 

removes them but leaves other bookmarks intact. 

4.3.5 Remove Locator Comments 

If you’ve had DEXembed add comments while you were automatically getting 

locators from a reference document, this feature removes them but leaves other 

comments intact. 

4.3.6 Combine Documents 

This feature combines all the documents in a folder you specify into a single 

new blank document (which you must create before using this feature) . The 

documents are combined in alphabetical order, so if your documents are 

named like this— 

1chapter 

2chapter 

3chapter 

—you’ll run into problems if other chapters are named like this: 

10chapter 

11chapter 

12chapter 
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Why? Because they’ll sort alphabetically like this: 

1chapter 

10chapter 

Oops. The solution is to name the single-digit chapters like this: 

01chapter 

02chapter 

03chapter 

Note: When the folder is opened, no files will appear, but don’t worry about 

that. Simply click Open, and the files in the folder will be combined. The folder 

must contain only the files to be combined and no others. 

4.3.7 Split Document 

This feature splits an existing document into automatically named separate 

files, based on any manual page breaks that have been previously inserted into 

the document (via Ctrl + Enter). The resulting new documents will be stored 

in the same folder as the original document. 

4.4 Set StartOfTopic Bookmark 

If you’re using DEXembed to automatically obtain locators from a reference 

document, you can let the program select text for you. To do so: 

1. In a reference document, place your cursor at a point that marks the 

beginning of your selection. 

2. Click DEXembed > Set StartOfTopic Bookmark (or press Ctrl + Alt 

+ M), which will insert a bookmark named StartOfTopic. 

3. Move your cursor however you like as you read through your text. 

4. When you get to a spot that seems like a good ending place for your 

selected text, put your cursor there. 

5. Click DEXembed > Get Locator (or press Ctrl + Alt + L). 

DEXembed will automatically select the text—from the StartOfTopic book-

mark to the position of your cursor—and place the range locators into the 

Clipboard (memory) for pasting into your indexing program. It will then delete 

the StartOfTopic bookmark so you can set it again in a new position. 
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4.5 Get Locator 

This feature identifies and copies the locator for the currently selected text into 

the Clipboard (memory) so you can paste that information into the locator field 

of your standalone indexing software. The steps are: 

1. In your reference document in Microsoft Word, select the text you want 

to index (a selection can be as large or as small as you want; even just 

placing your cursor somewhere in a document counts as a “selection”). 

2. Click DEXembed > Get Locator (or press Ctrl + Alt + L). 

3. Switch to your standalone indexing software. 

4. Paste the locator into the appropriate locator field. 

Note that the locator is based on the kind of locator (word, paragraph, or 

page) you previously selected under DEXembed > Set DEXembed Options. 

4.6 Find Locator 

If you copy the locator from an entry in your standalone indexing software, this 

feature will take you to that locator in your reference document in Microsoft 

Word. The steps are: 

1. In your standalone indexing software, select a locator. 

2. Copy the locator by pressing Ctrl + C (on a Macintosh, press Option + 

C). 

3. Switch to your reference document in Microsoft Word. 

4. Click DEXembed > Find Locator (or press Ctrl + Alt + F). 

DEXembed will find and select the text that corresponds to that locator. 

Note that the locator is based on the kind of locator (word, paragraph, or 

page) you previously selected under DEXembed > Set DEXembed Options. 

Also, if there is no locator in memory, DEXembed won’t take you anywhere. 

4.7 Go to Paragraph Number 

This feature takes you to the paragraph you specify (by number) in your 

Microsoft Word reference document. To use it, press Ctrl + Alt + P. 
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4.8 Display Paragraph Number 

This feature displays the number of the current paragraph (in which your cursor 

is placed) in your Microsoft Word reference document. To use it, press Ctrl + 

Alt + N. 

4.9 View 

4.9.1 Show Bookmarks 

This feature displays bookmark ranges with light-gray square brackets at the 

beginning and end of each range. 

4.9.2 Hide Bookmarks 

This feature hides bookmark ranges.  

4.9.3 Show Index Tags 

This feature shows embedded Microsoft Word index markers (XE field codes). 

4.9.4 Hide Index Tags 

This feature hides embedded Microsoft Word index markers (XE field codes). 

4.10 Generate Index from Embedded Entries 

This feature generates the index at the end of the document, based on the 

embedded entries in the document. If, however, all you see is a code like this 

one— 

{ INDEX \c "2" \z "1033" } 

—don’t panic. That code is, in fact, the index, but it’s being displayed as a field 

code rather than the index text it represents. To solve the problem, right-click 

the field and select Toggle Field Codes. Your index will appear as it should. 

If you change the document and need to regenerate the index, right-click 

anywhere in the index text, click “Update field,” and follow the prompts. 

If you need to turn the generated index text into actual text (no longer gener-

ated by a field and no longer updateable), put your cursor anywhere in the 
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index text and press Ctrl + 6. You can then copy the index text (and only the 

index text; don’t include any returns or breaks before or after the text) and paste 

it into a new document. Be sure to save the document using a different name 

before doing anything else with it (like trying to “round trip” it by converting it 

to a tab-delimited file for use in your indexing software). 

4.11 Remove Generated Index 

If you’ve generated an index to see what it looks like but then want to get rid 

of it, click DEXembed > Remove Generated Index. 

4.12 Modify Existing Index 

4.12.1 Combine Coded Ranges 

If you’ve marked ranges with range codes, and you’ve received a generated 

index from the publisher that includes those codes, you can use this feature to 

delete the codes and combine the locators of the matching entries. 

If you’re combining coded ranges with an index you’ve generated yourself in 

Word, be sure to convert the index into actual text before proceeding. To do so, 

put your cursor anywhere in the generated index. Then press CTRL + 6. 

Important: When combining coded ranges, make sure the only text in your 

document is the index itself; don’t include anything else. 

4.12.2 Fix Orphans 

This feature combines lone subentries with their main entries. For example, 

this: 

Apples 

 in pie, 26 

becomes this: 

Apples, in pie, 26 
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4.12.3 Format Inclusive Locators 

This feature puts inclusive locators (such as 212-214) into the style specified in 

The Chicago Manual of Style (212–14), including an en dash to separate the 

numbers. 

4.12.4 Standardize Styles 

This feature standardizes the paragraph styles used in an existing index. The 

main reason you might want to do that is so you can then convert that index 

into a tab-delimited file that can be imported into your standalone indexing 

software (see below). 

To use the feature, identify the paragraph styles that are used for the different 

levels of an existing index. (You can see them on the left of Word’s Formatting 

toolbar for the text where your cursor is placed.) Then enter the names of those 

styles in the boxes on the left. (The names of the styles are case sensitive, and 

their spelling must be exact, including any spaces.) When you click the OK 

button, the existing styles will be changed to the default styles listed in the 

boxes on the right. 

 

 

You can also convert tabbed indexes to styles: No tab represents a main en-

try, one tab represents a subentry, and so on. 
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4.12.5 Convert to Tab-Delimited File 

This feature converts a previously generated and formatted index back into a 

tab-delimited file that you can import into your standalone indexing software. 

For this to work, the index must be the only text in a Microsoft Word docu-

ment, and it must be formatted with Microsoft Word’s default index paragraph 

styles (Index 1, Index 2, and so on). If the index you need to convert isn’t 

formatted with those styles, you can reformat it by clicking DEXembed > 

Modify Existing Index > Standardize Styles (see above). 

As an example, let’s say you have an existing, formatted index, one that 

looks something like this (run-in or indented, it doesn’t matter): 

Adobe Acrobat, indexing files from, 51 

Angle brackets, in generated index, 47 

AutoCorrect, 58 

Bookmarks: counting, 16; upper limit on, 16; StartOfTopic, 

19; displaying, 28, 37–38; tagging, 56 

Brackets, in generated index, 47 

Capitalizing, headings, 24–25 

But to import into a standalone indexing program, it needs to look like this, 

with tabs separating the parts of an entry: 

Adobe Acrobat indexing files from 51 

Angle brackets in generated index 47 

AutoCorrect 58 

Bookmarks counting 16 

Bookmarks upper limit on 16 

Bookmarks StartOfTopic 19 

Bookmarks displaying 28, 37–38 

Bookmarks tagging 56 

Brackets in generated index 47 

Capitalizing headings 24–25 

To make that happen (after backing up your original file), first convert the 

styles as described above. Then click DEXembed > Modify Existing Index > 

Convert to Tab-Delimited File. (Note that this feature isn’t magic; it can’t 

anticipate every possible variation in structure, which means it may not work 

correctly if your index has unusual formatting or other problems.) 

DEXembed will put the tab-delimited entries into a new document, which it 

will save in text format with a “.dat” extension. Word will probably warn you 
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that “Saving as a text file will cause all formatting, pictures, and objects in your 

file to be lost.” That’s just as it should be, so click OK to save the file. 

After the index has been deconstructed and the file saved, carefully check the 

tab-delimited entries against the original index to make sure the deconstruction 

was successful and accurate. Then save and close the file. 

When you’re finished, you can take a final step: In SKY Index select File > 

Import. In the “file types” dropdown menu, select CINDEX (*.dat). Then 

navigate to where your .dat file is located, select it, and click Open. The index 

will flow into SKY Index, ready for you to perform your final edit. 

4.13 DocBook XML 

The features under this menu make it possible to write an index in a standalone 

indexing program and then embed those entries in DocBook syntax into an 

XML document. They do this without messing up the existing DocBook tags, 

and without any conversion of the tags to Word formatting. 

First, you’ll need to open the XML file as plain text in Word, which is not 

easy unless you know the secret: 

1. In Word, click Tools > Options. (In Word 2007, click the round Office 

button at the top left of your screen. Then click Advanced > Word Op-

tions.) 

2. Click the General tab. 

3. Put a check in the box labeled “Confirm conversion at Open.” 

4. Click the OK button. 

Now when you try to open an XML file, Word will ask you to confirm that you 

want to “Convert file from” XML, and it will show “XML Document” as the 

default selection. Don’t take it. Instead, select “Encoded Text” and click OK. 
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If you don’t, Word will display the XML tags in its own tagged format, which 

is not what you want. Converting as encoded text will bring the document into 

Word with all of the XML tags intact, which is what you want. 

Next, Word will ask what encoding you want to use. Just click OK to accept 

the default encoding of Unicode (UTF-8). 

 

Once you have the document open in Word, with the XML tags showing, do 

not try to save the file. DEXembed will take care of that as you use the follow-

ing features to create and embed your index entries. 

4.13.1 Add Paragraph Numbers to DocBook File 

To use this feature, click DEXembed > DocBook XML > Add Paragraph 

Numbers to DocBook File (not to be confused with DEXembed > Prepare 

Documents > Add Paragraph Numbers). This feature does several things: 

1. It removes carriage returns in any text between paragraph tags: 

<para>like¶ 

this</para> 

2. It removes carriage returns from any text within any kind of tag: 
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<like¶ 

this> 

 Although such carriage returns won’t actually hurt anything as far as 

XML is concerned, they’ll wreak havoc when you’re trying to index us-

ing paragraph numbers as locators—which, by the way, is the only type 

of locator DEXembed will use for DocBook indexing, and it does so au-

tomatically. 

3. It adds a paragraph number in front of each paragraph (except the first) 

in the form of an XML “comment,” so that the numbered paragraphs 

look like this in XML syntax (if you open the file in a text editor): 

<?xml version=“1.0” encoding=“UTF-8”?> 

<!--2--><chapter id=“nch-dates”> 

<!--3-->  <title>Working with Dates and Times</title> 

<!--4-->  <section id=“nch-dates-dates-intro”> 

<!--5-->    <title>Introduction</title> 

4. It saves the document in UTF-8 encoding, adding “for Index” to the 

filename so that “MyChapter.xml” is saved as “MyChapter for In-

dex.xml.” This newly saved file is the one you’ll be using to embed your 

index, and it’s the one you’ll eventually return to your client. Do not use 

the original file, which will be left untouched in its original state. 

5. It closes the document so you don’t have to worry about how to save it 

in the correct encoding. You’ll find the saved document in the same 

folder as your original XML file. 

Now open the saved document (for example, “MyChapter for Index.xml”) in 

a WYSIWYG XML editor, such as the free personal edition of XMLmind 

XML Editor, which you can download here: 

http://www.xmlmind.com/xmleditor/download.shtml 

If you’re using Windows, download and install the “Windows auto-

installable binary distribution, bundled with a private JavaTM 1.6.0_04 

runtime.” 

If you’re using a Macintosh, download and install the “Mac OS X auto-

installable binary distribution.” This version requires Mac OS X 10.4 (Tiger) or 

Mac OS X 10.5 (Leopard) and the latest Apple Java 1.5 runtime. 

Start your XML editor and open your “for indexing” XML file. You should 

see the paragraph numbers preceding each paragraph. In XMLmind, they 
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appear in yellow bands above the paragraphs to which they refer, and you will 

use those numbers as locators while you write your index: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

You’ll probably find that the paragraph numbers are too small for easy refer-

ence. To fix the problem in XMLmind, click Options > Preferences > View 

and set “Default point size” to something big, like 20. While you’re there, you 

may also want to change “Monospaced font family” to a more readable (bold, 

maybe?) font. 

If you get an error message when trying to to open the file in the XML edi-

tor, there’s something wrong in the file, probably with one or more of the XML 

tags. With any luck, your XML editor will tell you what the error is and on 

which line it occurs. If you know what you’re doing, you can open the file in a 

plain-text editor such as the excellent (and free) Notepad++: 

http://notepad-plus.sourceforge.net/uk/site.htm 

(You can set Notepad++ to show the line numbers on the left of the text, 

making it easy to go to the line that has problems.) 

If you don’t know what you’re doing, you probably shouldn’t mess around 

with this, as you could inadvertently break something else in the file. You may 

need to check with an XML expert (such as the client for whom you are 

working). If you can’t resolve the problem, you simply won’t be able to embed 

entries in the DocBook files, and, of course, you’ll need to let your client know 

that. 

Once you’ve successfully opened the file in XMLmind, you can use the par-

agraph numbers displayed there as locators while writing the index in your 

standalone indexing program. 
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CAUTION: Before writing an entire index and embedding all those entries, 

you should always try embedding entries from a short test file. Then open the 

resulting XML file with your XML editor. If the editor gives you an error 

message, the embedding test was not successful, and you should not write the 

index or continue in any way without first resolving the problem, perhaps with 

the help of your client. DEXembed embeds DocBook entries correctly in our 

test documents, but it has not been used extensively in the real world for this 

purpose, and there’s no guarantee that it will work at all. XML can be tricky 

stuff, so test, test, test before proceeding with the real thing. 

4.13.2 Embed Entries for DocBook Index 

After you’ve written your index and exported it as a tab-delimited text file, 

follow these steps to embed your entries: 

1. In Word, use File > Open to open the “for Index” XML file (for exam-

ple, “MyChapter for Index.xml”), using UTF-8 encoding as described 

above. Please do not just double-click the XML file outside of Word. 

2. Open the tab-delimited text file,  accepting the default “Plain Text” en-

coding. 

3. With the tab-delimited file open as the active document, click DEXem-

bed > DocBook XML > Embed DocBook Index Entries to embed the 

entries from the file into the DocBook XML document. 

DEXembed will embed the entries, save the files, and close the files so you 

don’t have to worry about how to save them. 

Although you won’t see the embedded entries unless you open the XML 

document into a text editor, the entries look something like this: 

<indexterm> 

 <primary> 

  Apples 

 </primary> 

 <secondary> 

  in pies 

 </secondary> 

</indexterm> 

DEXembed can convert and embed the following using DocBook tags: 

• Main entries 



 27 

• Subentries 

• Sub-subentries 

• “See” cross-references 

• “See also” cross-references 

• Forced sort for main entries (based on the first character specified as a 

forced sort in your standalone program). 

DEXembed currently does not support special page numbers in bold or italic. 

After the entries have been embedded, DEXembed will (1) remove the para-

graph numbers added earlier and (2) save and close the document ready for 

your client to use. 

Note: When embedding DocBook index entries, DEXembed ignores the 

options set under DEXembed > Set DEXembed Options (except for “Use 

chapter designators for multiple chapters”). It automatically uses paragraph 

numbers as locators and handles ranges using DocBook syntax. 

4.13.3 Remove Entries for DocBook Index 

This feature removes existing DocBook index tags. 

4.13.4 Remove Paragraph Numbers from DocBook 
File 

This feature removes paragraph numbers that were previously added to the 

DocBook file. 

4.14 Register DEXembed 

DEXembed will stop working after its 45-day trial period. Clicking this feature 

explains how to purchase a license to use DEXembed so it will continue to 

work without limitation. 

4.15 About DEXembed 

Displays the current version of DEXembed and its registration status. 
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5 Keyboard Shortcuts 

DEXembed includes useful keyboard shortcuts to help you work more effi-

ciently: 

 

Feature Shortcut 

Set a bookmark (named StartOfTopic) at the 

beginning of a passage to be indexed. 

Ctrl + Alt + M 

Get the locator for the selected text and place it 

in memory so it can be pasted into a standalone 

indexing program. 

Ctrl + Alt + L 

Find and select the text corresponding to the 

locator in memory (copied from a standalone 

indexing program). 

Ctrl + Alt + F 

Display the number of the current paragraph. Ctrl + Alt + N 

Go to and select the paragraph you specify (by 

number). 

Ctrl + Alt + P  
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6 Locators 

DEXembed can embed entries based on three kinds of locators: 

• Word numbers 

• Paragraph numbers 

• Page numbers 

But only one kind at a time, please. 

The locators are listed in the options dialog in order of their precision. If you 

use word numbers, the entries will be embedded exactly before the words 

indicated by your locators. (Unfortunately, word locators can be ungainly; in a 

large document, they can get quite long.) If you use paragraph numbers, the 

entries will be embedded in the paragraphs indicated by your locators. If you 

use page numbers, the entries will be embedded in the pages indicated by your 

locators. (Unfortunately, page locators are not very precise; after the embedded 

entries have been imported into a composition program like QuarkXPress, the 

pagination will almost certainly change, making some of your page locator 

entries inaccurate.) 

With paragraph numbering, the embedded tags will be placed five words into 

the first line of the designated paragraph, and in the case of a range of pages, 

several words in from the paragraph marking the end of the range. (This helps 

keep typesetters from inadvertently deleting them.) For most purposes, para-

graph numbers offer a nice balance between the need for precision and ease of 

use, and they are the recommended option for use with DEXembed. 

DEXembed makes it possible to select text and then press a key combination 

(Ctrl + Alt + L) to automatically obtain a locator that you can then paste into 

your standalone indexing program. The kind of locator you’ll get is determined 

by your selection under DEXembed > Set DEXembed Options. 

If you check the box labeled “Add comment when getting locator,” a Mi-

crosoft Word “comment” that includes the locator will be added to your Word 

document; you may find this convenient for quick reference. 

If you check the box labeled “Require chapter designators for multiple chap-

ters,” you are telling DEXembed that you are planning to embed entries in 

multiple documents from a single tab-delimited file, which indicates that 

you’ve added a two-digit chapter number to the front of each locator in your 

index and to the front of the name of each Word file so that DEXembed will 

know in which document to embed each entry.  
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Marking entries as a range of locators (for example, 323-327) can be done in 

two different ways: 

• Bookmarks. 

• Codes (range codes). 

If you select “Bookmarks,” DEXembed will add uniquely named Microsoft 

Word bookmarks that span the range indicated by your locators. For example, 

if an entry specifies paragraph locators 3-5, then the third, fourth, and fifth 

paragraphs in your document will be marked with a bookmark named zzz3-5. 

The “zzz” is added to differentiate DEXembed bookmarks from other book-

marks that may already be in the document, and to force Word to sort them at 

the bottom of the bookmark list (under Insert > Bookmark). 

If you select Codes, DEXembed will create two entries for each index entry 

in your tab-delimited file, one at the beginning and one at the end of the range 

specified by your locators, with the first entry using the “Start code” and the 

second using the “End code” that you’ve specified. This is an important feature 

because it enables publishers to generate indexes with page ranges in 

QuarkXPress, InDesign, and FrameMaker without the difficulties that usually 

occur with bookmarks. Then, after a publisher sends you the generated index 

for final editing (as a Word file, not a PDF), DEXembed will properly combine 

the paired entries and eliminate the range codes as part of the final editing 

process.1 

You can also elect not to mark ranges at all, and in spite of tradition, many 

indexers now consider this to be a legitimate option. After all, most readers 

simply go to the first page in an index range and then read from that point, so it 

can be persuasively argued that the second locator in a range does little more 

                                                 
1 Please note that combining range codes will work correctly only on actual 

text and not on a generated index field. You can usually tell if your index is a 

field by placing your cursor anywhere in the index text. If the entire index turns 

gray, it’s a field. Before combining coded ranges, you must convert that field to 

actual text. To do that, put your cursor anywhere in the index; then press CTRL 

+ 6. The index field will be converted into actual text, and combining coded 

ranges should work correctly. Also, when combining coded ranges, make sure 

the only text in your document is the index itself; don’t include anything else. 

(Combining coded ranges is really intended for use with an index generated by 

the publisher in a composition program such as InDesign. If you’re generating 

an index in Word, marking ranges with bookmarks is a better option than using 

codes.) 
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than take up unnecessary space and add needless complexity to indexes and to 

indexing procedure. 

6.1.1 Embedding with Multiple Files 

If (and only if) you are going to embed entries from a single index file into 

multiple documents, you must follow these steps: 

1. Click DEXembed > Set DEXembed Options and select “Require chap-

ter designators for multiple chapters.” 

2. Rename your files to include a two-digit chapter number at the begin-

ning of the file name. These two digits must correspond to those used 

with the locators for that chapter in the index to ensure that entries are 

embedded in their proper chapters. For example, if you’re indexing a file 

named MyChapter.doc, you’ll need to rename it to something like 

02MyChapter.doc. There’s no need to do this manually, however. A 

number of free renaming programs are available. One of the best is Flex-

ible Renamer, which can be downloaded here: 

http://hp.vector.co.jp/authors/VA014830/english/FlexRena 

3. In your index file, start each locator with a two-digit number specifying 

the chapter into which that entry will be embedded, followed by a peri-

od. For example, a locator for paragraphs 10 through 12 in chapter 3 

would look like this: 

03.10-12 

   Note that  “03.” occurs only before the first number in the range and is 

not repeated in front of the second. A range locator should never look 

like this: 03.34–03.78. This is true whether you use page, paragraph, or 

word numbering. 

     When you use chapter designators for embedding in multiple files, all 

cross-references (such as See, See also, and See under) must also be pre-

ceded by the two-digit chapter number and period in the page field of 

SKY Index. This is necessary in order to embed them properly in the 

relevant chapter. Thus, a cross-reference will look like this: 

03.See also dogs. 

       Tip: You can avoid the extra keystrokes (03.) simply by entering the 

locator numbers by themselves and then, after indexing the chapter, add 
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the chapter prefixes automatically. The tutorial below explains how to do 

this in SKY Index. 

But remember: You’ll need to do all of this only if you’re embedding entries 

from a single index into multiple files. If the entire book is simply in one file, 

you won’t need to use chapter designators at all. 

6.2 Method 1: Working from Printed Pages 

Some indexers prefer to work from printed pages. If you’re one of them, here’s 

how to do that. (Note: Using paragraph numbers as locators is the only option 

that allows this.) 

1. Click DEXembed > Set DEXembed Options > Paragraph Numbers. 

2. Open the chapter to be indexed. 

3. In the DEXembed drop-down menu select Prepare Document > Add 

Paragraph Numbers. DEXembed will place paragraph numbers to the 

left of every paragraph. 

4. Print the document. 

5. Use the paragraph numbers as locators in SKY Index. They can be typed 

directly into the page field. 

6.3 Method 2: Working On Screen 

You can also work on screen, switching back and forth between the Microsoft 

Word document and your indexing program (press Alt + Tab or click the 

appropriate program window). If you have two monitors or a single wide-

screen monitor—22” or 24” monitors work best—you can index on screen 

without switching—highly recommended. 

Working on screen also allows you to avoid typing complex entries by copy-

ing and pasting from Word directly into SKY Index or other standalone index-

ing program. In fact, on many mice now available, you can program two 

buttons for copy and paste and perform these actions directly from the mouse 

(if you’re a rodent lover!). 

With this method you also have the option of obtaining paragraph or other 

locators automatically. You can do that in three ways: 

1. Place your cursor in any paragraph of the document and press Ctrl + Alt + 

L (L for locator). DEXembed will automatically place the locator for that 

paragraph into the clipboard, ready to be pasted into the locator field in 

SKY Index or other indexing program. 
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2. For ranges, place your cursor at the beginning of the text to be selected. An 

easy way to select text is to hold down the SHIFT key and move your cur-

sor to the end of the text you want to select. You can also select text with 

your mouse (two clicks for a word, three clicks for a paragraph), or you can 

click at the beginning of the text, hold down SHIFT, and then click at the 

end of the text. With the text now selected, press Ctrl + Alt + L, and the 

full range locator will automatically be placed on the clipboard, ready to be 

pasted into your indexing program. 

3. You can also let DEXembed select text for you: 

A. Place your cursor at a point in a reference document that you know 

marks the beginning of your selection. 

B. Press Ctrl + Alt + M to set the StartOfTopic bookmark. 

C. Move your cursor to the end of your selection and press Ctrl + Alt + L. 

DEXembed will automatically select the text—from the StartOfTopic 

bookmark to the position of your cursor—and place the locator on the 

clipboard. It will then automatically delete the bookmark so you can set 

it again in a new position. 

6.3.1 Word number locators 

This option will embed tags exactly where you place your cursor in the Word 

document (between words, not characters). When using this option, you must 

work on screen. If necessary, you can still print out pages for reference, but you 

can obtain locators only by using Ctrl + Alt + L as described above. 

6.3.2 Locating Text from a Locator 

If you copy a locator from SKY Index into your clipboard and then insert your 

cursor anywhere in the Word document and press Ctrl + Alt + F, DEXembed 

will find the corresponding text in your reference document. Note that this is 

based on the locator type selected under DEXembed > Set DEXembed 

Options. 

6.3.3 Locating Paragraphs in Word Files 

There are two very useful keyboard shortcuts if you are indexing with para-

graph numbers: 

• Ctrl + Alt + P (go to paragraph number—if you know the number): the 

paragraph will be selected. 
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• Ctrl + Alt + N (display paragraph number): shows the number of the 

paragraph where the cursor is located. 

These two commands come in handy during both the indexing and editing 

processes. 

6.3.4 Cross-References 

DEXembed places cross-reference embedded tags at the end of the Word 

chapter, several words in from the end of the last paragraph. Some publishers 

require special formatting of these tags (for importing into a layout program), 

which can easily be accomplished with Word’s Find and Replace feature.  

Note: Most layout programs don’t handle embedded cross-reference tags 

well and thus require cleanup in the final generated index. A clever way to 

completely avoid this is to place your cross-reference at the end of the relevant 

entry and not in the page field. Thus your entry (main or sub) might look like 

this in SKY Index, CINDEX, or MACREX: 

Opera singers. See divas. 

In other words, add “. See divas” directly to the main entry or subentry rather 

than placing it in the page (locator) field. 

The embedded tag will look just like that, and QuarkXPress or FrameMaker 

will read it as a single entry. If you don’t like the way this looks in your index-

ing program, you can enter your cross-references in the usual way, since 

DEXembed has another great feature that will clean up the final Quark or 

Frame-generated output later on. 
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7 Ranges 

In embedded indexing, the term range takes on a somewhat different meaning 

than in conventional indexing where you are using page numbers as locators. 

Since you want the embedded tags that define a range to translate into cor-

rect pagination when the pages are composed in the layout program, and since 

you also want to take into account any possible reflow of text during layout or 

in a later revised version, a range can encompass one or more paragraphs as 

well as one or more pages. This is up to the discretion of the indexer and the 

requirements of the publisher. (In the final generated index, of course, locators 

will be displayed as page numbers, even if you’re using paragraph numbers as 

locators while writing your index.) 

Microsoft Word uses bookmarks to define ranges, but bookmarks create 

problems when imported into layout programs like QuarkXPress, FrameMaker, 

or InDesign, and most publishers don’t want anything to do with them. But 

without bookmarks, how can these programs recognize index ranges? 

As described earlier, many publishers have adopted a system of using arbi-

trary codes to signify the beginning and end of a range. Thus, DEXembed 

allows the indexer to create such coded entries (and tags) without ever having 

to type a single code. The process is fully automated. 

When you Set DEXembed Options at the start of a project, you will enter 

the begin and end range codes you wish to use. Some indexers use BEG and 

END. Others use RRA and RRZ or something similar. The only rule when 

using DEXembed is that the start-of-range code must alphabetically precede 

the end-of-range code (as in the examples given here). Once this option is set, 

DEXembed will automatically add these codes and a unique numerical value to 

all embedded index tags (even those without ranges). 

The embedded tags you would see in the Word file for the main entry “dogs” 

would look something like this: 

{ XE "dogs|72BEG, 8" } 

{ XE "dogs|72END, 8" } 

Note that there are two tags here even though there is no range, and 

that’s the way it’s supposed to be. DEXembed creates these double 

entries to facilitate the cleanup later. 

The tags for the main entry “animals,” with a subentry for “dogs,” and a 

range of 8-12, would look something like this: 
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{ XE "animals:dogs|72BEG, 8" } 

{ XE "animals:dogs|72END, 12" } 

This all occurs automatically in the embedding process. When the final index 

is generated in the layout program (QuarkXPress, FrameMaker, or InDesign) 

and returned to you as a Word file for final editing, it will have the correct final 

pagination but still contain the codes. It will look something like this (where 

BEG and END, for example, were the range codes used): 

dogs|72BEG, 8 

 beagles|86BEG, 12 

 beagles|86END, 14 

 collies|345BEG, 9 

 collies|345END, 9 

 pinschers|45BEG, 10 

 pinschers|45END, 10 

dogs|72END, 16 

canines" \t "See dogs, 120 

Note: DEXembed automatically adds the pipe symbol (vertical line), the 

unique numerical identifiers, and the designated codes during the embedding 

process to facilitate the cleanup process that follows. 

The stray characters and extraneous locator in the See reference is typical of 

what QuarkXPress generates from cross-references. If the compositor has not 

cleaned this up (usually not), DEXembed will. If another composition program 

produces other extraneous material, you’ll need to use Word’s Find and Re-

place feature to eliminate it. 

7.1 Range Code Cleanup 

DEXembed has a feature that automatcially removes range codes, properly 

combines the locators, and cleans up the stray characters and locators in the 

cross-reference entries—all at once! Click DEXembed > Modify Existing 

Index > Combine Coded Ranges. 

The result, in the case of the above example, will look like this: 

dogs, 8–16 

 beagles, 12–14 

 collies, 9 

 pinschers, 10 

canines. See dogs 
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This feature alone will save a great deal of time so you can focus on substan-

tive editing rather than cleanup editing. 

Note: A few publishers have devised a tool chain of their own that will re-

move the codes and properly combine the locators as part of the layout process 

prior to returning the index to you for editing. In this case, you will have to 

submit your embedded files with the codes in the form the publisher requests. 

A wildcard Find and Replace in Microsoft Word will usually handle this. 

Here’s an example: Suppose the publisher wants you to use BEG and END 

as the range codes. You would enter these under DEXembed options at the start 

of the process and proceed normally. Now, let’s say the publisher already has a 

process in place that will clean up those codes during the layout process and 

therefore needs to see only those codes and nothing else in the embedded tags. 

In that case, after embedding, run the following wildcard Find and Replace 

on the file before sending it back. (Click Edit > Replace. If the “More” button 

is showing, click it. Put a check in the box labeled “Use wildcards.”): 

In the Find What box, enter this (note the initial pipe symbol): 

|[0–9]{1,} 

In the Replace With box, enter nothing (in other words, make 

sure the box is empty). Then click Replace All. 

That would change all the tags from this: 

dogs|65BEG and dogs|65END 

to this: 

dogsBEG and dogsEND 

Please see “Editing the Final Index” later in this guide for 

a more detailed discussion of the final editing process. 
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8 Error Log 

After you’ve embedded entries with DEXembed, the program will create and 

automatically display a log of any errors it encounters, including: 

• The number for the kind of error (for debugging purposes). 

• The row number in the file where the error occurred. 

• The text for the main heading of the entry (e.g., ‘Apples’), in single 

quotation marks. 

Usually errors are caused by an illegal character in the locator, which should 

be composed only of numbers, with a hyphen or en dash to separate number 

ranges. Anything else will cause trouble. 

A typical log entry looks like this: 

 
 Error 13 on entry 1, ‘Apples.’ Illegal locator or other 

problem. 

 

The error log also includes the date and time when you started the embed-

ding process: 

 
 DEXembed Error Log 1/23/2008 4:08:21 PM 

 

Using the log, you can locate and correct the offending entries. It’s difficult 

to predict everything that might cause an error. Sometimes you just have to 

check for anything that looks fishy and change it to something else. Be sure to 

close the error log before running DEXembed again. 

DEXembed will delete the existing error log each time you embed entries, so 

if you want to keep a certain log, you should rename it, possibly using the date 

and time as part of the filename. The log is automatically saved to your Docu-

ments folder. 
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9 Embedding for LaTeX 

You can use DEXembed to embed index entries into a Word document for 

conversion into the LaTeX typesetting system—if you or your clients are 

planning to convert the document using one of the following programs (both 

available at no charge): 

 

Writer2LaTeX (which is also included as a built-in export filter with 

OpenOffice.org’s Writer program): 

 

www.hj-gym.dk/~hj/writer2latex/ 

 

WordML2LaTeX: 

 

www.ctan.org/tex-archive/support/WordML2LaTeX/ 

 

Both do a fairly good job of converting Word documents into LaTeX, in-

cluding embedded index entries. (Other converters may also work.) However, 

they won’t convert the more esoteric “switches” available in Word index 

entries, such as forced sorts. As long as you stick to such basics as main entries, 

subentries, cross-references, and locators, you should be okay. (Please consult 

the most recent program documentation for a full description of what can be 

converted.) As with everything else, be sure to run the process on test docu-

ments before proceeding with the real thing. 
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10  Tutorial 

This tutorial uses SKY Index for the examples given. Any of the functions 

described here can most likely be duplicated in CINDEX or MACREX. 

The organization of files, folders, naming conventions, and so on, are an 

individual choice, and the examples given here are simply how this indexer 

(Ron Strauss) decided to organize his work. 

10.1 Step One: Organize Files and Folders 

If your publisher’s work flow is such that you are sent one or two Word chap-

ters at a time to index and embed, then set up three folders for the book, naming 

them as follows: 

• Original Word Files. 

• Embedded Word Files. 

• Index files. This will contain the exported tab-delimited files for each 

chapter. 

10.1.1 Master File. 

You will also create a SKY Index “Master file,” which you can name with the 

book title, ISBN number, or any other convenient designation. The “Master 

File” will contain your growing cumulative index in SKY Index. 

You index each chapter in the SKY Index Master file (using the form of 

locator you chose under Set DEXembed Options) just as you would in a non-

embedded index. If you will be embedding in multiple files, your must prefix 

the locators with their two-digit chapter numbers so DEXembed will know 

which entries are associated with which Word chapters (see step 3 below). 

Some indexers may prefer to index each chapter in a separate SKY Index 

file, save those files, and then later merge them into a Master file in order to see 

the whole index as it grows. To do this in SKY Index, click Files > File Man-

agement > Merge. 
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10.2 Step Two: Back Up Files 

Make copies of the original Word files as you receive them. Always work with 

these backups of your original files. Place the backups on your desktop or in a 

folder where they won’t get confused with the originals. 

10.3 Step Three: Rename Files 

If you’ll be embedding entries in multiple files, rename the backup copies by 

adding the two-digit chapter number to the beginning of the name. 

Examples: 02.SmithCh02, or 03_SmithCh03, or 04Smith. 

The two-digit number of the chapter must occupy the first two places in the 

file name. (The rest of the file name is irrelevant to DEXembed.) This is critical 

to the embedding process. You can delete these initial digits from the file name 

after the files are embedded. Front-matter chapters (preface, etc.) can be named 

with 00, appendixes named with consecutive numbers following the last 

chapter (e.g., appendix A might start with 22 if there are 21 chapters in the 

book; appendix B would start with 23, etc.). 

Page Numbering. It does not matter to DEXembed whether the pages of your 

Word documents are numbered or not. Some publishers request that you 

number the pages in some form prior to indexing. 

10.4 Step Four: Set Options and Preferences 

Set the following Preferences and Options in both Word and SKY Index before 

proceeding: 

10.4.1  In Word: 

If you want the index tags to show up in red or some other color for rapid 

identification, click Tools > Options > Track Changes > Insertions and set to 

a Color. This and most other options set in Word will become the default until 

you change them. 

10.4.2  In SKY Index: 

1. Click Options > Index Options > Locators tab. Set the chapter input 

and output separator to a period and check the checkboxes for “Chap-
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ters” and “In page Runs Only.” Set the page-range style to “Simple.” 

This will produce the SKY Index locators and corresponding index file 

in the form required by DEXembed. 

2. Click Options > Index Options > Locators tab > Volume Separators 

> Input & Output and set the separator to a colon (:) or something oth-

er than a period. 

3. Groups > Define. Under Name, type “Current Chapter” (or something 

similar). Uncheck all fields except “Page.” Under “Pattern,” enter !. 

(an exclamation point followed by a period). You will use this later on to 

group all the entries for a currently indexed chapter prior to exporting 

from SKY Index. 

4. After setting these (and any other) options in SKY Index, export a Sky 

Index “options template” and name it “Embedding” or whatever name 

will remind you to import this template at the start of an embedded in-

dexing project—or chapter (if you are creating separate SKY Index files 

for each chapter). 

10.5 Step Five: Set Form of Locator 

Open the book or chapter in Word. From the DEXembed dropdown menu 

select Set DEXembed Options and choose “Page numbers,” “Paragraph 

numbers,” or “Word numbers,” depending on the type of locator you wish to 

use. Your selection will become the default in DEXembed until you change it. 

The locator option you choose must be used throughout the project. Obviously, 

you cannot combine two of these numbering options in the same project. See 

the Locators section of this guide for a detailed explanation of locator usage. If 

you’re embedding index entries from a single index file into multiple chapters, 

put a check in the box labeled “Require chapter designators for multiple 

chapters.” Of course, for this option to work, your locators and filenames must 

actually include chapter designators. For more information, see section 6.1.1, 

“Embedding with Multiple Files.” 

10.6 Step Six: Set Form of Ranges 

In Set DEXembed Options, under “Mark ranges automatically with,” select 

“Automatically named bookmarks,” “Codes,” or “Nothing.” If you’ve selected 

Codes, enter the specific start and end range codes to be used. See the “Ranges” 

section in this guide for further explanation. 
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10.7 Step Seven: Clean Up Original File 

If there are a lot of tracking changes and/or commenting in the document, 

launch the “Reviewing” toolbar (right-click on any tool bar) and select “Final 

Markup” to minimize their visibility. If there are old XE indexing tags in the 

document to be removed, select Prepare Document > Remove Embedded 

Entries from the DEXembed menu. Or you can search and replace (Find: ^d 

XE Replace: Nothing). Number the pages if necessary or directed to do so by 

the publisher. Save the document. 

10.8 Step Eight: Number Paragraphs 

 In step three above, if you selected Paragraph Numbers, now select Prepare 

Document > Add Paragraph Numbers from the DEXembed menu. All the 

paragraphs in the document will be numbered in the left-hand margin. DO 

NOT SAVE. You will index from this numbered document, but you will embed 

into the document saved in step 7 above. 

10.9 Step Nine (optional): Print Document 

Print the paragraph-numbered document—unless you will be working on-

screen with Word and SKY Index open simultaneously. After printing, close 

the document without saving. 

10.10 Step Ten: Index Chapter 

Index the chapter in your SKY Index “Master File,” typing paragraph numbers 

directly into the Page field, or using Ctrl + Alt + L (perhaps first using Ctrl + 

Alt + M [mark range]) to get single or range locators automatically copied 

directly to your clipboard. Paste the locator(s) into the Page field in SKY Index. 

If you will be embedding into multiple files, everything in the page field 

(locators and cross-references) must be preceded by the two-digit chapter 

number. Sky Index can add these automatically at the end of each chapter (see 

9.10.2 below) 

10.10.1 Cross-References 

As mentioned above, if you will be embedding into multiple files, then when-

ever you enter a See or See also cross-reference in SKY Index’s page field, 
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always prefix the See with the two-digit chapter number followed by a period. 

For example, for chapter 3, “03.see also . . .,” or for chapter 21, “21.see . . .” 

The cross-references will thus embed in the chapters in which you created 

them. You can make this a keyboard shortcut if you like for each chapter. If 

you use Ctrl + Alt + L to get your locators, the two chapter digits will automat-

ically be included in the locator (except for cross-references). 

10.10.2 Adding Two-Digit Chapter Designators 

If you choose to enter the paragraph numbers manually (either from printed 

pages or from the on-screen paragraph-numbered file), you can do all your 

entries without worrying about the two-digit chapter designators and then add 

them at the end as follows: 

1. In SKY Index—Select Groups > Current Chapter (or whatever name 

you chose to define the Group in Step Four above. The !. symbols in the 

Pattern Field will tell SKY Index to group all entries whose locators do 

not have a period. This instantly groups all the entries from your current-

ly indexed chapter as these will be the only ones without the 2-digit pre-

fix (since previously indexed chapters would all have them). Your cur-

rent chapter entries are now isolated (grouped). 

2. In SKY Index—Tools > Add/Remove Volume/Chapter Labels (or Alt 

+ T + V). Check “add” and “chapter” and enter the 2 digit number in the 

“labels” field (no period, just the digits). Press okay and the locators of 

all your grouped entries (except Cross-References) will show the desired 

prefixes. 

3. Then, on the same grouping, for cross-references—Find: “See” and Re-

place: “##.See” (include the period). That will add the desired prefixes 

to all cross-references in the group. These steps take a matter of seconds 

at the end of indexing each chapter. 

10.11 Step Eleven: Edit Chapter 

At this point this indexer sometimes likes to return to “As Entered” mode in 

SKY Index and quickly scan to see how the newly indexed chapter entries fit in 

with the rest of the index. One might also group the current chapter entries 

again in alphabetical order (now you can “Group by Chapter Number”—Ctrl + 

Alt + H in SKY Index), and do a quick edit on them. Performing mini-edits on 

these chapters prior to embedding may be something you will want to do as a 
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routine with each chapter in order to save time in the final edit phase. Such 

ongoing editing will also help you make consistent entries in future chapters. 

Important: Don’t forget to check your locators for the chapter prefixes at the 

conclusion of indexing each chapter, as this is what differentiates paragraph 42 

in Chapter 01 from paragraph 42 in Chapter 03, for example. And DEXembed 

needs to know this, of course, when it comes time to embed. 

See the Locators section in this guide for an explanation of the other locator 

types if you prefer not to use paragraph numbers. 

10.11.1  Indexing Tips 

1. Use Sub-entries as much as possible to qualify mains that seem to be 

broad enough to warrant subs (a standard indexing practice). 

2. Most publishers do not want tags placed in heads or subheads, captions, 

tables, figure reference fields, or figure captions. A safe bet is to always 

embed your tags in body text and nowhere else. 

3. A very useful keyboard shortcut in SKY Index, Ctrl + Alt + U, will 

refresh the Auto-Complete feature to account for any changes, corrected 

typos, etc. Using this command at regular intervals can save a lot of typ-

ing. 

4. If you are a mouse lover, the Microsoft IntelliMouse, Logitech Laser 

mice (and many others) have programmable buttons. Setting one button 

for copy, another to paste, and another to cut is invaluable, particularly if 

working on-screen, where you can cut, copy, and paste complex entries 

(or any entry) directly from Word to SKY Index without letting go of the 

mouse (helps eliminate typos). 

10.12 Step Twelve: Export the Index File 

The index file is what DEXembed uses to embed the Word document. In order 

to export only the entries for a particular chapter, follow these steps in SKY 

Index: 

1. Group the entries for a particular chapter using Ctrl + Alt + H. Leave 

the “Volume” field blank and enter the 2-digit chapter designator in the 

“Chapter” field (no period). Click OK and all the entries from that chap-

ter will be grouped and ready for export. 

2. File > Export will bring up the export dialog. Select TEXT format. This 

will give you a tab-delimited file (.txt), which is exactly what you want. 

Also, be sure to uncheck “Enclose fields within Quotes.” You can name 
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the text file anything you like but include the chapter number for future 

reference. So you might name it Ch03IDX or Ch03TDF (for tab-

delimited file). Save to a convenient place like your desktop. For con-

venience we will refer to this as an “index file” throughout this Guide. 

10.13 Step Thirteen: Embed the File 

Important—Follow These Steps Exactly: 

1. Open the (non-numbered) original file you just indexed in Word. If you 

accidentally embed the numbered file, don’t forget to remove the num-

bers with Prepare Document > Remove Paragraph Numbers on the 

DEXembed menu before submitting your file! 

2. Open the index file. You now have two Word windows open. 

3. With the index file as the active window, select Embed from Tab-

Delimited File from the DEXembed menu (in the index file toolbar, not 

the chapter toolbar).  

This will automatically embed the index tags in the Word document and 

simultaneously add the range codes you chose in step 4. There will be no 

bookmarks in these tags unless you told DEXembed to mark ranges with 

bookmarks under Set DEXembed Options. 

Note on Placement of Tags: Word automatically places all cross-references 

at the end of the document. To avoid any possibility of losing tags, DEXembed 

places all the cross-references several words into the last paragraph of the 

document. 

Important Note: When using paragraph numbers as locators, DEXembed 

automatically places index tags four or five words in from the start of a para-

graph and, for ranges, several words in from the end of the last paragraph in the 

range. Therefore try to use paragraphs that are at least eight words long for 

your embedding. 

10.14 Step Fourteen: Saving and Renaming 

Save and rename the Word file (Save As), adding a suffix to the file name such 

as IND (for Indexed) or EMB (for Embedded) and deleting the two-digit 

chapter prefix you added in Step Two. 
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10.15 Step Fifteen: Checking Tags 

Briefly scroll through the now-embedded file, spot-checking to see that the tags 

are in the right places and have the codes appended to the entries. DEXembed 

is very accurate, but we suggest this quick review as you may find something 

you wish to change or add. Also, if you made an entry error in a SKY Index 

locator field, the tag might be in a place other than where you intended it. If 

you should move or change a tag, make the corresponding locator change in 

your SKY Index file. 

10.16 Step Sixteen: Organize Your Files 

1. Store the index file in the dat folder you created in Step One. 

2. Before sending the embedded file off to the publisher, make a copy of it 

for the Embedded Files folder you created in Step One. 

10.17 Step Seventeen (optional): Preview 
Word-Generated Index 

This step is not usually necessary, but if you ever want to preview a given 

chapter’s index entries as generated by Word: 

1. Click DEXembed > View > Hide Index Tags. 

2. Click IDEXembed > Generate Index from Embedded Entries > OK. 

3. Look through the index as needed. 

4. Delete the index at the end of the document before sending the docu-

ment to the publisher. 

See also “Previewing the Combined Index in Word” in this guide. 

10.18 Step Eighteen: Final Editing 

When all chapters have been indexed, sent off, laid out, and the final index 

generated, your client should send you a Word file (in rare cases a PDF) to edit. 

Please see the following section. 
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11 Editing the Generated Index 

Editing the final index is a tricky business in embedded indexing. The approach 

to your final edit depends on the workflow of your publisher. There are three 

basic scenarios: 

11.1 Scenario 1: Changes in the final edit must be 
made in the embedded tags themselves 

If the embedded files have not yet gone to layout and you are given access to 

them after completing the indexing, you can perform your final edit in SKY 

Index and re-embed the entries into the Word chapters. Your SKY Index file 

contains the index for the entire book, and the locator prefixes indicate which 

chapter each entry came from (which is how DEXembed knows where to 

embed the tags). 

Thus, after your final edit you can generate a new index file for the entire 

book and use it to quickly re-embed all the files, one at a time.  

But first you must select Prepare Document > Remove Embedded Entries 

from the DEXembed menu to remove the previously embedded tags from each 

file. Then select “Embed from Tab-Delimited File” on the DEXembed menu 

to re-embed the file. 

11.2 Scenario 2: Changes apply only to the 
printed book index and will not require 
changing embedded tags 

In this scenario you should receive a Word file (generated by the layout pro-

gram) which now has the correct pagination. The range codes and possibly 

other extraneous characters will still be part of this document. Here is the clean-

up/final edit process: 

1. DEXembed can clean up this file in short order. Click DEXembed > 

Modify Existing Index > Combine Coded Ranges. This feature will 

eliminate all the range codes, combine the appropriate locators with an 

en dash, and clean up cross-reference debris left over from QuarkXPress 

in particular. The file should then be reviewed for any other anomalies 

left over from the layout program, and corrected. 
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2. At this point, the Word file can either be edited in Word directly or pre-

pared for import back into SKY Index, where it is much more efficient 

to perform the final edit. In order to import your index back into SKY 

Index you must first convert it to a tab-delimited table. This is described 

in sections 4.13.4 and 4.13.5 above and repeated here for emphasis and 

further detail. 

For example, let’s say you have an existing, formatted index, one that looks 

something like this (run-in or indented, it doesn’t matter): 

Adobe Acrobat, indexing files from, 51 

Angle brackets, in generated index, 47 

AutoCorrect, 58 

Bookmarks: 

 counting, 16 

 upper limit on, 16 

 StartOfTopic, 19 

 displaying, 28, 37–38 

 tagging, 56 

Brackets, in generated index, 47 

Capitalize or lowercase a word, 34 

Capitalizing, headings, 24–25 

You will have to “deconstruct” that index into a tab-delimited file in order to 

import it into CINDEX, MACREX, or SKY Index. In other words, you want it 

to look like this (with tabs between the elements): 

Adobe Acrobat indexing files from 51 

Angle brackets in generated index 47 

AutoCorrect58 

Bookmarks counting 16 

Bookmarks upper limit on Bookmarks 16 

Bookmarks StartOfTopic 19 

Bookmarks displaying 28, 37–38 

Bookmarks tagging 56 

Brackets in generated index 47 

Capitalize or lowercase a word 34 

Capitalizing headings 24–25 

In order for DEXembed to make this conversion, the index levels must be 

formatted as follows: Index 1 (for Mains), Index 2 (for Sub-1s) and Index 3 (for 
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Sub-2s). DEXembed will do this for you. Select Modify Existing Index > 

Standardize Styles. Enter the names of the existing styles and click OK. 

DEXembed will replace those styles throughout the index. 

To ascertain what the names of the existing styles are, place your cursor over 

any main, sub-1 or sub-2 and note the name of its style in the Styles task pane. 

Once DEXembed has standardized the styles, you are ready to deconstruct 

your index (after backing up your original file, of course). Select Modify 

Existing Index > Convert to Tab-Delimited File. DEXembed will convert 

your index into, believe it or not, a .dat file (plain text)! The file will open 

automatically. Check it carefully against the original index to make sure the 

deconstruction was successful and accurate and the formatting is correct. Save 

it to your desktop or other convenient location and close the file. 

Now the final step: In SKY Index select File > Import. In the “file types” 

dropdown menu select CINDEX (*.dat). Then navigate to where your .dat file 

is located, select it, and click open. The index will flow into SKY Index with all 

the elements neatly placed in the correct fields, ready for you to perform your 

final edit. 
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12 Editing Microsoft Word Index Tags 

12.1 Tag Syntax 

At times you may want to edit a few tags directly in an embedded Word 

document. These tags can be edited, copied, cut, and pasted. Here is their exact 

format: 

{ · XE · "dogs" · } Main entry = dogs 

{ · XE · "dogs:poodles" · } Main entry = dogs, Sub1 = 

poodles 

{ · XE · "dogs:poodles" · \t · 

"See · canines" · } 

Cross-Reference (See and See 

also) 

 

The dots (for purposes of illustration) indicate spaces, and the colon indicates 

sub-headings. The beginning and ending braces are part of the index-entry field 

and cannot be typed in by hand. If you try doing so, your index entry will be 

ignored. 

12.2 Special Characters in Tags 

Since colons and quotation marks are part of Word’s syntax for index tags, if 

you have either of these characters in the text of your entry you will have to ask 

your publisher how to handle them (particularly if these files will be imported 

into a layout program). 

The solution used when indexing directly in Word (when Word will generate 

the index) is to “escape” those characters by inserting a backslash ( \ ) before 

any colon or quote mark in the entry. Word will then treat those characters as 

part of the entry text. 

Examples: 

{ · XE · "\"All About Dogs\"" · } 

{ · XE · "FileMaker Pro\: For Dummies" · } 

DEXembed automatically escapes those characters for you as it embeds your 

entries. There’s no need for you to do it manually. 
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12.3 Forced Sorts 

This is another point to check with your publisher. 

Let’s say you have an entry like “10” and you want it to sort under “T” (for 

“ten”) in the index. Again, if indexing directly in Word, you would use a semi-

colon ( ; ) to force the sort, like this: 

{ · XE · "10;ten" · } 

The entry will appear in the index as it looks before the semicolon, but it will 

sort as it looks after the semicolon. This will work for a Word-generated index 

but may not work for an index generated by Quark, PageMaker, or InDesign. 

Check with your client. 

In your indexing software (SKY, CINDEX, etc.), if you enclose part of a 

heading in angle brackets, DEXembed will automatically add the necessary 

forced sort during the embedding process. For example, let’s say you have the 

following entry in your index and in your exported, tab-delimited file: 

<The >Ghost in the Machine 123 

DEXembed will embed that entry like this: 

{ · XE · "The Ghost in the Machine;Ghost in the Ma-

chine" · } 

After the index is generated, the entry will look like this: 

The Ghost in the Machine 123 

But it will be sorted like this: 

Gargoyles, 480 

The Ghost in the Machine, 123 

Granite, 76 

12.4 Attributes on Locators 

Microsoft Word provides two “switches” that you can use in an XE field to 

format the locator for that entry as bold or italic. To format the locator as bold, 

use the \b switch. To format the locator as italic, use the \i switch. For example, 

the field { XE "Highlighting text" \b } displays the entry as “Highlighting text, 

23” in the index. 
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You probably don't want to insert the \b switches by hand. You can work 

around the problem by using a unique code in your index heading to indicate 

bold. For example, if your heading is "Mona Lisa," you could code the heading 

like this: 

Mona Lisa+% 

After embedding, the entry will look like this: 

{ XE "Mona Lisa+%" } 

At that point (after embedding), you can use Word's Find and Replace fea-

ture to remove the code and insert the \b switch. Here's how: 

1. In Word, press CTRL + H to display the Replace dialog. 

2. In the “Find what” box, enter this: 

+%^034 

3. In the “Replace with” box, enter this (be sure to enter a space before the 

backslash): 

^034 \b 

4. Click the “Replace all” button. 

Now your embedded entry will look like this: 

{ XE "Mona Lisa" \b } 

And when you generate the index, the entry will look like this: 

Mona Lisa, 232 
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13 Previewing the Developing Index in Word 

If you ever need to preview your compiled index in Word at any stage of 

development: 

• For a single chapter, simply insert a page break after the end of the text 

(Insert > Break > Page Break) and then click Insert > Reference > Index 

and Tables, and click OK on the Index tab. The index appears at the end of 

your Word document. 

• To view the combined index for a number of Word chapters: 

1. Set up some sort of convenient page numbering if the chapters are not 

already sequentially numbered (e.g. Chapter 1 starting at 101, Ch. 2 

starting at 201, etc.) 

2. In the same file folder as your chapters, create a new Word document 

that will hold the combined index. 

3. In the index document, set up an RD (“referenced document”) field for 

each chapter to be covered by the index: 

a. Click Insert > Field > RD. 

b. Under “Field properties,” type filename (e.g., 

ch01.doc). 

c. Under “field options,” select “Path is relative to current 

doc.” This will insert an RD field, which looks like this: {RD 

"ch01.doc" \f} 

4. Repeat these steps for each chapter you want to include in the index, or 

copy and paste the entire tag (including the brackets) and manually edit 

the filename so it looks like this: {RD "ch01.doc" \f}{RD 

"ch02.doc" \f}, and so on. Use one RD field per chapter, and list 

each chapter sequentially (ch01.doc before ch02.doc, etc.) 

5. Generate the index by placing the cursor at the end of the index file (af-

ter the final bracket) and clicking Insert > Reference > Index and Ta-

bles > OK (on the index tab). This will generate the index, using mark-

ers from all the referenced documents. 

To update the index later on, click to the right of the index and then hit F9, or 

right-click and select Update Field from the pop-up menu that appears. 

If you’re not able to see the RD fields, go to Tools > Options > Formatting 

marks > Hidden text and click the Show > Hide Paragraph Marks button. 
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If you ever want to cut and paste a Word-generated index into its own sepa-

rate file for editing, place the cursor anywhere in the index and type Cntrl-6. 

This will convert the fields into copyable text. 

A way to circumvent this entire process is to make a copy of your embedded 

files and, after numbering the pages in some form of non-overlapping order, 

use DEXembed’s Prepare Document > Combine Documents command. This 

will combine the individual files into one file. Once the files are merged simply 

generate the index for the entire file. 
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14 Registering DEXembed 

If you like DEXembed and plan to continue using it, you should purchase a 

license to do so. If you don’t, your copy of the program is for evaluation 

purposes only, and it will stop working after 45 days. After you purchase a 

license to use the program, we’ll send you a password that will unlock the 

program to run without limitation on time or use. 

The terms of your license prohibit you from giving your program password 

to someone else or using it on someone else’s computer. However, you may 

use the password on up to three of your own computers. For example, you 

could install DEXembed and use your password on your computer at work, 

your computer at home, and your laptop. However, you may run the program 

on only one of your computers at a time. If you need to run the program on 

more than one computer at a time (for example, for use by a family member or 

employee), you must purchase another license and get another password for the 

program. This is the honest and legal thing to do. Besides that, we’re a small 

company and need your support. Thanks for your cooperation. 

14.1 Obtaining a Password 

Here’s how to purchase a program license so you can obtain your password: 

1. Click the DEXembed menu at the top of your Word window. 

2. Click “Register DEXembed.” 

You’ll be presented with two options: 

1. Get a password for this computer. 

2. Enter the password for this computer. 

Click option 1, “Get a password for this computer.” Then click “OK.” 

You’ll be presented with two more options: 

1. Register on the Internet (at www.editorium.com). 

2. Register by mail. 

Click the option that meets your needs and follow the instructions on your 

screen. Registering on the Internet offers some distinct advantages: 
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1. You’ll receive your password automatically by return email as soon as 

your payment is processed. If you’re paying by credit card, you’ll re-

ceive your password almost immediately. Just check your email as soon 

as your online registration is complete. 

2. You can make your payment in several different forms: credit card, 

check, or money order. If you don’t pay with a credit card, however, you 

won’t receive your password until after we receive your payment. 

3. You can make your payment in several different ways: on our secure 

online order form, by fax, or over the phone. 

If you’re interested in using a purchase order, please let us know by emailing 

editor@editorium.com. 

If you don’t have access to the Internet, you can still register by postal mail. 

In that case, we’ll send your password by email (if you have it) or postal mail 

after we receive your check or money order and your registration form. If 

you’re registering by mail, the program will create a registration form in 

Microsoft Word. Please fill out the form, using your cursor keys to move from 

item to item. Then print the form and mail it to the address at the top of the 

form. 

14.2 Using Your Password 

Once you’ve received your password from the Editorium, you’ll need to enter it 

into the DEXembed program. To do so: 

1. Click the “DEXembed” menu item at the top of the Word screen. 

2. Click “Register DEXembed.” 

3. Click “Enter the password for this computer.” Then click “OK.” 

The password entry box will appear on your screen. Carefully type the pass-

word into the box labeled “Enter your password.” 

If you have a valid password and type it correctly, the program will tell you 

that your registration was successful. After that, the program will run without 

limitation on time or use. 

Thanks for your support! 
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15 Troubleshooting 

15.1 Macros Are Disabled 

Problem: When you try to open the file to install the program, Microsoft Word 

tells you that “The macros in this project are disabled . . .” 

Solution: Microsoft Word’s macro virus protection is enabled or set to a high 

level of security. To change this: 

In Word 2007 (PC): 

1. Click the round Office button at the upper left of your Word window. 

2. Click “Word Options.” 

3. Click the “Trust Center” button on the left. 

4. Click the “Trust Center Settings” button on the right. 

5. Select “Enable all macros,” which you should change back to your 

previous setting after the installation is finished. 

6. Click the OK button. 

7. Click the next OK button to close the Word Options dialog. 

In Word 2004 (Macintosh): 

1. Click the “Word” menu. 

2. Click “Preferences.” 

3. Click “Security.” 

4. Uncheck “Warn before opening a file that contains macros.” 

5. Click the OK button. 

In Word 2002/XP or 2003 (PC): 

1. Click the “Tools” menu. 

2. Click “Options.” 

3. Click the “Security” tab. 

4. Click the “Macro Security” button (on the lower right). 

5. Click the “Security Level” tab if it’s not already active. 

6. Set your security level to medium and click the OK button. 

7. Click the next OK button to close the Options dialog. 

In Word 2001 (Macintosh): 

1. Click the “Edit” menu. 

2. Click “Preferences.” 

3. Click the “General” tab if it’s not already active. 
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4. Uncheck “Macro virus protection.” 

5. Click the OK button. 

In Word 2000 (PC): 

1. Click the “Tools” menu. 

2. Click “Macro.” 

3. Click “Security.” 

4. Click the “Security Level” tab if it’s not already active. 

5. Set your security level to medium and click the OK button. 

In Word 98 (Macintosh): 

1. Click the “Tools” menu. 

2. Click “Preferences.” 

3. Click the “General” tab. 

4. Uncheck the box labeled “Macro virus protection.” 

5. Click the “OK” button. 

In Word 97 (PC): 

1. Click the “Tools” menu. 

2. Click “Options.” 

3. Click the “General” tab. 

4. Uncheck the box labeled “Macro virus protection.” 

5. Click the “OK” button. 

After installing the program, you may want to reset your security settings to 

their previous state. If you don’t (in Word 2000 through 2003 on PC), any time 

you open a document or template that includes macros, Word will give you the 

choice of whether to disable or enable macros. If the document or template isn’t 

supposed to have macros in it, you should click the “Disable Macros” button, 

because the macros could be a virus. If the document or template is supposed to 

have macros and comes from a source you know is reliable, click the “Enable 

Macros” button so you can run the macros. 

In other versions of Word, you don’t have these options. Macro virus protec-

tion is either on or off. Before turning it off permanently you may want to read 

more about it in Word’s Help file or check with your system administrator. 

If you need more help, please send an email message to: 

support@editorium.com. 
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15.2 You Generated an Index but See Only a Code 

If you generate the index from the embedded entries in your Word document, 

but all you see is a code like this one— 

{ INDEX \c "2" \z "1033" } 

—don’t panic. That “code” is, in fact, the index, but it’s being displayed as a 

field code rather than the index text it represents. To solve the problem, click 

Tools > Options, click the “View” tab, and remove the check from the box 

labeled “Field codes.” Then click OK. Your index will appear. 

15.3 DEXembed Won’t Embed Your Entries 

Make sure your tab-delimited index file is the active document (the one up 

front, with your cursor in it) before trying to embed. If the reference document 

(on the other hand) is active, DEXembed won’t be able to find the entries in 

your index file, because it looks for entries in the active document. 

Also, did you set the option to “Use chapter designators for multiple chap-

ters”? If so, you must include those designators, both in your locators and in 

your filenames. If you don’t, DEXembed won’t embed your entries. For more 

information, please see the “Locators” section in this guide. If you don’t need 

to embed entries from a single index into multiple chapters, simply turn off 

DEXembed > Set DEXembed Options > Use chapter designators for 

multiple chapters. 

15.4 DEXembed Won’t Work at All 

Problem: DEXembed won’t work at all, even though you’ve properly installed 

it as a global template and the DEXembed menu is visible at the top of your 

Word window. 

Solution: You may see this problem if you’re working on documents that 

have been created in other word-processing programs, such as WordPerfect, 

and then opened into Microsoft Word. If that’s the case, you should save the 

documents from the other program into Microsoft Word format before opening 

them into Word. You may also need to use a dedicated document-conversion 

program. 
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15.5 Microsoft Word Crashes 

Problem: Microsoft Word crashes at some point when you’re using DEXem-

bed. 

Solution: Your document may be corrupt. If possible, open the document, 

copy all of its text but the final paragraph mark, and paste the text into a new 

document. 
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16 Any Questions? 

We hope you find DEXembed to be immensely useful. If you have any ques-

tions or comments, please let us know. 

support@editorium.com 

www.editorium.com 

The Editorium provides word-processing tools for editors, writers, and other 

publishing professionals. If you like DEXembed, you may be interested in 

other products from the Editorium. You can download fully functioning 

evaluation copies of these programs free of charge from the Editorium’s site on 

the World Wide Web at www.editorium.com. 
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17 Terms of Agreement 

By using DEXembed, you agree to these terms: 

 

LICENSE AGREEMENT 

The DEXembed software and its documentation (collectively the Software) 

are protected by the United States copyright laws and international treaties and 

are owned solely and entirely by the Editorium. 

You (the licensee) may run the Software on up to three computers (but only 

on one at a time) during its evaluation period and (if you purchase a license to 

do so) after that. You may not copy or sell the Software for commercial gain. 

You may freely transfer copies of the Software to others for evaluation. 

You may NOT let someone else use your password for the Software or rent or 

lease your license to run it, but you may transfer the license to someone else 

who accepts this agreement. 

You may not modify, reverse engineer, decompile, disassemble, unencrypt, 

or create derivative works from the Software. You may not use the Software in 

any manner that infringes the intellectual property or other rights of another 

party. 

DISCLAIMER OF WARRANTY AND LIABILITY 

The Editorium disclaims all warranties on the Software, expressed or im-

plied, including but not limited to warranties of merchantability and fitness for 

any particular application, use, or purpose. You use it at your own risk. 

Under no circumstances, including its own negligence, shall the Editorium or 

its suppliers be liable for any special, incidental, or consequential damages or 

loss that result from the use of, or the inability to use, the Software. 

This agreement shall be construed, interpreted, and governed by the laws of 

the State of Utah in the United States of America.  
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