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1 About IndexDeconstructor 

IndexDeconstructor is a Microsoft Word add-in created specifically to meet the 
needs of indexers who use standalone indexing programs (such as SKY Index, 
CINDEX, and MACREX), and who need to “desconstruct” an existing index 
into a tab-delimited file that can be imported into one of thes programs. 
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2 Installing or Uninstalling 

IndexDeconstructor is a collection of macros in a template. You don’t use the 
template as you would an ordinary one by attaching it to a document. If you try 
to do that, you’ll run into problems. Instead, you “add” it to Microsoft Word as 
a global template or add-in (see the installation instructions below). 

Because the template contains macros, some virus-checking programs or 
even Word itself may warn you that the template could contain Word viruses. 
Please rest assured that it does not. The macros have been carefully checked 
and tested to make sure they are safe and usable. To ensure your security, you 
should download the program directly from the Editorium website at 
www.editorium.com. 

Please do not rename any of the IndexDeconstructor macros, copy them to 
another template, or remove them from the IndexDeconstructor template. 
IndexDeconstructor uses these macros in combination and won’t work properly 
if they have been copied to another template or renamed, or if some of the 
macros are no longer present. 

2.1 Installing IndexDeconstructor 

To install the program (please read carefully): 

1. Unzip (or unstuff) the program files so that they’re all together in a 
single folder or on your desktop. (If you need software to unzip or un-
stuff the program, you can download it from www.winzip.com or 
www.aladdinsys.com.) You cannot install the program by just opening 
the zip file and double-clicking one of the files. Most likely, however, 
you can open the zip file and drag the files out to your desktop. 

2. After the files are unzipped, open the file named “Install IndexDecon-
structor.dot” in Microsoft Word by clicking File > Open, selecting the 
file, and clicking the Open button. Do not open the file by double-
clicking it outside of Microsoft Word. If you do, you’ll run into problems 
later. 

3. If Word asks if you want to “enable macros” when opening the file, your 
answer should be yes. Otherwise, the program won’t work. If Word tells 
you that the macros have been disabled, you’ll need to change your 
macro security settings and then restart Word before installing. Please 
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see the “Troubleshooting” section at the end of this document for in-
structions. 

4. Double-click the large button that says “Double-Click here to Install.” 
This will install IndexDeconstructor as a global template or add-in, 
which simply means that the program will be saved to Word’s Startup 
folder and will thus be available any time you start Word. 

5. Restart Word to activate the program and display the IndexDeconstruc-
tor menu at the top of your Word window. In Word 2007, the menu will 
be displayed under Word’s “Add-ins” menu. 

If that doesn’t  work, you can install IndexDeconstructor manually. With 
Microsoft Word closed: 

1. On your computer desktop, double-click My Computer. (On a Macin-
tosh, open your hard drive. Then continue with step 5, below.) 

2. At the top of the window that opens, you’ll see a “Tools” menu. Please 
click that, and then click “Folder Options.” 

3. Click the “View” tab and make sure that “Show hidden files and fold-
ers” is selected. Then click the OK button. 

4. Back in the window for “My Computer,” double-click your local hard 
drive, probably “C.” 

5. Open the folders named, consecutively within each other, Documents 
and Settings > [your name] > Application Data > Microsoft > Word > 
Startup. (On a Macintosh, open Applications > Microsoft Office > Of-
fice > Startup > Word.) 

6. Put the file named IndexDeconstructor.dot into the Startup folder (on a 
Macintosh, into the Startup > Word folder). 

7. Restart Microsoft Word. 

2.2 Uninstalling IndexDeconstructor 

To uninstall the program: 

1. Open the file named “Install IndexDeconstructor.dot” in Microsoft Word 
by clicking File > Open, selecting the template, and clicking the Open 
button. Do not open the file by double-clicking it outside of Microsoft 
Word. If you do, you’ll run into problems later. 

2. If Word asks if you want to “enable macros” when opening the file, your 
answer should be yes. Otherwise, the program won’t work. If Word tells 
you that the macros have been disabled, you’ll need to change your 



 6 

macro security settings in order to use the program. Please see the 
“Troubleshooting” section of this documentation for instructions. 

3. Double-click the large button that says “Double-Click here to Uninstall.” 

If necessary, you can remove the template manually from Word’s Startup 
folder: 

1. On your computer desktop, double-click My Computer. (On a Macin-
tosh, open your hard drive. Then continue with step 5, below.) 

2. At the top of the window that opens, you’ll see a “Tools” menu. Please 
click that, and then click “Folder Options.” 

3. Click the “View” tab and make sure that “Show hidden files and fold-
ers” is selected. Then click the OK button. 

4. Back in the window for “My Computer,” double-click your local hard 
drive, probably “C.” 

5. Open the folders named, consecutively within each other, Documents 
and Settings > [your name] > Application Data > Microsoft > Word > 
Startup. (On a Macintosh, open Applications > Microsoft Office > Of-
fice > Startup > Word.) 

6. Remove the file named IndexDeconstructor.dot. 
7. Restart Microsoft Word. 
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3 Features 

3.1 Standardize Styles 

This feature standardizes the paragraph styles used in an existing index. The 
main reason you might want to do that is so you can then convert that index 
into a tab-delimited file that can be imported into your standalone indexing 
software (see below). 

To use the feature, identify the paragraph styles that are used for the different 
levels of an existing index. (You can see them on the left of Word’s Formatting 
toolbar for the text where your cursor is placed.) Then enter the names of those 
styles in the boxes on the left. (The names of the styles are case sensitive, and 
their spelling must be exact, including any spaces.) When you click the OK 
button, the existing styles will be changed to the default styles listed in the 
boxes on the right. 

 

 
You can also convert tabbed indexes to styles: No tab represents a main en-

try, one tab represents a subentry, and so on. 
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3.2 Convert to Tab-Delimited File 

This feature converts a previously generated and formatted index back into a 
tab-delimited file that you can import into your standalone indexing software. 
For this to work, the index must be the only text in a Microsoft Word docu-
ment, and it must be formatted with Microsoft Word’s default index paragraph 
styles (Index 1, Index 2, and so on). If the index you need to convert isn’t 
formatted with those styles, you can reformat it by clicking IndexDeconstruc-
tor > Modify Existing Index > Standardize Styles (see above). 

As an example, let’s say you have an existing, formatted index, one that 
looks something like this (run-in or indented, it doesn’t matter): 

Adobe Acrobat, indexing files from, 51 
Angle brackets, in generated index, 47 
AutoCorrect, 58 
Bookmarks: counting, 16; upper limit on, 16; StartOfTopic, 
19; displaying, 28, 37–38; tagging, 56 
Brackets, in generated index, 47 
Capitalizing, headings, 24–25 

But to import into a standalone indexing program, it needs to look like this, 
with tabs separating the parts of an entry: 

Adobe Acrobat indexing files from 51 
Angle brackets in generated index 47 
AutoCorrect 58 
Bookmarks counting 16 
Bookmarks upper limit on 16 
Bookmarks StartOfTopic 19 
Bookmarks displaying 28, 37–38 
Bookmarks tagging 56 
Brackets in generated index 47 
Capitalizing headings 24–25 

To make that happen (after backing up your original file), first convert the 
styles as described above. Then click IndexDeconstructor > Convert to Tab-
Delimited File. (Note that this feature isn’t magic; it can’t anticipate every 
possible variation in structure, which means it may not work correctly if your 
index has unusual formatting or other problems.) 

IndexDeconstructor will put the tab-delimited entries into a new document, 
which it will save in text format with a “.dat” extension. Word will probably 
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warn you that “Saving as a text file will cause all formatting, pictures, and 
objects in your file to be lost.” That’s just as it should be, so click OK to save 
the file. 

After the index has been deconstructed and the file saved, carefully check the 
tab-delimited entries against the original index to make sure the deconstruction 
was successful and accurate. Then save and close the file. 

When you’re finished, you can take a final step: In SKY Index, CINDEX, or 
MACREX, select File > Import (or the equivalent). In the “file types” drop-
down menu, select CINDEX (*.dat). Then navigate to where your .dat file is 
located, select it, and click Open. The index will flow into your standalone 
indexing program, ready for you to use. 

3.3 Register IndexDeconstructor 

IndexDeconstructor will stop working after its 45-day trial period. Clicking this 
feature explains how to purchase a license to use IndexDeconstructor so it will 
continue to work without limitation. 

3.4 About IndexDeconstructor 

Displays the current version of IndexDeconstructor and its registration status. 
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4 Registering IndexDeconstructor 

If you like IndexDeconstructor and plan to continue using it, you should 
purchase a license to do so. If you don’t, your copy of the program is for 
evaluation purposes only, and it will stop working after 45 days. After you 
purchase a license to use the program, we’ll send you a password that will 
unlock the program to run without limitation on time or use. 

The terms of your license prohibit you from giving your program password 
to someone else or using it on someone else’s computer. However, you may 
use the password on up to three of your own computers. For example, you 
could install IndexDeconstructor and use your password on your computer at 
work, your computer at home, and your laptop. However, you may run the 
program on only one of your computers at a time. If you need to run the 
program on more than one computer at a time (for example, for use by a family 
member or employee), you must purchase another license and get another 
password for the program. This is the honest and legal thing to do. Besides that, 
we’re a small company and need your support. Thanks for your cooperation. 

Here are the prices for a program license, but these are subject to change 
without notice: 

1 user: $49.95 
2–10 users: $39.95 per user 
11–49 users: $29.95 per user 
50+ users: $19.95 per user 

4.1 Obtaining a Password 

Here’s how to purchase a program license so you can obtain your password: 

1. Click the IndexDeconstructor menu at the top of your Word window. 
2. Click “Register IndexDeconstructor.” 

You’ll be presented with two options: 

1. Get a password for this computer. 
2. Enter the password for this computer. 

Click option 1, “Get a password for this computer.” Then click “OK.” 
You’ll be presented with two more options: 
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1. Register on the Internet (at www.editorium.com). 
2. Register by mail. 

Click the option that meets your needs and follow the instructions on your 
screen. Registering on the Internet offers some distinct advantages: 

1. You’ll receive your password automatically by return email as soon as 
your payment is processed. If you’re paying by credit card, you’ll re-
ceive your password almost immediately. Just check your email as soon 
as your online registration is complete. 

2. You can make your payment in several different forms: credit card, 
check, or money order. If you don’t pay with a credit card, however, you 
won’t receive your password until after we receive your payment. 

3. You can make your payment in several different ways: on our secure 
online order form, by fax, or over the phone. 

If you’re interested in using a purchase order, please let us know by emailing 
editor@editorium.com. 

If you don’t have access to the Internet, you can still register by postal mail. 
In that case, we’ll send your password by email (if you have it) or postal mail 
after we receive your check or money order and registration form. If you’re 
registering by mail, the program will create a registration form in Microsoft 
Word. Please fill out the form, using your cursor keys to move from item to 
item. Then print the form and mail it to the address at the top of the form. 

4.2 Using Your Password 

Once you’ve received your password from the Editorium, you’ll need to enter it 
into the IndexDeconstructor program. To do so: 

1. Click the “IndexDeconstructor” menu item at the top of the Word 
screen. 

2. Click “Register IndexDeconstructor.” 
3. Click “Enter the password for this computer.” Then click “OK.” 

The password entry box will appear on your screen. Carefully type the pass-
word into the box labeled “Enter your password.” 

If you have a valid password and type it correctly, the program will tell you 
that your registration was successful. After that, the program will run without 
limitation on time or use. 

Thanks for your support! 
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5 Troubleshooting 

5.1 Macros Are Disabled 

Problem: When you try to open the file to install the program, Microsoft Word 
tells you that “The macros in this project are disabled . . .” 

Solution: Microsoft Word’s macro virus protection is enabled or set to a high 
level of security. To change this: 

In Word 2007 (PC): 
1. Click the round Office button at the upper left of your Word window. 
2. Click “Word Options.” 
3. Click the “Trust Center” button on the left. 
4. Click the “Trust Center Settings” button on the right. 
5. Select “Enable all macros,” which you should change back to your 

previous setting after the installation is finished. 
6. Click the OK button. 
7. Click the next OK button to close the Word Options dialog. 

In Word 2004 (Macintosh): 
1. Click the “Word” menu. 
2. Click “Preferences.” 
3. Click “Security.” 
4. Uncheck “Warn before opening a file that contains macros.” 
5. Click the OK button. 

In Word 2002/XP or 2003 (PC): 
1. Click the “Tools” menu. 
2. Click “Options.” 
3. Click the “Security” tab. 
4. Click the “Macro Security” button (on the lower right). 
5. Click the “Security Level” tab if it’s not already active. 
6. Set your security level to medium and click the OK button. 
7. Click the next OK button to close the Options dialog. 

In Word 2001 (Macintosh): 
1. Click the “Edit” menu. 
2. Click “Preferences.” 
3. Click the “General” tab if it’s not already active. 
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4. Uncheck “Macro virus protection.” 
5. Click the OK button. 

In Word 2000 (PC): 
1. Click the “Tools” menu. 
2. Click “Macro.” 
3. Click “Security.” 
4. Click the “Security Level” tab if it’s not already active. 
5. Set your security level to medium and click the OK button. 

In Word 98 (Macintosh): 
1. Click the “Tools” menu. 
2. Click “Preferences.” 
3. Click the “General” tab. 
4. Uncheck the box labeled “Macro virus protection.” 
5. Click the “OK” button. 

In Word 97 (PC): 
1. Click the “Tools” menu. 
2. Click “Options.” 
3. Click the “General” tab. 
4. Uncheck the box labeled “Macro virus protection.” 
5. Click the “OK” button. 

After installing the program, you may want to reset your security settings to 
their previous state. If you don’t (in Word 2000 through 2003 on PC), any time 
you open a document or template that includes macros, Word will give you the 
choice of whether to disable or enable macros. If the document or template isn’t 
supposed to have macros in it, you should click the “Disable Macros” button, 
because the macros could be a virus. If the document or template is supposed to 
have macros and comes from a source you know is reliable, click the “Enable 
Macros” button so you can run the macros. 

In other versions of Word, you don’t have these options. Macro virus protec-
tion is either on or off. Before turning it off permanently you may want to read 
more about it in Word’s Help file or check with your system administrator. 

If you need more help, please send an email message to: 
support@editorium.com. 
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5.2 IndexDeconstructor Won’t Deconstruct Your 
Entries 

Before IndexDeconstructor will work, your entries must be styled with 
Word‘s default paragraph styles for index entries: Index 1, Index 2, and so on. 
If your entries are styled in some other way, click IndexDeconstructor > 
Standardize Styles to change them into something IndexDeconstructor can 
use. 

5.3 IndexDeconstructor Won’t Work at All 

Problem: IndexDeconstructor won’t work at all, even though you’ve properly 
installed it as a global template and the IndexDeconstructor menu is visible at 
the top of your Word window. 

Solution: You may see this problem if you’re working on documents that 
have been created in other word-processing programs, such as WordPerfect, 
and then opened into Microsoft Word. If that’s the case, you should save the 
documents from the other program into Microsoft Word format before opening 
them into Word. You may also need to use a dedicated document-conversion 
program. 

5.4 Microsoft Word Crashes 

Problem: Microsoft Word crashes at some point when you’re using IndexDe-
constructor. 

Solution: Your document may be corrupt. If possible, open the document, 
copy all of its text but the final paragraph mark, and paste the text into a new 
document. 
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6 Any Questions? 

We hope you find IndexDeconstructor to be immensely useful. If you have any 
questions or comments, please let us know. 

support@editorium.com 
www.editorium.com 

The Editorium provides word-processing tools for editors, writers, and other 
publishing professionals. If you like IndexDeconstructor, you may be interested 
in other products from the Editorium. You can download fully functioning 
evaluation copies of these programs free of charge from the Editorium’s site on 
the World Wide Web at www.editorium.com. 
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7 Terms of Agreement 

By using IndexDeconstructor, you agree to these terms: 
 
LICENSE AGREEMENT 
The IndexDeconstructor software and its documentation (collectively the 

Software) are protected by the United States copyright laws and international 
treaties and are owned solely and entirely by the Editorium. 

You (the licensee) may run the Software on up to three computers (but only 
on one at a time) during its evaluation period and (if you purchase a license to 
do so) after that. You may not copy or sell the Software for commercial gain. 

You may freely transfer copies of the Software to others for evaluation. 
You may NOT let someone else use your password for the Software or rent or 
lease your license to run it, but you may transfer the license to someone else 
who accepts this agreement. 

You may not modify, reverse engineer, decompile, disassemble, unencrypt, 
or create derivative works from the Software. You may not use the Software in 
any manner that infringes the intellectual property or other rights of another 
party. 

DISCLAIMER OF WARRANTY AND LIABILITY 
The Editorium disclaims all warranties on the Software, expressed or im-

plied, including but not limited to warranties of merchantability and fitness for 
any particular application, use, or purpose. You use it at your own risk. 

Under no circumstances, including its own negligence, shall the Editorium or 
its suppliers be liable for any special, incidental, or consequential damages or 
loss that result from the use of, or the inability to use, the Software. 

This agreement shall be construed, interpreted, and governed by the laws of 
the State of Utah in the United States of America.  


