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Introduction

Thank you for using Puller for Microsoft Word!

Puller copies delimited items (such as bracketed or parenthetical text) from the active document, all open documents, or all documents in a folder. Then it pastes them into a separate document, sorts the entries alphabetically (if you so specify), and deletes duplicate items (if you so specify), providing an alphabetical list of the delimited items you specified. If you need to create a summary of typesetting codes or source citations, you need Puller!

I strongly recommend that you try Puller several times on a variety of test documents until you understand fully how it works and what it can do.

By using Puller, you agree to the terms of agreement found at the end of this document.

Macros and Templates

Puller is basically a collection of macros in a template (named Puller.dot). You don’t use this template as you would an ordinary template by attaching it to a document. If you try to do that, you’ll run into problems. Instead, you “add” it to Microsoft Word as a global template or add-in (see installation instructions below).

Because the template contains macros, some virus-checking programs or even Word itself may warn you that the template could contain Word viruses. Please rest assured that it does not. Our macros have been carefully checked and tested to make sure they are safe and usable. To ensure your security, you should download the program directly from our Web site at www.editorium.com.

Please do not rename any of the Puller macros, copy them to another template, or remove them from the Puller template. Puller uses these macros in combination and will not work properly if they have been copied to another template or renamed, or if some of the macros are no longer present.

Installing Puller

To install the program:

1. Unzip (or unstuff) the program files so that they’re all together in a single folder or on your desktop. (If you need software to unzip or unstuff the program, you can download it from www.winzip.com or www.aladdinsys.com.) You cannot install the program by just opening the zip file and double-clicking one of the files.
2. After the files are unzipped, open the file named “Install Puller.dot” in Microsoft Word by clicking File > Open, selecting the file, and clicking the Open button. Do not open the file by double-clicking it outside of Microsoft Word. If you do, you’ll run into problems later.

3. If Word asks if you want to “enable macros” when opening the file, your answer should be yes. Otherwise, the program won’t work. If Word tells you that the macros have been disabled, you’ll need to change your macro security settings and then restart Word before installing. Please see the “Troubleshooting” section at the end of this document for more information.

4. Double-click the large button that says “Double-Click here to Install.” This will install Puller as a global template or add-in, which simply means that the program will be saved to Word’s Startup folder and will thus be available any time you start Word.

5. Restart Word to activate the program and display the Puller menu at the top of your Word window. In Word 2007, the menu will be displayed under Word’s “Add-ins” menu.
If that doesn’t  work, you can install the program manually. With Microsoft Word closed:

1.
On your computer desktop, double-click My Computer. (On a Macintosh, open your hard drive. Then continue with step 5, below.)

2.
At the top of the window that opens, you’ll see a “Tools” menu. Click that, and then click “Folder Options.”

3.
Click the “View” tab and make sure that “Show hidden files and folders” is selected. Then click the OK button.

4.
Back in the window for “My Computer,” double-click your local hard drive, probably “C.”

5.
Open the folders named, consecutively within each other, Documents and Settings > [your name] > Application Data > Microsoft > Word > Startup. (On a Macintosh, open Applications > Microsoft Office > Office > Startup > Word.)

6.
Put the file named “Puller.dot” into the Startup folder (on a Macintosh, into the Startup > Word folder).

7.
Restart Microsoft Word.

Uninstalling Puller

To uninstall the program:

1. Open the file named “Install Puller.dot” in Microsoft Word by clicking File > Open, selecting the template, and clicking the Open button. Do not open the file by double-clicking it outside of Microsoft Word. If you do, you’ll run into problems later.

2. If Word asks if you want to “enable macros” when opening the file, your answer should be yes. Otherwise, the program won’t work. If Word tells you that the macros have been disabled, you’ll need to change your macro security settings in order to use the program. Please see the “Troubleshooting” section of this documentation for more information.

3. Double-click the large button that says “Double-Click here to Uninstall.”

If necessary, you can remove the template manually from Word’s Startup folder:

1.
On your computer desktop, double-click My Computer. (On a Macintosh, open your hard drive. Then continue with step 5, below.)
2.
At the top of the window that opens, you’ll see a “Tools” menu. Click that, and then click “Folder Options.”
3.
Click the “View” tab and make sure that “Show hidden files and folders” is selected. Then click the OK button.

4.
Back in the window for “My Computer,” double-click your local hard drive, probably “C.”
5.
Open the folders named, consecutively within each other, Documents and Settings > [your name] > Application Data > Microsoft > Word > Startup. (On a Macintosh, open Applications > Microsoft Office > Office > Startup > Word.)
6.
Remove the file named “Puller.dot.”
7.
Restart Microsoft Word.

Using Puller 
To use Puller, follow these steps:

1. Back up your documents—just in case.

2. Click the Puller menu at the top of your Word window.

3. Click Puller. (The first time you run Puller, you will see the terms of agreement for using the program. Please read them carefully. If you agree with the terms, you will be able to use the program. If not, you will not be able to use it.)

5. Select the options you want to use. (See “Puller Options,” below.)

6. Click “OK” to continue. (To quit, click "Cancel.")

Puller Options

Documents to Work On

You can select whether to run your macro on:

1. The active document.

2. All open documents.

3. All documents in a folder.

If you want to use Puller on all the documents in a folder, first make sure only the documents you want it to work on are in the folder. Show all documents (*.*) to be sure.

If you would like Puller to work on all documents in a folder, use the dialog box to carefully select the folder. (Don’t get the wrong one!) Then click “OK.” I recommend using a new folder called “Copy” into which you copy your documents so that your original documents remain intact.

Puller turns off all automacros while it runs.

Items to Pull

You can use Puller to make lists of various kinds of delimited items, including:

1. Items in angle brackets. This option is useful for creating lists of codes in marked-up documents, such as QuarkXPress tags and HTML codes.

2. Items in parentheses. Use this option to create a list of parenthetical source citations, which you can then use in checking consistency, creating a bibliography, and so on. Since Puller eliminates duplicate items, if you see what appear to be two identical items on the list, you can be sure that they’re different in some way. If you can figure out what that is, you’ve removed one more inconsistency from your manuscript.

3. Items in square brackets. I’m not sure what you might have in square brackets, but this option will pull them!

4. Other delimited items. Use this option to specify custom delimiters, such as braces, slashes, or pipe symbols.
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Options

You can also have Puller alphabetically sort the items it pulls, and you can have it delete duplicate sorted items.

Pulling Names in Front of Citations

You may want to use Puller to pull names in front of parenthetical citations, like this:

Smith, Jones, and Hernandez (Studies, 1996).

There’s no easy way to make Puller do this and still allow the compilation of an unsorted list. There is a way around the problem, however, which is to use Word’s Replace feature to put delimiters around the items you want to pull. I recommend using double angle brackets for this purpose. Here’s how to do it:

1. Click the Edit menu.

2. Click Replace.
3. In the Find What box, enter the following wildcard string (the easiest way is to copy it directly from this document):

([A-Z][a-z]@, )@and [A-Z][a-z]@ \(*\)

4. In the Replace With box, enter the following string:

<<^&>>

5. Put a check in the box labeled “Use Wildcards” or “Use Pattern Matching.”

6. Click Replace All.
7. Repeat steps 1 through 6 using the following strings in the “Find What” box:

[A-Z][a-z]@ and [A-Z][a-z]@ \(*\)

[A-Z][a-z]@ \(*\)

Doing this will delimit citations of the following forms:

Smith, Jones, and Hernandez (Studies, 1996). (Actually, any number of names will work here—three, four, five, or whatever.)

Jones and Hernandez (Studies, 1996).

Hernandez (Studies, 1996).

This may delimit some other items too, but that’s okay. You can always edit your final list to include only the entries you need. After you’ve used Puller to pull these items, just use Word’s Find and Replace to replace double angle brackets with nothing in your original document. Or better yet, just don’t save the document after inserting the double angle-bracket delimiters and using Puller.

Utilities

Puller comes with two utility programs:

• Check for Unmatched Delimiters.

• Check for Nested Delimiters.

You’ll find these on the Puller menu.

Check for Unmatched Delimiters checks for unmatched delimiters in the active document. For example, if it finds an opening parenthesis but not a closing one, it will let you know. Then you can fix the problem before running Puller.

Check for Nested Delimiters checks for delimiters within delimiters in the active document. For example, if it finds an opening parenthesis followed by an open parenthesis and then a closing one, it will let you know. Then you can fix the problem before running Puller.

Registering Puller

If you like Puller and plan to continue using it, you should purchase a license to do so. If you don't, your copy of the program is for evaluation purposes only, and it will stop working after 30 days or 1,000 uses, whichever comes first. After you purchase a license to use the program, we'll send you a password that will unlock the program to run without limitation on time or use.

The terms of your license prohibit you from giving your program password to someone else or using it on someone else's computer. However, you may use the password on up to three of your own computers. For example, you could install Puller and use your password on your computer at work, your computer at home, and your laptop. However, you may run the program on only one of your computers at a time. If you need to run the program on more than one computer at a time (for example, for use by a family member or employee), you must purchase another license and get another password for the program. This is the honest and legal thing to do. Besides that, we’re a small company and need your support. Thanks for your cooperation.

Here are the prices for a program license, but these are subject to change without notice:

1 user: $19.95

2-10 users: $14.95

11-49 users: $13.95

50+ users: $12.95

Getting a Password

Here’s how to purchase a program license so you can get your password:

1. Click the Puller menu item at the top of your Word window.

2. Click the “Register Puller” menu item.

You’ll be presented with two options:

1. Get a password for this computer.

2. Enter the password for this computer.

Click option 1, “Get a password for this computer.” Then click “OK.”

You’ll be presented with two more options:

1. Register on the Internet (at www.editorium.com).

2. Register by mail.

Click the option that meets your needs and follow the instructions on your screen. Registering on the Internet offers some distinct advantages:

1. You’ll receive your password automatically by return email as soon as your payment is processed. If you’re paying by credit card, you’ll receive your password almost immediately. Just check your email as soon as your online registration is complete.

2. You can make your payment in several different forms: credit card, check, or money order. If you don’t pay with a credit card, however, you won’t receive your password until after we receive your payment.

3. You can make your payment in several different ways: on our secure online order form, by fax, or over the phone.

If you're interested in using a purchase order, please let us know by emailing sales@editorium.com.

If you don’t have access to the Internet, you can still register by postal mail. In that case, we’ll send your password by email (if you have it) or postal mail after we receive your check or money order and your registration form. If you’re registering by mail, the program will create a registration form in Microsoft Word. Please fill out the form, using your cursor keys to move from item to item. Then print the form and mail it to the address at the top of the form.

Using Your Password

Once you’ve received your password from the Editorium, you’ll need to enter it into the Puller program. To do so:

1. Click the “Puller” menu item at the top of the Word screen.

2. Click the “Register” menu item.

3. Click “Enter the password for this computer.” Then click “OK.”

The password entry box will appear on your screen. Carefully type the password into the box labeled “Enter your password.”

If you have a valid password and type it correctly, the program will tell you that your registration was successful. After that, the program will run without limitation on time or use.

Thanks for your support!

Troubleshooting

Problem: When you try to open the file to install the program, Microsoft Word tells you that “The macros in this project are disabled . . .”

Solution: Microsoft Word’s macro virus protection is enabled or set to a high level of security. To change this:

In Word 2007 (PC):

1. Click the round Office button at the upper left of your Word window.

2. Click “Word Options”.

3. Click the “Trust Center” button on the left.

4. Click the “Trust Center Settings” button on the right.

5. Select “Enable all macros,” which you should change back to your previous setting after the installation is finished.

6. Click the OK button.

7. Click the next OK button to close the Word Options dialog.

In Word 2004 (Macintosh):

1. Click the “Word” menu.

2. Click “Preferences.” 

3. Click “Security.”

4. Uncheck “Warn before opening a file that contains macros.”

5. Click the OK button.

In Word 2002/XP or 2003 (PC):

1. Click the “Tools” menu.

2. Click “Options.”

3. Click the “Security” tab.

4. Click the “Macro Security” button (on the lower right).

5. Click the “Security Level” tab if it’s not already active.

6. Set your security level to medium and click the OK button.

7. Click the next OK button to close the Options dialog.

In Word 2001 (Macintosh):

1. Click the “Edit” menu.

2. Click “Preferences.”

3. Click the “General” tab if it’s not already active.

4. Uncheck “Macro virus protection.”

5. Click the OK button.

In Word 2000 (PC):

1. Click the “Tools” menu.

2. Click “Macro.”

3. Click “Security.”

4. Click the “Security Level” tab if it’s not already active.

5. Set your security level to medium and click the OK button.

In Word 98 (Macintosh):

1. Click the “Tools” menu.

2. Click “Preferences.”

3. Click the “General” tab.

4. Uncheck the box labeled “Macro virus protection.”

5. Click the “OK” button.

In Word 97 (PC):

1. Click the “Tools” menu.

2. Click “Options”.

3. Click the “General” tab.

4. Uncheck the box labeled “Macro virus protection.”

5. Click the “OK” button.

After installing the program, you may want to reset your security settings to their previous state. If you don’t (in Word 2000 through 2003 on PC), any time you open a document or template that includes macros, Word will give you the choice of whether to disable or enable macros. If the document or template isn’t supposed to have macros in it, you should click the “Disable Macros” button, because the macros could be a virus. If the document or template is supposed to have macros and comes from a source you know is reliable, click the “Enable Macros” button so you can run the macros.

In other versions of Word, you don’t have these options. Macro virus protection is either on or off. Before turning it off permanently you may want to read more about it in Word’s Help file or check with your system administrator.

If you need more help, please send an email message to support@editorium.com.

Problem: Puller has been running for hours on just a few short documents.

Solution: Press the Escape key to stop the program. Look at the cursor position in the open document to see if you can figure out what may be causing the problem. If you can, fix the problem before running Puller again. Also, check the documents after the problem document to see if they have the same problem.

Problem: You get weird error messages while running Puller.

Solution: See the solution to the problem above.

Problem: Microsoft Word crashes at some point when you’re running macros on all open documents or all documents in a folder.

Solution: Some of your documents may be corrupt. You can identify a document that caused the crash by reading its name in the bar at the top of the Word window when the program crashes. If possible, open the document, copy all of its text but the last carriage return, and paste the text into a new document.

Any Questions?

We hope you find Puller to be immensely useful. If you have any questions or comments, please let us know.

support@editorium.com

www.editorium.com

The Editorium

P.O. Box 702601

Salt Lake City, UT 84170  USA

The Editorium provides word-processing tools for editors, writers, and other publishing professionals. If you like Puller, you may be interested in these other products from the Editorium:

Editor’s ToolKit Plus includes Editor’s ToolKit, FileCleaner, NoteStripper, and QuarkConverter.

Editor’s ToolKit provides a variety of powerful tools for editing with Microsoft Word.

FileCleaner cleans up common typographical and editorial problems in electronic manuscripts.

NoteStripper converts automatically numbered notes into text notes or vice versa.

QuarkConverter converts Word documents into XPressTag files that can be imported into QuarkXPress.

MegaReplacer finds and replaces multiple words, phrases, and even styles in multiple documents.

You can download fully functioning evaluation copies of these programs free of charge from the Editorium's site on the World Wide Web at www.editorium.com.

This documentation and the Puller software are copyright © 1996, 2000, 2001 by the Editorium. All rights are reserved. Puller, Editor’s ToolKit, FileCleaner, QuarkConverter, NoteStripper, MegaReplacer, and Editorium are trademarks of the Editorium.

All trademarks mentioned in this documentation or the program are acknowledged as trademarks of their owners.

Terms of Agreement

By using Puller, you agree to these terms:

LICENSE AGREEMENT

The Puller software and its documentation (collectively the Software) are protected by the United States copyright laws and international treaties and are owned solely and entirely by the Editorium.

You (the licensee) may run the Software on up to three computers (but only on one at a time) during its evaluation period and (if you purchase a license to do so) after that. You may not copy or sell the Software for commercial gain.

You may freely transfer copies of the Software to others for evaluation. You may NOT let someone else use your password for the Software or rent or lease your license to run it, but you may transfer the license to someone else who accepts this agreement.

You may not modify, reverse engineer, decompile, disassemble, unencrypt, or create derivative works from the Software. You may not use the Software in any manner that infringes the intellectual property or other rights of another party.

DISCLAIMER OF WARRANTY AND LIABILITY

The Editorium disclaims all warranties on the Software, expressed or implied, including but not limited to warranties of merchantability and fitness for any particular application, use, or purpose. You use it at your own risk.
Under no circumstances, including its own negligence, shall the Editorium or its suppliers be liable for any special, incidental, or consequential damages or loss that result from the use of, or the inability to use, the Software.

This agreement shall be construed, interpreted, and governed by the laws of the State of Utah in the United States of America.

October 20, 2001

