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Introduction

Thank you for using MultiMacro for Microsoft Word!

Have you ever had a whole folder full of documents and needed to do something to all of them? Like insert page numbers? Or open each one and paste in a header? Or correct a misspelled address?

MultiMacro lets you do almost anything to all the documents in a folder without going through the laborious routine of opening a document, making the change, saving the document, closing the document, and going on to the next one. Suppose you've written a thirty-chapter book with each chapter in a separate document. Suddenly you realize you need to include page numbers in each chapter. Ordinarily you'd have to open each chapter and insert the page number. Now you can have MultiMacro do the job for you in seconds.

We strongly recommend that you try MultiMacro several times on a variety of test documents until you understand fully how it works and what it can do.

By using MultiMacro, you agree to the terms of agreement found at the end of this document.

Macros and Templates

MultiMacro is basically a collection of macros in a template (named Multimac.dot). You don’t use this template as you would an ordinary template by attaching it to a document. If you try to do that, you’ll run into problems. Instead, you “add” it to Microsoft Word as a global template or add-in (see installation instructions below).

Because the template contains macros, some virus-checking programs or even Word itself may warn you that the template could contain Word viruses. Please rest assured that it does not. Our macros have been carefully checked and tested to make sure they are safe and usable. To ensure your security, you should download the program directly from our Web site at www.editorium.com.

Please do not rename any of the MultiMacro macros, copy them to another template, or remove them from the MultiMacro template. MultiMacro uses these macros in combination and will not work properly if they have been copied to another template or renamed, or if some of the macros are no longer present.

Installing MultiMacro

To install the program:

1. Unzip (or unstuff) the program files so that they’re all together in a single folder or on your desktop. (If you need software to unzip or unstuff the program, you can download it from www.winzip.com or www.aladdinsys.com.) You cannot install the program by just opening the zip file and double-clicking one of the files.
2. After the files are unzipped, open the file named “Install MultiMacro.dot” in Microsoft Word by clicking File > Open, selecting the file, and clicking the Open button. Do not open the file by double-clicking it outside of Microsoft Word. If you do, you’ll run into problems later.

3. If Word asks if you want to “enable macros” when opening the file, your answer should be yes. Otherwise, the program won’t work. If Word tells you that the macros have been disabled, you’ll need to change your macro security settings and then restart Word before installing. Please see the “Troubleshooting” section at the end of this document for more information.

4. Double-click the large button that says “Double-Click here to Install.” This will install MultiMacro as a global template or add-in, which simply means that the program will be saved to Word’s Startup folder and will thus be available any time you start Word.

5. Restart Word to activate the program and display the MultiMacro menu at the top of your Word window. In Word 2007, the menu will be displayed under Word’s “Add-ins” menu.
If that doesn’t  work, you can install the program manually. With Microsoft Word closed:

1.
On your computer desktop, double-click My Computer. (On a Macintosh, open your hard drive. Then continue with step 5, below.)

2.
At the top of the window that opens, you’ll see a “Tools” menu. Click that, and then click “Folder Options.”

3.
Click the “View” tab and make sure that “Show hidden files and folders” is selected. Then click the OK button.

4.
Back in the window for “My Computer,” double-click your local hard drive, probably “C.”

5.
Open the folders named, consecutively within each other, Documents and Settings > [your name] > Application Data > Microsoft > Word > Startup. (On a Macintosh, open Applications > Microsoft Office > Office > Startup > Word.)

6.
Put the file named “Multimac.dot” into the Startup folder (on a Macintosh, into the Startup > Word folder).

7.
Restart Microsoft Word.
Uninstalling MultiMacro

To uninstall the program:

1. Open the file named “Install MultiMacro.dot” in Microsoft Word by clicking File > Open, selecting the template, and clicking the Open button. Do not open the file by double-clicking it outside of Microsoft Word. If you do, you’ll run into problems later.

2. If Word asks if you want to “enable macros” when opening the file, your answer should be yes. Otherwise, the program won’t work. If Word tells you that the macros have been disabled, you’ll need to change your macro security settings in order to use the program. Please see the “Troubleshooting” section of this documentation for more information.

3. Double-click the large button that says “Double-Click here to Uninstall.”

If necessary, you can remove the template manually from Word’s Startup folder:

1.
On your computer desktop, double-click My Computer. (On a Macintosh, open your hard drive. Then continue with step 5, below.)
2.
At the top of the window that opens, you’ll see a “Tools” menu. Click that, and then click “Folder Options.”
3.
Click the “View” tab and make sure that “Show hidden files and folders” is selected. Then click the OK button.

4.
Back in the window for “My Computer,” double-click your local hard drive, probably “C.”
5.
Open the folders named, consecutively within each other, Documents and Settings > [your name] > Application Data > Microsoft > Word > Startup. (On a Macintosh, open Applications > Microsoft Office > Office > Startup > Word.)
6.
Remove the file named “Multimac.dot.”
7.
Restart Microsoft Word.

Using MultiMacro 
Preparation

Before actually running MultiMacro, prepare to use it by following these steps:

1. Back up your documents. MultiMacro is powerful. It will do exactly what you tell it to, and it will do it to all the documents you specify. If you make a mistake, you'll want something to go back to. Please, please believe me.

2. Record a macro that does the task you need done. For complete instructions on recording a macro, see your Word manual or Help file. Here's the basic procedure:


a. Click on the Tools menu.


b. Click “Macro” (and, in Word 97, 98, or 2000, “Record New Macro”).


c. In the Macro Name box, type a name for your macro.


d. Click the “Record” button.


e. Click “OK.” (The Macro Record toolbar will appear on your screen.)


f. Do the things you want your macro to do, such as inserting text, finding and replacing, and so on.


g. Click the “Stop” button on the Macro Record toolbar.

3. Try your macro on some sample files. Make sure it works the way you want it to.

Running MultiMacro

To run MultiMacro, follow these steps:

1. Record or write the macro or macros you want to use.

2. List the names of the macros in a Word document, in the order you want to run them, with each name followed by a carriage return. Your list should look something like this:

Macro1

Macro2

Macro3

(Remember to put a carriage return after the last entry.)

Your list should contain nothing but the names of the macros you want to run. It should not contain headings, explanatory notes, and so on. Be sure to save your list for later use, but leave it open as the active document in Microsoft Word.

3. Click the MultiMacro menu at the top your Microsoft Word window.

4. Click “MultiMacro.” (The first time you run MultiMacro, you will see the terms of agreement for using the program. Please read them carefully. If you agree with the terms, you will be able to use the program. If not, you will not be able to use it.)

5. Select the options you want to use. (See “MultiMacro Options,” below.)

6. Click “OK” to continue. (To quit, click "Cancel." After the program has started, you can press the ESCAPE key to stop it and abort what you were doing, but this will probably leave your documents in a half-finished mess. You made backups, right?)

7. Wait until MultiMacro tells you it's finished.

8. Review your documents as necessary to make sure the changes were made the way you wanted.

MultiMacro Options

Watch MultiMacro at Work

You can watch MultiMacro as it works on your documents. Watching it is more interesting and lets you see what’s going on. Not watching it is faster.

Documents to Work On

You can select whether to run your macro on:

1. The first document after your list of macros. This is the document that would be active if you closed the list. Be careful to get the right document. Better yet, open only one document besides your list so that you don’t accidentally run your macros on the wrong one.

2. All open documents but your list.

3. All documents in a folder.

If you want to use MultiMacro on all the documents in a folder, first make sure only the documents you want it to work on are in the folder. Then you won't inadvertently change, say, some press-ready documents that you have spent many hours editing and formatting. Show all documents (*.*) to be sure. In addition, make sure none of the documents is protected or read only. MultiMacro runs the selected macro on the documents and then saves them. If the documents are protected or read only, MultiMacro will not work.

If you would like MultiMacro to work on all documents in a folder, use the dialog box to carefully select the folder. (Don’t get the wrong one!) Then click “OK.” I recommend using a new folder called “Copy” into which you copy your documents so that your original documents remain intact.

MultiMacro turns off all automacros while it runs.

Planning Your Macros

As you create your macros, keep in mind what MultiMacro does, and the order in which it does it:

1. MultiMacro opens the first (alphabetically) document in the folder you specified.

2. MultiMacro runs the macros in their listed order on that document.

3. If the document has changed, MultiMacro saves it.

4. MultiMacro closes the document.

5. MultiMacro repeats steps 1 through 4 for each remaining document in the folder.

You'll need to plan your macros with great care, keeping these steps in mind. For example, if you open a document, close a document, or switch to a different document somewhere in one of your macros, you may cause problems for MultiMacro. Also, if you run into problems, remember that MultiMacro does exactly what you would do if you opened each document and ran each macro by hand. You can actually do it by hand if you need to see where problems are occurring, and you may need to change your macros to address those problems. MultiMacro doesn’t do anything to the documents but open them, run your macros, and save the documents.

Running Word Commands

Using MultiMacro, you can run Word's built-in commands as well as macros. To do so, type the name of the command in your list of macros. To see a list of Word commands, click the Tools menu and select Macro; then, in the Macros Available In box, select Word Commands. To get a description of what a command does, click on the command name. You can also look up the commands in your Word manual or Help file. Most of the commands are used with a selection of text rather than a whole document, but you may find some of the commands useful for a document as a whole.

Registering MultiMacro

If you like MultiMacro and plan to continue using it, you should purchase a license to do so. If you don't, your copy of the program is for evaluation purposes only, and it will stop working after 45 days or 1,000 uses, whichever comes first. After you purchase a license to use the program, we'll send you a password that will unlock the program to run without limitation on time or use.

The terms of your license prohibit you from giving your program password to someone else or using it on someone else's computer. However, you may use the password on up to three of your own computers. For example, you could install MultiMacro and use your password on your computer at work, your computer at home, and your laptop. However, you may run the program on only one of your computers at a time. If you need to run the program on more than one computer at a time (for example, for use by a family member or employee), you must purchase another license and get another password for the program. This is the honest and legal thing to do. Besides that, we’re a small company and need your support. Thanks for your cooperation.

Here are the prices for a program license, but these are subject to change without notice:

1 user: $29.95

2-10 users: $19.95

11-49 users: $18.95

50+ users: $17.95

Getting a Password

Here’s how to purchase a program license so you can get your password:

1. Click the MultiMacro menu item at the top of your Word window.

2. Click the “Register MultiMacro” menu item.

You’ll be presented with two options:

1. Get a password for this computer.

2. Enter the password for this computer.

Click option 1, “Get a password for this computer.” Then click “OK.”

You’ll be presented with two more options:

1. Register on the Internet (at www.editorium.com).

2. Register by mail.

Click the option that meets your needs and follow the instructions on your screen. Registering on the Internet offers some distinct advantages:

1. You’ll receive your password automatically by return email as soon as your payment is processed. If you’re paying by credit card, you’ll receive your password almost immediately. Just check your email as soon as your online registration is complete.

2. You can make your payment in several different forms: credit card, check, or money order. If you don’t pay with a credit card, however, you won’t receive your password until after we receive your payment.

3. You can make your payment in several different ways: on our secure online order form, by fax, or over the phone.

If you're interested in using a purchase order, please let us know by emailing sales@editorium.com.

If you don’t have access to the Internet, you can still register by postal mail. In that case, we’ll send your password by email (if you have it) or postal mail after we receive your check or money order and your registration form. If you’re registering by mail, the program will create a registration form in Microsoft Word. Please fill out the form, using your cursor keys to move from item to item. Then print the form and mail it to the address at the top of the form.

Using Your Password

Once you’ve received your password from the Editorium, you’ll need to enter it into the MultiMacro program. To do so:

1. Click the “MultiMacro” menu item at the top of the Word screen.

2. Click the “Register” menu item.

3. Click “Enter the password for this computer.” Then click “OK.”

The password entry box will appear on your screen. Carefully type the password into the box labeled “Enter your password.”

If you have a valid password and type it correctly, the program will tell you that your registration was successful. After that, the program will run without limitation on time or use.

Thanks for your support!

Troubleshooting

Problem: When you try to open the file to install the program, Microsoft Word tells you that “The macros in this project are disabled . . .”

Solution: Microsoft Word’s macro virus protection is enabled or set to a high level of security. To change this:

In Word 2007 (PC):

1. Click the round Office button at the upper left of your Word window.

2. Click “Word Options”.

3. Click the “Trust Center” button on the left.

4. Click the “Trust Center Settings” button on the right.

5. Select “Enable all macros,” which you should change back to your previous setting after the installation is finished.

6. Click the OK button.

7. Click the next OK button to close the Word Options dialog.

In Word 2004 (Macintosh):

1. Click the “Word” menu.

2. Click “Preferences.” 

3. Click “Security.”

4. Uncheck “Warn before opening a file that contains macros.”

5. Click the OK button.

In Word 2002/XP or 2003 (PC):

1. Click the “Tools” menu.

2. Click “Options.”

3. Click the “Security” tab.

4. Click the “Macro Security” button (on the lower right).

5. Click the “Security Level” tab if it’s not already active.

6. Set your security level to medium and click the OK button.

7. Click the next OK button to close the Options dialog.

In Word 2001 (Macintosh):

1. Click the “Edit” menu.

2. Click “Preferences.”

3. Click the “General” tab if it’s not already active.

4. Uncheck “Macro virus protection.”

5. Click the OK button.

In Word 2000 (PC):

1. Click the “Tools” menu.

2. Click “Macro.”

3. Click “Security.”

4. Click the “Security Level” tab if it’s not already active.

5. Set your security level to medium and click the OK button.

In Word 98 (Macintosh):

1. Click the “Tools” menu.

2. Click “Preferences.”

3. Click the “General” tab.

4. Uncheck the box labeled “Macro virus protection.”

5. Click the “OK” button.

In Word 97 (PC):

1. Click the “Tools” menu.

2. Click “Options”.

3. Click the “General” tab.

4. Uncheck the box labeled “Macro virus protection.”

5. Click the “OK” button.

After installing the program, you may want to reset your security settings to their previous state. If you don’t (in Word 2000 through 2003 on PC), any time you open a document or template that includes macros, Word will give you the choice of whether to disable or enable macros. If the document or template isn’t supposed to have macros in it, you should click the “Disable Macros” button, because the macros could be a virus. If the document or template is supposed to have macros and comes from a source you know is reliable, click the “Enable Macros” button so you can run the macros.

In other versions of Word, you don’t have these options. Macro virus protection is either on or off. Before turning it off permanently you may want to read more about it in Word’s Help file or check with your system administrator.

If you need more help, please send an email message to support@editorium.com.

Problem: MultiMacro has been running for hours on just a few short documents.

Solution: Press the Escape key to stop the program. Look at the cursor position in the open document to see if you can figure out what may be causing the problem. If you can, fix the problem before running MultiMacro again. Also, check the documents after the problem document to see if they have the same problem. You’ll also need to check your macros carefully to make sure they’re not sending Microsoft Word into a loop.

Problem: You get weird error messages while running MultiMacro.

Solution: See the solution to the problem above.

Problem: Microsoft Word crashes at some point when you’re running macros on all open documents or all documents in a folder.

Solution: Some of your documents may be corrupt. You can identify a document that caused the crash by reading its name in the bar at the top of the Word window when the program crashes. If possible, open the document, copy all of its text but the last carriage return, and paste the text into a new document.

Any Questions?

We hope you find MultiMacro to be immensely useful. If you have any questions or comments, please let us know.

support@editorium.com

www.editorium.com

The Editorium provides word-processing tools for editors, writers, and other publishing professionals. If you like MultiMacro, you may be interested in these other products from the Editorium:

Editor’s ToolKit Plus includes Editor’s ToolKit, FileCleaner, NoteStripper, and QuarkConverter.

Editor’s ToolKit provides a variety of powerful tools for editing with Microsoft Word.

FileCleaner cleans up common typographical and editorial problems in electronic manuscripts.

NoteStripper converts automatically numbered notes into text notes or vice versa.

QuarkConverter converts Word documents into XPressTag files that can be imported into QuarkXPress.

MegaReplacer finds and replaces multiple words, phrases, and even styles in multiple documents.

You can download fully functioning evaluation copies of these programs free of charge from the Editorium's site on the World Wide Web at www.editorium.com.

This documentation and the MultiMacro software are copyright © 1996–2007 by the Editorium. All rights are reserved. MultiMacro, Editor’s ToolKit, FileCleaner, QuarkConverter, NoteStripper, MegaReplacer, and Editorium are trademarks of the Editorium.

All trademarks mentioned in this documentation or the program are acknowledged as trademarks of their owners.

Terms of Agreement

By using MultiMacro, you agree to these terms:

LICENSE AGREEMENT

The MultiMacro software and its documentation (collectively the Software) are protected by the United States copyright laws and international treaties and are owned solely and entirely by the Editorium.

You (the licensee) may run the Software on up to three computers (but only on one at a time) during its evaluation period and (if you purchase a license to do so) after that. You may not copy or sell the Software for commercial gain.

You may freely transfer copies of the Software to others for evaluation. You may NOT let someone else use your password for the Software or rent or lease your license to run it, but you may transfer the license to someone else who accepts this agreement.

You may not modify, reverse engineer, decompile, disassemble, unencrypt, or create derivative works from the Software. You may not use the Software in any manner that infringes the intellectual property or other rights of another party.

DISCLAIMER OF WARRANTY AND LIABILITY

The Editorium disclaims all warranties on the Software, expressed or implied, including but not limited to warranties of merchantability and fitness for any particular application, use, or purpose. You use it at your own risk.
Under no circumstances, including its own negligence, shall the Editorium or its suppliers be liable for any special, incidental, or consequential damages or loss that result from the use of, or the inability to use, the Software.

This agreement shall be construed, interpreted, and governed by the laws of the State of Utah in the United States of America.

