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1. Introducing DEXter
If you’ve tried to do much indexing using Microsoft Word’s built-in indexing feature, you know how cumbersome and inefficient it is. Its drawbacks are legion, but one of the worst is its inability to let indexers see and edit more than one entry at a time. In Word, indexers must work “in the dark,” lacking a comprehensive list of entries for reference.

Dedicated indexing programs, such as Cindex®, Macrex®, and SKY Index®, overcome this limitation but have one of their own—the inability to easily embed index entries into the text of an electronic document. That means if a book’s contents or design changes, the indexer may need to change hundreds of page numbers (although the indexing programs do provide tools to help with that). More serious is the fact that indexing can’t take place until design, editing, proofreading, and corrections are finished, making indexing the last step (and thus a bottleneck) in the production process.

DEXter was created in an attempt to replicate (and, in some ways, improve on) the strengths of dedicated indexing programs while embedding index entries in a Microsoft Word document. It doesn’t embed the entries immediately, however. Instead, it marks your text selections with bookmarks. These bookmarks correspond with index entries you have typed into a separate document containing a multicolumn table, like this:

	Heading
	Subheading
	Index
	Cross-Reference
	Note
	Format
	Page 
	Entry 

	Washington, George
	and Continental Congress
	
	
	
	
	0001
	00001

	Continental Congress
	George Washington and
	
	
	
	
	0002–0003
	00002

	Capital
	
	
	>Washington, D.C.
	
	
	0004
	00003


After you have made and edited all of the entries, DEXter embeds the entries in the publication text, using the bookmarks to automatically generate page numbers.

Professional indexers would refer to DEXter as a tagging program. One of the main advantages of using such a program is that indexing can begin earlier in the production process. That means indexers can have more time to create an index (since they can be working through part of the production process rather than having to wait until the end) and that the overall publishing schedule can be tightened up—often by several weeks.

These instructions assume that you already understand the basics of indexing and of using Microsoft Word. If that is not the case, you should learn more about these things before using this program. Some good places to start include Word’s Help feature and the indexing chapter in the Chicago Manual of Style (the 14th edition is the clearest).
Features
DEXter overcomes many of the drawbacks of Microsoft Word’s indexing features:

 •  You (the indexer) never need to enter, edit, or even look at embedded “XE” entries.

 •  Bookmarks used to specify a range of text are inserted automatically based on the text you have selected.

 •  Index entries are available and visible at all times in an editable, sortable table.

 •  You create and edit index entries directly in the index table rather than in a dialog box or the document being indexed.

 •  Entries are not embedded until all of them have been made and edited, at which point they are embedded automatically, based on the bookmarks in the indexed document.

 •  Entries in the finished index can be sorted letter by letter or word by word.

 •  Subheadings can be sorted by page order as well as alphabetically.

 •  Leading words (such as “in,” “by,” and “of,” specified by you) in subheadings can be ignored in sorting.

 •  Other words or characters (specified by you) can be ignored in sorting.

 •  Words or characters (specified by you) can be sorted as other words or characters.

 •  Words in quotation marks are sorted by letter rather than by punctuation, putting the words where they belong rather than at the start of the index.

 •  Numbers (such as 80806 and 8008808) are sorted properly.

 •  Cross-references are automatically combined and sorted alphabetically.

 •  Page numbers can be sequential (such as 3, 4) or inclusive (such as 3–4), depending on whether you have selected the text sequentially or inclusively.

Dexter provides many other features that make indexing more efficient:

 •  Automatically insert page numbers into the index table for reference, based on the text you have selected. (In dedicated indexing programs, page numbers must be typed.)

 •  Automatically insert selected or copied text as the heading in a new index entry.

 •  Automatically duplicate an existing entry.

 •  Automatically swap heading and subheading when duplicating an existing entry.

 •  While swapping, automatically capitalize the first word of the index heading (optional).

 •  While swapping, automatically lowercase the heading when it becomes the new subheading (optional).

 •  Automatically transpose words. “Washington, George” becomes “George Washington”—or vice versa.

 •  Automatically adjust specified words and capitalization during a swap. “Apples: in pie” becomes “Pie: apples in.

 •  Automatically insert cross-references based on existing headings.

 •  Jump from a table index entry to the corresponding bookmark in the reference document, or from the bookmarked text to the table index entry.

 •  Set a special bookmark at the beginning of a topic. Then, when you put your cursor at the end of the text that discusses that topic, automatically select from your current location back to the bookmark.

 •  Index multiple documents at once.

 •   Compile DEXter’s index table with a dedicated indexing program, such as Cindex, Macrex, or SKY Index.

2. Setting Up DEXter
 XE "Setting up;Settingup:SUB:SUBSUB" \f "testeroo" \r "ZZZDEXterdocumentationdoc00002" You can use DEXter without setting up the following items, but if you do, you’ll miss some of DEXter’s most powerful features. You’ll learn more about these features later in the documentation. For now, please do the following:

 1. Identify and navigate to your documents folder.

Where is your documents folder? On a Windows computer, it’s probably My Documents, located on your Windows desktop. On a Macintosh, it’s probably Documents. You can find out for sure by starting Word from scratch, creating a new document, and clicking File > Save. The folder where Word tries to save the document is your default documents folder.

 2. Find the four text files that came with DEXter. These text files are lists of “stop words” that DEXter uses for the following purposes:

 •  Identify leading words in index subheadings (so they can be ignored in sorting).

 •  Identify other words and characters to ignore in sorting.

 •  Identify words and characters to be sorted as other words and characters.

 •  Identify words to adjust when swapping entries.

The text files are:

 •  DEXterLeadingWords.txt

 •  DEXterIgnore.txt

 •  DEXterSortAs.txt

 •  DEXterSwap.txt

You can (and should) modify these lists to meet your own needs, as explained under “Adjust Sorting with Word Lists.”

 3. Put the four lists into your documents folder. You can always remove them later if you decide not to use them.

 4. Display bookmarks by clicking DEXter > DEXter Tools > Display Bookmarks. This is a toggle that will display or hide bookmarks in the document you’re indexing. The bookmarks will be displayed as square, gray [brackets] at the beginning and end of text you’ve selected and indexed. The brackets will help you see where your text selections begin and end.

 5. Display highlighting by clicking Tools > Options >  View and putting a check in the checkbox labeled “Highlight” (under the “Show” heading). Click OK to finish.

 6. Click DEXter > DEXter Tools > DEXter Options, put a checkmark in both checkboxes, and click the OK button. Again, these features will be explained later in the documentation, and you can always remove the checkmarks later if you decide not to use them.

 XE "Shortcut keys;Shortcutkeys" \r "ZZZDEXterdocumentationdoc00004" 

 XE "Key combinations;Keycombinations" \f "testeroo" \r "ZZZDEXterdocumentationdoc00003"  7. Open and print the document named “FKeys.doc.” (If you have a color printer, the highlight colors on the template will be printed in color.) This document contains a keyboard template that you can (and should) cut off with a pair of scissors and place above the function keys (F1 through F12) at the top of your computer keyboard. The template shows the function keys that can be used to activate DEXter’s features. Note the words SHIFT and CTRL (or OPTION for Macintosh) on the left side of the template. They indicate that you should hold down the SHIFT key or the CTRL key while pressing the function key for the feature indicated. For example, to delete an index entry, you’d hold down SHIFT while pressing F3. Using the keyboard template will help you a lot in both learning and using DEXter. Please don’t overlook it. The template shows (in abbreviated form) the following function-key assignments:

	
	
	CTRL (Macintosh OPTION)
	SHIFT

	F1
	
	Sort index table by heading
	

	F2
	Go2Text
	Sort index table by column containing cursor
	Reassign entry

	F3
	Switch documents
	Sort index table by page
	Delete entry

	F4
	Jump
	Sort index table by entry number
	Swap existing heading and subheading

	F5
	Create new entry
	Capitalize/lowercase
	Highlight in colors selected automatically

	F6
	Create duplicate entry
	Transpose words
	Highlight in gray

	F7
	Create duplicate entry, swapping heading and subheading
	Transpose parenthetical items
	Highlight in yellow

	F8
	Create duplicate entry, swapping heading and subheading lowercased
	Cycle words
	Highlight in cyan

	F9
	Create entry from selection
	Start topic
	Highlight in green

	F10
	Create and transpose entry from selection
	Remove start of topic
	Highlight in magenta

	F11
	Create entry from Clipboard
	Insert “See” cross-reference
	Highlight in red

	F12
	Create and transpose entry from Clipboard
	Insert “See also” cross-reference
	Don’t highlight


The keys you’ll use the most for creating new entries are F5 through F12. DEXter includes other keyboard shortcuts as well (the same on both PC and Mac):

TAB: Move to next cell in table

SHIFT + TAB: Move to previous cell in table

ALT + HOME: Move to first cell in row

INSERT: Create new entry

ALT + INSERT: Reassign entry

ALT + DELETE: Delete entry

SHIFT + CTRL + E: Count entries

SHIFT + CTRL + D: Display bookmarks

SHIFT + CTRL + B: Set StartofTopic bookmark

SHIFT + CTRL + G: Go2Text

SHIFT + CTRL + R: Repeat Go2Text

SHIFT + CTRL + F5: Arrange documents

SHIFT + CTRL + F6: Switch documents

3. Getting Started Fast
 XE "Quick start;Quickstart" \r "ZZZDEXterdocumentationdoc00006" 

 XE "Getting started;Gettingstarted" \r "ZZZDEXterdocumentationdoc00005" To understand everything you can do with DEXter, you’ll need to read all of the program’s documentation. But if you want to get started right away, here are the basic steps:

 1. Make sure DEXter is installed and available. If you see the DEXter menu at the top of your Microsoft Word window, you’re ready to go. (For more information, see the document named “Installing DEXter” that came with the program.)

 2. Make sure no documents are open.

 3. Open a document you want to index. This is your reference document.
 4. Click DEXter > Create Index Document. This will create your index document, with a table where you’ll type your index entries.

 5. Switch back to your reference document. You can switch back and forth between documents by pressing F3.

 6. Select some text for which you want to create an index entry. (An easy way to select text is to hold down the SHIFT key and then press the arrow [cursor] keys as needed.)

 7. Press F5 to create a new entry. This will take you to the index document, create a new row in your index table, and place your cursor at the beginning of the row so you can start typing. (To delete an entry, place your cursor in that entry and press SHIFT + F3 or ALT + DELETE. To duplicate an existing entry, put your cursor in that entry and press F6.)

 8. Type the heading for your index entry (“Washington, George”).

 9. If you want to enter a subheading, press the TAB key to move your cursor to the next cell. Then type the subheading (“and Valley Forge”).

10. If you want to enter a cross-reference, press the TAB key twice to move your cursor to the cross-reference column. Then type the cross-reference. If you want this to be a “See” reference, put a “>” at the beginning of the reference, like this: >Delaware (which will later be converted into “See Delaware”). If you want this to be a “See also” reference, put a “&” at the beginning of the reference, like this: &Delaware (which will later be converted into “See also Delaware”). You can insert a cross-reference automatically (no typing) by moving to a previous entry to which your cross-reference will refer; then press CTRL + F11 (“See”) or CTRL + F12 (“See also”) to automatically copy the heading from that entry to the cross-reference cell in your new entry.

11. When you’re finished with your entry, press F4 to jump back to the selection in your reference document.

12. Repeat steps 6 through 10 until all of your entries are finished. Each time you index a new passage about a previous topic, you should enter that topic again (press F6 to duplicate an existing entry for a new text selection). For example, if you index three passages about George Washington, you might have the following three entries:

Washington, George

Washington, George

Washington, George

Each of those entries will later become an embedded index entry, and they will be combined automatically when you generate your final index.

If you need to sort your index so you can see your headings and subheadings in alphabetical order, press CTRL + F1. To sort by page number, press CTRL + F3. To sort by entry number, press CTRL + F4. To sort by anything else, put your cursor in the column you want to sort by (such as Subheading or Note) and press CTRL + F2. You don’t have to wait until all of your entries are finished before sorting; you can sort any time you need to see your entries in a certain order.

13. Edit your index as needed, changing your entries however you like. This is possible because your entries will not be embedded until after you have DEXter create your index, so feel free. As you edit, however, make sure you don’t change anything in the last two columns, which DEXter needs to create your index. Be especially careful not to do a global find and replace (Edit > Replace) that involves numbers, which could mess up your page and entry numbers.

14. Click DEXter > Check Duplicate Entries to see if you have headings or subheadings that should be identical but are off by a letter or two. The program will color duplicate headings in red and duplicate subheadings in blue, leaving near matches (and unique entries) in black. Look carefully at entries that appear to be the same as adjacent entries but are not colored in red or blue. They probably contain a typographical error. To check headings, press CTRL + F1, which will sort headings together alphabetically. To check subheadings, put your cursor in the second column and press CTRL + F2. Warning: If your index is long, this check may take quite a while. You don’t have to do it if you don’t want to.

15. Click DEXter > Check Cross-References to check for blind cross-references, circular cross-references, and other such problems. Follow the prompts on your screen to correct them. Warning: If your index is long, this check may take quite a while. You don’t have to do it if you don’t want to.

16. Click DEXter > Make My Index and follow the prompts to create your finished index at the bottom of your reference document.

4. Creating an Index Document
 XE "Index;Index:document, creating;00013-00016document,creating" \r "ZZZDEXterdocumentationdoc00007" An index document is the document into which you will type your index entries. It should not be confused with a reference document, which is the document you are indexing, probably the text of a book. Think of the index document as a collection of index cards and your reference document as a set of page proofs. (You can use multiple reference documents at the same time.)

To create an index document:

 1. Make sure DEXter is installed and available. If you see the DEXter menu at the top of your Microsoft Word window, you’re ready to go. (For more information, see the document named “Installing DEXter” that came with the program.)

 2. Open one or more documents you want to index. These are your reference documents that you will use with your index document.

 3. Click DEXter > Create Index Document. This will create your index document, with a table where you’ll type your index entries. When you first create an index document, the table will have only one row, containing the headings of the table columns. (On a PC, the headings will be gray; on a Macintosh, they’ll be black.)

	Heading
	Subheading
	Index
	Cross-Reference
	Note
	Format
	Page 
	Entry 


For ease of reference, this row will be repeated automatically at the top of every page of your index document.

Don’t try to create an index document and table by hand. Why? Because DEXter does more than just create a table; it also sets document properties for later reference. Thus, you should always create an index document by clicking DEXter > Create Index Document.

When you go to use one of DEXter’s features, the program will check to make sure the reference document and index document go with each other. If they don’t, the program will ask you to verify that you want to use them together. This is a protection against using an index document with the wrong reference document. XE "Punctuation;Punctuation:in names of reference documents;00013-00013innamesofreferencedocuments" \r "ZZZDEXterdocumentationdoc00215" 
Warning: The name of a reference document must contain only letters and numbers—no punctuation marks allowed! That’s because DEXter uses the document name as part of the bookmarks it sets, and bookmark names in Word cannot contain punctuation marks. (In actuality, DEXter will work around spaces, apostrophes, hyphens, periods, and lowlines [ _ ], but not around anything else, so please be careful in how you name your reference documents.)

Column Headings
 XE "Column;Column:headings;00013-00016headings" \r "ZZZDEXterdocumentationdoc00008" After you’ve created an index document, you’ll notice that its table includes these column headings:

 •  Heading

 •  Subheading

 •  Index

 •  Cross-Reference

 •  Note

 •  Format

 •  Page

 •  Entry

 XE "Heading column;Headingcolumn" \r "ZZZDEXterdocumentationdoc00016" The Heading column is where you’ll type your heading:

	Heading
	Subheading
	Index
	Cross-Reference
	Note
	Format
	Page 
	Entry 

	Washington, George
	
	
	
	
	
	0001
	00001


 XE "Subheading column;Subheadingcolumn" \r "ZZZDEXterdocumentationdoc00017" In the Subheading column, you’ll type your subheading:

	Heading
	Subheading
	Index
	Cross-Reference
	Note
	Format
	Page 
	Entry 

	Washington, George
	and cherry tree
	
	
	
	
	0001
	00001


You can enter multiple levels of subheadings by separating them with colons (but no space):

	Heading
	Subheading
	Index
	Cross-Reference
	Note
	Format
	Page 
	Entry 

	Washington, George
	and cherry tree:origin of story
	
	
	
	
	0001
	00001


Theoretically, Microsoft Word allows an unlimited number of subheading levels.

 XE "Index column;Indexcolumn" \r "ZZZDEXterdocumentationdoc00018" The Index column allows you to enter a code designating a certain type of index. For example, if you were indexing a poetry anthology, you could enter a “t” for a title-index entry (“Tyger, The”), an “a” for an author entry (“Blake, William”), and an “f” for a first-line entry (“Tyger! Tyger! burning bright”). Later, when you generate your index, you can tell Word to create a separate index for each type. (See “Type of Index.”)

	Heading
	Subheading
	Index
	Cross-Reference
	Note
	Format
	Page 
	Entry 

	Tyger, The
	
	t
	
	
	
	0001
	00001


	Heading
	Subheading
	Index
	Cross-Reference
	Note
	Format
	Page 
	Entry 

	Blake, William
	
	a
	
	
	
	0001
	00002


	Heading
	Subheading
	Index
	Cross-Reference
	Note
	Format
	Page 
	Entry 

	Tyger! Tyger! burning bright
	
	f
	
	
	
	0001
	00003


 XE "See also;Seealso" \t "See Cross-references" 

 XE "See;See" \t "See Cross-references" 

 XE "Cross-reference column;Cross-referencecolumn" \r "ZZZDEXterdocumentationdoc00019" The Cross-Reference column is the place to enter, yes, a cross-reference: “See Honesty.” In DEXter, however, See is indicated with a closing angle bracket: “>Honesty”:

	Heading
	Subheading
	Index
	Cross-Reference
	Note
	Format
	Page 
	Entry 

	Cherry tree
	
	
	>Honesty
	
	
	0001
	00001


 See also is indicated with an ampersand: “&Honesty”:

	Heading
	Subheading
	Index
	Cross-Reference
	Note
	Format
	Page 
	Entry 

	Cherry tree
	
	
	&Honesty
	
	
	0001
	00001


 XE "Note column;Notecolumn" \r "ZZZDEXterdocumentationdoc00022" In the Note column, you can type notes to yourself. These notes will not be included in the finished index or affect it in any way. They’re for your reference only:

	Heading
	Subheading
	Index
	Cross-Reference
	Note
	Format
	Page 
	Entry 

	Sanctum sanctorum
	
	
	
	Check Latin spelling
	
	0001
	00001


 XE "Format column;Formatcolumn" \r "ZZZDEXterdocumentationdoc00023" The Format column allows you to designate the type style in which you want the page number for that entry to appear. If you enter “i” then the page number will be displayed in italic in the finished index. If you enter “b” you’ll get bold, while “&” will produce bold italic.

	Heading
	Subheading
	Index
	Cross-Reference
	Note
	Format
	Page 
	Entry 

	Washington, George
	crosses Delaware
	
	
	
	i
	0001
	00001


 XE "Page column;Pagecolumn" \r "ZZZDEXterdocumentationdoc00025" The Page column displays the page numbers of the text you selected for that entry. Page numbers can accommodate books of up to 9,999 pages. They look like this:

0134

0009–0012

0010

The initial zeroes force Word to sort the numbers correctly in the table if you decide to sort by the Page column.

Page numbers are entered automatically, and they serve two purposes:

 1. As a reference for you.

 2. As the numbers by which subentries will be sorted if you decide to sort subentries by page number.

 XE "Entry column;Entrycolumn" \r "ZZZDEXterdocumentationdoc00026" Finally, the Entry column holds the sequence number for the current entry. For example, your first three entries will be numbered (automatically) like this:

00001

00002

00003

The initial zeroes force Word to sort the numbers correctly in the table.

 XE "Bookmarks;Bookmarks:upper limit on;00016-00016upperlimiton" \r "ZZZDEXterdocumentationdoc00027" The Entry column includes a bookmark for the entry. This bookmark has the same name as the corresponding bookmark in your reference document and is used to match entry to text when the program is generating your index.

Counting Entries

 XE "Entries;Entries:counting;00016-00016counting" \r "ZZZUsingDEXterdoc00235" 

 XE "Limit;Limit:on number of entries;00016-00016onnumberofentries" \r "ZZZDEXterdocumentationdoc00028" 

 XE "Bookmarks;Bookmarks:counting;00016-00016counting" \r "ZZZUsingDEXterdoc00261" Word can handle 16,379 bookmarks, so that’s the upper limit on the number of entries you can have in a single reference or index document. The Entry column shows the number of entries you’ve created for your index, but if you’ve deleted entries (which is likely), it won’t give you an accurate count of how many entries you now have. To get a true count of the number of entries (actually bookmarks) in your table, press SHIFT + CTRL + E. (The StartOfTopic bookmark will not be included in this count).

To count the number of entries (actually bookmarks) in a reference document, switch to that document and, again, press SHIFT + CTRL + E. (This will also give you the average number of entries per page). To count the number of entries in a specific part of a document, select the text whose entries you’d like to count and press SHIFT + CTRL + E. Note that bookmarks you’ve created manually will be included in this count.

Getting Around

 XE "Navigation;Navigation" \r "ZZZDEXterdocumentationdoc00209" 

 XE "Movement;Movement" \r "ZZZDEXterdocumentationdoc00010" 

 XE "Getting around;Gettingaround" \r "ZZZDEXterdocumentationdoc00009" 

 XE "Windows;Windows:arranging;00016-00016arranging" \r "ZZZUsingDEXterdoc00266" 

 XE "Documents;Documents:arranging;00016-00016arranging" \r "ZZZUsingDEXterdoc00267" Now that you have your reference documents and index documents open in Word, you can arrange them side by side or top to bottom for easy reference.

To arrange them side by side:

Click DEXter > Arrange Documents (or press F2).

To arrange them top to bottom:

Click Window > Arrange All.

 XE "Monitors;Monitors" \r "ZZZDEXterdocumentationdoc00014" 

 XE "Dual monitors;Dualmonitors" \r "ZZZDEXterdocumentationdoc00015" If your computer can accommodate dual monitors, you can display the reference document on one monitor and the index document on the other—a convenient way to work. Most laptops have a monitor port into which you can plug an additional monitor. If you don’t have a laptop, you can install an additional video (monitor) card into your desktop computer, or even a dual-monitor card. These cards can be obtained very reasonably online or at your favorite computer store. You may be able to find an additional monitor at a garage sale or thrift store—or at the computer store, of course. But you don’t have to have one to use DEXter.

Go2Text

 XE "Text;Text:finding;00017-00017finding" \r "ZZZDEXterdocumentationdoc00213" 

 XE "Go2Text;Go2Text" \r "ZZZDEXterdocumentationdoc00212" DEXter includes a utility called Go2Text that makes it easy to find text (entries, for example) that you specify. It’s similar to Word’s Find feature, but it eliminates two keystrokes because the dialog automatically closes and there’s no need to “deselect” the found text.

Going to Text

 1. On your keyboard, press F2 or SHIFT + CTRL + G (which stands for “Go2Text”).

 2. In the box labeled “Enter Text,” type the text you want to go to. It doesn’t have to be far away (although it can be). For example, if you see an error a few paragraphs down from your cursor, just type the first few characters of the error into the box. If there’s a certain entry you need to find (so you can duplicate it, for example), type the entry into the box.

 3. Check the boxes for any options you want to use. Quite often, you’ll want to select the option to “Go up,” since what you’re looking for will usually be an entry you created earlier in your index table.

 4. Press ENTER or click the OK button.

Go2Text will take you to the text you specified. It will also remember your entry and options for the next time you use the program.

Repeating

To repeat the last action of Go2Text without having to retype the text, press SHIFT + CTRL + R (which stands for “Repeat”). The Go2Text dialog will not appear, but Go2Text will take you to the next occurrence of the text you specified earlier. You can keep repeating the action as many times as you like.

Switch Windows

 XE "Windows;Windows:switching;00017-00017switching" \r "ZZZUsingDEXterdoc00265" 

 XE "Documents;Documents:switching;00017-00017switching" \r "ZZZUsingDEXterdoc00268" To switch from one window to another, press F3. You’ll be doing this a lot.

Jump

 XE "Jump;Jump" \r "ZZZDEXterdocumentationdoc00011" To jump from an entry in the index table to the text it refers to (the text you selected when you created the entry), press F4. The program will switch to the matching reference document and select the bookmarked text.

Usually, you can also jump from an indexed selection in a reference document to an entry in the index document. Unfortunately, if a text selection has multiple entries, Word has no way to identify which of those multiple entries you have in mind, so it will take you to whatever entry it thinks is best. There seems to be no rhyme or reason to this; you get what you get. But remember that you can also press F3 to switch documents rather than jumping.

5. Creating Index Entries

 XE "Index;Index:creating entries for;00019-00024creatingentriesfor" \r "ZZZDEXterdocumentationdoc00029" 

 XE "Entries;Entries:creating;00019-00024creating" \r "ZZZDEXterdocumentationdoc00030" 

 XE "Text;Text:selecting;00019-00019selecting" \r "ZZZDEXterdocumentationdoc00032" 

 XE "Selecting text;Selectingtext" \r "ZZZDEXterdocumentationdoc00031" When you’re ready to create an index entry, make sure your cursor is in one of your reference documents (at least for now). Then select the text for which you want to create an entry. An easy way to do that is to place your cursor at the beginning of the text you want to select, hold down the SHIFT key, and move your cursor to the end of the text you want to select. You can also select text with your mouse, or you can click at the beginning of the text, hold down SHIFT, and then click at the end of the text. In other words, you can use all the usual procedures.

A text “selection” can be as small as one character, as large as an entire document, or anything in between. In fact, you can simply place your cursor at a certain spot in a document, and that, too, is a “selection.”

You can also let DEXter select text for you. To do so:

 1. Place your cursor at a point in a reference document that you know marks the beginning of your selection.

 2. Press CTRL + F9 or SHIFT + B to set the StartOfTopic bookmark.

 3. Move your cursor however you like as you read through your text.

 4. When you get to a spot that seems like a good ending place for your selection, put your cursor there.

 5. Press one of the following “New Entry” keys (F5, F6, F7, F8, F11, or F12).

DEXter will automatically select the text from your cursor position to the “Start of Topic” bookmark and switch to your index table so you can type your entry. It will then delete the bookmark so you’re ready to set it again in a new position.

 XE "StartOfTopic bookmark;StartOfTopicbookmark" \r "ZZZDEXterdocumentationdoc00033" 

 XE "Bookmarks;Bookmarks:StartOfTopic;00019-00019StartOfTopic" \r "ZZZDEXterdocumentationdoc00034" If you’ve previously set the StartOfTopic bookmark and want to remove it, click DEXter > Delete StartOfTopic bookmark, or press CTRL + F10.

New Entry

 XE "New Entry;NewEntry" \r "ZZZDEXterdocumentationdoc00035" After you’ve selected the text for which you want to create an entry, press F5. DEXter will switch to your index document and add a new row to your index table. It will also enter the page number(s) and entry number in the columns on the right and then place your cursor at the beginning of the row, in the Heading column, so you can type your entry.

Note that you don’t have to select text every time you create a new entry. You can use the current selection over and over without switching back to the reference document. For example, with the same text selection, you can press F5 to create an entry for “Washington, George,” press it again to create an entry for “Honesty,” and press it again to create an entry for “Cherry tree,” all without leaving your index document.

Never try to add a new entry by manually adding a table row and typing in an entry number. Why? Because each index entry is recorded in two places and in four ways:

 1. In the reference document (as a bookmark and as highlighting).

 2. In the index document (as a bookmark and as a reference number).

Thus, you shouldn’t try to insert entries manually; it’s too complicated and may lead to errors. Just let the program do it for you.

New Entry Duplicate

 XE "New Entry Duplicate;NewEntryDuplicate" \r "ZZZDEXterdocumentationdoc00036" New Entry Duplicate creates a new entry by duplicating the entry in which your cursor rests. For example, let’s say you’ve got an entry for Bananas on page 30 and you need to make another entry for Bananas on page 45. Rather than retyping the entry, just select the text on page 45, switch to the index document, place your cursor anywhere in the row containing your previous entry for your favorite fruit, and press F6 to duplicate that entry for page 45.

That means you will probably have numerous duplicate entries in your index table, each with a different page number. For example, if you index three passages about George Washington, you might have the following three entries:

	Heading
	Subheading
	Index
	Cross-Reference
	Note
	Format
	Page 
	Entry 

	Washington, George
	
	
	
	
	
	0119
	00201

	Washington, George
	
	
	
	
	
	0230-0232
	00489

	Washington, George
	
	
	
	
	
	0054
	00072


Those entries will be combined automatically when you generate your final index. You should not try to combine them manually.

You should also avoid having duplicate entries with overlapping page numbers.

Good:

	Heading
	Subheading
	Index
	Cross-Reference
	Note
	Format
	Page
	Entry 

	Washington, George
	
	
	
	
	
	0119-0121
	00201

	Washington, George
	
	
	
	
	
	0122
	00202

	Washington, George
	
	
	
	
	
	0123-0125
	00203


Bad:

	Heading
	Subheading
	Index
	Cross-Reference
	Note
	Format
	Page
	Entry 

	Washington, George
	
	
	
	
	
	0119-0124
	00201

	Washington, George
	
	
	
	
	
	0123-0125
	00202

	Washington, George
	
	
	
	
	
	0125
	00203


For one thing, such overlapping entries make no sense. For another, Microsoft Word will sort them incorrectly (for example, they might look like this: 111–32, 111). Later when you check your index, DEXter will identify these and allow you to fix them. (See “Check Cross-References.”)
New Entry Duplicate and Swap

 XE "New Entry Duplicate and Swap;NewEntryDuplicateandSwap" \r "ZZZDEXterdocumentationdoc00037" New Entry Duplicate and Swap duplicates the entry in which your cursor rests and then swaps the heading and subheading. For example, if the current entry reads like this—

	Heading
	Subheading
	Index
	Cross-Reference
	Note
	Format
	Page 
	Entry 

	angel food cake
	ingredients
	
	
	
	
	0119
	00201


—your new entry will look like this:

	Heading
	Subheading
	Index
	Cross-Reference
	Note
	Format
	Page 
	Entry 

	ingredients
	angel food cake
	
	
	
	
	0119
	00202


Press F7 to use this feature.

New Entry Duplicate and Swap Lowercase

 XE "Entry Duplicate and Swap Lowercase;EntryDuplicateandSwapLowercase" \r "ZZZDEXterdocumentationdoc00038" New Entry Duplicate and Swap Lowercase duplicates the entry in which your cursor rests, swaps the heading and subheading, and lowercases the new subheading. To use it, place your cursor anywhere in the entry you want to duplicate and swap lowercase. Then press F8.

If the entry you are duplicating looks like this—

	Heading
	Subheading
	Index
	Cross-Reference
	Note
	Format
	Page 
	Entry 

	Oranges
	apples
	
	
	
	
	0119
	00201


—the new, duplicated entry will look like this:

	Heading
	Subheading
	Index
	Cross-Reference
	Note
	Format
	Page 
	Entry 

	apples
	oranges
	
	
	
	
	0119
	00202


You’ll probably use this feature a lot if you capitalize all headings:

Apples

Butterflies

Idaho

But if you capitalize only headings that are proper nouns—

apples

butterflies

Idaho

—you probably won’t want to use it.

Note that you can set an option (under DEXter > DEXter Tools > DEXter Options) to automatically capitalize the new heading in a swapped entry. If you’ve done that, the entry above would look like this after being swapped:

	Heading
	Subheading
	Index
	Cross-Reference
	Note
	Format
	Page 
	Entry 

	Apples
	oranges
	
	
	
	
	0119
	00202


Insert Selected Text

 XE "New Entry from Selection;NewEntryfromSelection" \r "ZZZDEXterdocumentationdoc00039" Insert Selected Text creates a new entry and automatically inserts a heading based on text you’ve selected. For example, if your reference document includes this text—

As workers began constructing the Social Hall, winter was approaching . . .

—and you select the words “Social Hall,” your new entry will include those words as its heading:

	Heading
	Subheading
	Index
	Cross-Reference
	Note
	Format
	Page 
	Entry 

	Social Hall
	
	
	
	
	
	0119
	00201


Press F9 to use this feature.

Insert Selected Text and Transpose

 XE "New Entry from Selected Text Transposed;NewEntryfromSelectedTextTransposed" \r "ZZZDEXterdocumentationdoc00040" Insert Selected Text and Transpose creates a new entry, automatically inserts a heading based on the text you’ve selected, and then transposes the words of the heading. This is particularly useful if you are indexing names. For example, if your reference document includes this text—

As Ronald Reagan greeted his Russian visitors . . .

—and you select the words “Ronald Reagan,” your new entry will include the following as its heading:

	Heading
	Subheading
	Index
	Cross-Reference
	Note
	Format
	Page 
	Entry 

	Reagan, Ronald
	
	
	
	
	
	0119
	00201


This feature is smart enough to handle middle names, initials, and quite a few name “suffixes,” including Jr., Jr, JR, Sr., Sr, SR, I, I, II, III, IV, V, VI, VII, VIII, IX, X, XI, XII, XIII, XIV, XV, Esq., Esq, Esquire, Ph.D., Ph.D, PhD., PhD, M.D., MD., MD, D.D.S., DDS., DDS., J.D., JD., JD, Ed.D., Ed.D, EdD., and EdD.

Thus, if you select a name like “John F. Kennedy, Jr.,” your new heading will look like this:

	Heading
	Subheading
	Index
	Cross-Reference
	Note
	Format
	Page 
	Entry 

	Kennedy, John F., Jr.
	
	
	
	
	
	0119
	00201


Press F10 to use this feature.

Insert Clipboard Text

 XE "New Entry from Clipboard;NewEntryfromClipboard" \r "ZZZDEXterdocumentationdoc00041" Insert Clipboard Text creates a new entry from text you have previously copied to the Clipboard. For example, if a reference document includes the text “New Hampshire,” you can select it and copy it to the Clipboard. Then you might select the entire paragraph or section that discusses that state. Finally, you can press F11 to create an entry with the heading “New Hampshire.”

Insert Clipboard Text and Transpose

 XE "New Entry from  Clipboard Transposed;NewEntryfromClipboardTransposed" \r "ZZZDEXterdocumentationdoc00042" 

 XE "Transposing;Transposing:names;00023-00024names" \r "ZZZDEXterdocumentationdoc00217" 

 XE "Names;Names:transposing;00023-00024z00025-00025transposing" \r "ZZZDEXterdocumentationdoc00216" Insert Clipboard Text and Transpose creates a new entry, with the words transposed, from text you have previously copied to the Clipboard. For example, if a reference document includes the text “Martha Washington,” you can select it and copy it. Then you might select the entire paragraph or section that discusses Martha Washington. Finally, you can press F12 to create an entry with the heading “Washington, Martha.”

This feature is smart enough to handle middle names, initials, and quite a few name “suffixes,” including Jr., Jr, JR, Sr., Sr, SR, I, I, II, III, IV, V, VI, VII, VIII, IX, X, XI, XII, XIII, XIV, XV, Esq., Esq, Esquire, Ph.D., Ph.D, PhD., PhD, M.D., MD., MD, D.D.S., DDS., DDS., J.D., JD., JD, Ed.D., Ed.D, EdD., and EdD.

Thus, if you copy a name like “John F. Kennedy, Jr.,” your new heading will look like this:

	Heading
	Subheading
	Index
	Cross-Reference
	Note
	Format
	Page 
	Entry 

	Kennedy, John F., Jr.
	
	
	
	
	
	0119
	00201


Press F12 to use this feature.

Setting DEXter Options
 XE "Setting up;Settingup:options;00024-00025options" \r "ZZZDEXterdocumentationdoc00044" 

 XE "Options;Options:setting;00024-00025setting" \r "ZZZDEXterdocumentationdoc00043" 

 XE "Headings;Headings:capitalizing;00024-00025capitalizing" \r "ZZZDEXterdocumentationdoc00218" 

 XE "Capitalizing;Capitalizing:headings;00024-00025headings" \r "ZZZDEXterdocumentationdoc00219" Dexter Options allows you to choose what happens when you automatically swap, paste, or insert a heading. There are two options, which you can set by clicking DEXter > DEXter Tools > DEXter Options:

 •  Capitalize headings when automatically swapping, pasting, or inserting.

 •  Transpose headings with commas when automatically swapping.

“Capitalize headings” automatically capitalizes the first letter of a heading. For example, let’s say you have an entry like this:

	Heading
	Subheading
	Index
	Cross-Reference
	Note
	Format
	Page 
	Entry 

	Lepidoptera
	butterflies
	
	
	
	
	0119
	00201


If you press F7 to duplicate and swap that entry, you’ll get this:

	Heading
	Subheading
	Index
	Cross-Reference
	Note
	Format
	Page 
	Entry 

	Butterflies
	Lepidoptera
	
	
	
	
	0119
	00202


If you press F8 to duplicate and swap lowercase, you’ll get this:

	Heading
	Subheading
	Index
	Cross-Reference
	Note
	Format
	Page 
	Entry 

	Butterflies
	lepidoptera
	
	
	
	
	0119
	00202


You’ll probably want to use this option if you capitalize every heading in your index:

Apples

Butterflies

Idaho

But if you capitalize only headings that are proper nouns—

apples

butterflies

Idaho

—you probably won’t want to use it.

 XE "Transposing;Transposing:headings with commas;00025-00025headingswithcommas" \r "ZZZDEXterdocumentationdoc00221" 

 XE "Names;Names:transposing;00023-00024z00025-00025transposing" \r "ZZZDEXterdocumentationdoc00222" 

 XE "Headings;Headings:transposing, with commas;00025-00025transposing,withcommas" \r "ZZZDEXterdocumentationdoc00220" “Transpose headings with commas” automatically transposes elements of a heading on either side of a comma and then deletes the comma. For example, let’s say you have an entry like this:

	Heading
	Subheading
	Index
	Cross-Reference
	Note
	Format
	Page 
	Entry 

	Jefferson, Thomas
	Declaration of Independence
	
	
	
	
	0119
	00201


If you press F7 to duplicate and swap that entry, you’ll get this:

	Heading
	Subheading
	Index
	Cross-Reference
	Note
	Format
	Page 
	Entry 

	Declaration of Independence
	Thomas Jefferson
	
	
	
	
	0119
	00202


Ignoring an Entry (!)

 XE "Ignoring an entry;Ignoringanentry" \r "ZZZDEXterdocumentationdoc00045" If you’ve made some entries you no longer want to be included in your finished index, but you don’t yet want to delete them, you can tell DEXter to ignore them by putting an exclamation mark (!) in front of them. For example, if you wanted the program to ignore this entry—

	Heading
	Subheading
	Index
	Cross-Reference
	Note
	Format
	Page 
	Entry 

	Washington, George
	and cherry tree
	
	
	
	
	0119
	00201


—you could put an exclamation mark in front of it, like this:

	Heading
	Subheading
	Index
	Cross-Reference
	Note
	Format
	Page 
	Entry 

	!Washington, George
	and cherry tree
	
	
	
	
	0119
	00201


When DEXter marks your index entries, it will not mark that one. This is useful because, as you index, you may change your mind several times about how detailed your index should be. This feature allows you to do that without losing entries that may later prove valuable.

Forcing a Sort (;)

 XE "Sorting;Sorting:forced;00026-00026forced" \r "ZZZDEXterdocumentationdoc00208" 

 XE "Forcing a sort;Forcingasort" \r "ZZZDEXterdocumentationdoc00046" Microsoft Word includes an undocumented “switch” for embedded index entries that allows you to force Word to alphabetize text in the way you specify. To do that, put a semicolon after the heading or subheading and then type the text by which you want to alphabetize. For example, if you have a heading for Alpha but want it to be sorted as Omega, you’d type the heading like this:

	Heading
	Subheading
	Index
	Cross-Reference
	Note
	Format
	Page 
	Entry 

	Alpha;Omega
	
	
	
	
	
	0119
	00201


Then, sure enough, your index will look something like this:

Oleander, 54

Alpha, 10

Ontology, 103

DEXter automatically uses this feature to force Word to sort index entries letter by letter and to sort subheadings by page number, among other things. However, if you use the feature, the forced sort you’ve specified will be used instead of the one created by DEXter.

Don’t use this feature for words or characters you routinely sort as something else. Instead, use the DEXterSortAs.txt list. (See “Adjust Sorting with Word Lists.”)

Highlighting Selections

 XE "Highlighting;Highlighting" \r "ZZZDEXterdocumentationdoc00047" As you create entries, you’ll notice that your selected text is automatically highlighted with various colors to help you keep track of what you’ve already indexed. For example, if you select some previously unindexed text and create an entry for it, the selected text will be highlighted in gray:

Lorem ipsum dolor sit amet, consectetuer adipiscing elit, sed diam nonummy nibh euismod tincidunt ut laoreet dolore magna aliquam erat volutpat. Ut wisi enim ad minim veniam, quis nostrud exerci tation ullamcorper suscipit lobortis nisl ut aliquip ex ea commodo consequat.
If you then select a smaller portion of text within the gray text and create a new entry, the new selection will be highlighted in yellow:

Lorem ipsum dolor sit amet, consectetuer adipiscing elit, sed diam nonummy nibh euismod tincidunt ut laoreet dolore magna aliquam erat volutpat. Ut wisi enim ad minim veniam, quis nostrud exerci tation ullamcorper suscipit lobortis nisl ut aliquip ex ea commodo consequat.
If you select a smaller portion of text within the yellow text and create a new entry, the new selection will be highlighted in cyan:

Lorem ipsum dolor sit amet, consectetuer adipiscing elit, sed diam nonummy nibh euismod tincidunt ut laoreet dolore magna aliquam erat volutpat. Ut wisi enim ad minim veniam, quis nostrud exerci tation ullamcorper suscipit lobortis nisl ut aliquip ex ea commodo consequat.
And so on, with the colors being applied in this order:

Gray

Yellow

Cyan

Green

Magenta

Red

If you select a smaller portion of text within red text and create a new entry, the new selection will be highlighted in gray. In other words, the cycle will start over again.

If you like, you can choose the color you want to be applied to selected text. To do so, press one of the following key combinations before selecting your text:

SHIFT + F6: Gray

SHIFT + F7: Yellow

SHIFT + F8: Cyan

SHIFT + F9: Green

SHIFT + F10: Magenta

SHIFT + F11: Red

DEXter will remember your choice until you change it again.

You can also tell DEXter to apply no color by pressing SHIFT + F12.

To return to automatic highlight colors, press SHIFT + F5.

Note that if you create an entry that encompasses other entries, the highlighting for the new entry will override the highlighting for the encompassed entries. For example, let’s say you have text that looks like this, with progressively smaller entries over the top of bigger ones:

Ut wisi enim ad minim veniam, quis nostrud exerci tation ullamcorper suscipit lobortis nisl ut aliquip ex ea commodo consequat. Duis autem vel eum iriure dolor in hendrerit in vulputate velit esse molestie consequat, vel illum dolore eu feugiat nulla facilisis.

If you select the whole passage and create a new entry, the highlighting for the passage will then look like this, even though the individual index entries are still there:

Ut wisi enim ad minim veniam, quis nostrud exerci tation ullamcorper suscipit lobortis nisl ut aliquip ex ea commodo consequat. Duis autem vel eum iriure dolor in hendrerit in vulputate velit esse molestie consequat, vel illum dolore eu feugiat nulla facilisis.
Thus, when using automatic highlighting, you may want to index in broad strokes first and then index small details later.

 XE "Display;Display:bookmarks;00028-00028z00037-00038bookmarks" \r "ZZZDEXterdocumentationdoc00223" 

 XE "Bookmarks;Bookmarks:displaying;00028-00028z00037-00038displaying" \r "ZZZDEXterdocumentationdoc00224" When you reassign or delete entries, DEXter will try to adjust the highlighting as needed. However, you shouldn’t worry about keeping highlighting in perfect order. Its only purpose is to help you see what passages you’ve indexed and in what order. It has no effect at all on the actual index entries or the finished index. If you really want to see where your index entries are, click DEXter > DEXter Tools > Display Bookmarks (a toggle) until you see the gray [brackets] that enclose your indexed text.

Displaying Highlight Colors

 XE "Display;Display:highlight colors;00028-00028highlightcolors" \r "ZZZDEXterdocumentationdoc00048" 

 XE "Colors;Colors" \r "ZZZDEXterdocumentationdoc00206" If you’ve told DEXter to use highlight colors but you can’t see any colors as you work, you probably need to turn on the display of highlight colors. To do so, click Tools > Options >  View and put a check in the checkbox labeled “Highlight” (under the “Show” heading). Then click OK.

Removing Highlight Colors

 XE "Removing highlight colors;Removinghighlightcolors" \r "ZZZDEXterdocumentationdoc00049" After you’ve finished indexing, you can remove all highlighting from your reference document (if you like) by pressing CTRL + A to select the document text and then, on the Formatting toolbar, clicking the arrow to the right of the Highlight button and clicking “None.”

Specifying Index Type

 XE "Index;Index:type, specifying;00028-00028type,specifying" \r "ZZZDEXterdocumentationdoc00051" You can specify that an entry belongs to a certain type of index by entering a code (one you make up) in the Index column. For example, if you were indexing a poetry anthology, you could enter a “t” for a title-index entry (“Tyger, The”), an “a” for an author entry (“Blake, William”), and an “f” for a first-line entry (“Tyger! Tyger! burning bright”). Later, when you generate your index, you can tell Word to create separate indexes for each one of these. (See “Type of Index.”) Such codes can be more than one letter.

Adding Cross-References Manually
 XE "Cross-references;Cross-references:adding manually;00028-00031addingmanually" \r "ZZZDEXterdocumentationdoc00053" If you want to enter a cross-reference, type it into the column labeled “Cross-Reference.” For a “See” reference, put a closing angle bracket (>) at the beginning of the reference, like this: >Delaware (which will later be converted into “See Delaware”). If you want a “See also” reference, put an ampersand (&) at the beginning of the reference, like this: &Delaware (which will later be converted into “See also Delaware”). Note that each cross-reference should be on its own line and not combined into one entry.

Good:

	Heading
	Subheading
	Index
	Cross-Reference
	Note
	Format
	Page 
	Entry 

	Washington, George
	
	
	>Valley Forge
	
	
	0119
	00201

	Washington, George
	
	
	>Cherry tree
	
	
	0230-0232
	00489

	Washington, George
	
	
	>Washington, Martha
	
	
	0054
	00054


Bad:

	Heading
	Subheading
	Index
	Cross-Reference
	Note
	Format
	Page 
	Entry 

	Washington, George
	
	
	>Cherry tree; Valley Forge; Washington, Martha
	
	
	0119
	00201


DEXter will automatically combine and sort cross-references when the index is generated and processed.

If you don’t prefix your cross-reference with “>” or “&” then whatever you type in this column will be used as a cross-reference. This can be useful for entering such references as “Find and Replace codes are listed inside the back cover” or “Visit http://www.editorium.com for more information.”

Because of limitations with Microsoft Word, DEXter does not allow cross-references as part of subheadings. For example, you can’t use DEXter to create an entry like this:

Washington, George


childhood of, 9. See also Cherry tree


at Valley Forge, 231

Instead, cross-references go with the entire entry:

Washington, George


childhood of, 9.


at Valley Forge, 231


See also Presidents

If you want to use a “See also” cross-reference in an entry with subheadings, you must create a separate entry for it. In other words, it must not be included in the same entry as a subheading:

Good:

	Heading
	Subheading
	Index
	Cross-Reference
	Note
	Format
	Page 
	Entry 

	Washington, George
	and cherry tree
	
	
	
	
	0119
	00201

	Washington, George
	
	
	&Valley Forge
	
	
	0119
	00489


Bad:

	Heading
	Subheading
	Index
	Cross-Reference
	Note
	Format
	Page 
	Entry 

	Washington, George
	and cherry tree
	
	&Valley Forge
	
	
	0119
	00201


Why? Because such an entry will produce an index entry without a page number:

Washington, George


and cherry tree


See also Valley Forge

So even though such an entry has a number in the Page column, it will not produce a page number in your index. Consider this entry—

	Heading
	Subheading
	Index
	Cross-Reference
	Note
	Format
	Page 
	Entry 

	Apples
	
	
	>Oranges
	
	
	0223
	00201


—which will produce the following:

Apples. See Oranges.

Again, no page number—which, with a “See” cross-reference, makes sense. If, however, you create a duplicate entry without the cross-reference— 

	Heading
	Subheading
	Index
	Cross-Reference
	Note
	Format
	Page 
	Entry 

	Apples
	
	
	>Oranges
	
	
	0223
	00201

	Apples
	
	
	
	
	
	0223
	00489


—then your final entry will include a page number:

Apples, 223. See Oranges.

In that case, of course, you’d want a “See also” rather than a “See” cross-reference:

	Heading
	Subheading
	Index
	Cross-Reference
	Note
	Format
	Page 
	Entry 

	Apples
	
	
	&Oranges
	
	
	0223
	00201

	Apples
	
	
	
	
	
	0223
	00489


Apples, 223. See also Oranges.

It’s also possible—but undesirable—to create a nonsensical entry like this:

	Heading
	Subheading
	Index
	Cross-Reference
	Note
	Format
	Page 
	Entry 

	Apples
	
	
	&Oranges
	
	
	0223
	00201


Apples. See also Oranges.

Be careful not to include duplicate instances of a cross-reference with the same heading. If you do, you’ll get duplicate instances in your finished index, which is not what you want:

Apples. See Oranges; Oranges

Good:

	Heading
	Subheading
	Index
	Cross-Reference
	Note
	Format
	Page 
	Entry 

	Apples
	
	
	>Oranges
	
	
	0025
	00201


	Heading
	Subheading
	Index
	Cross-Reference
	Note
	Format
	Page 
	Entry 

	Apples
	
	
	
	
	
	0025
	00201

	Apples
	
	
	&Oranges
	
	
	0025
	00202


Bad:

	Heading
	Subheading
	Index
	Cross-Reference
	Note
	Format
	Page 
	Entry 

	Apples
	
	
	>Oranges
	
	
	0125
	00201

	Apples
	
	
	>Oranges
	
	
	0247
	00489


	Heading
	Subheading
	Index
	Cross-Reference
	Note
	Format
	Page 
	Entry 

	Apples
	
	
	
	
	
	0223
	00288

	Apples
	
	
	&Oranges
	
	
	0223
	00289

	Apples
	
	
	
	
	
	0389
	00401

	Apples
	
	
	&Oranges
	
	
	0389
	00402


This problem may be resolved automatically in future versions of DEXter, but for now you can check it by sorting your index table on the Cross-Reference column.

In summary, “See” cross-references require one index entry; “See also” cross-references require two. Do not include duplicate instances of a cross-reference with the same heading.

Adding Cross-References Automatically

 XE "Cross-references;Cross-references:adding automatically;00032-00032addingautomatically" \r "ZZZ00055" DEXter provides a way to insert cross-references automatically. This helps ensure that the cross-references you create actually do refer to something. It also means less typing for you.

Inserting a “See” Cross-Reference
To insert a “See” cross-reference automatically:

 1. Create a new entry (using any of the “new entry” features), which will automatically set the StartOfTopic bookmark in the new entry.

 2. Sort the table by heading (CTRL + F1) if that will help you locate the heading to which you want a cross-reference.

 3. Place your cursor anywhere in the entry you want to cross-reference.

 4. Press CTRL + F11 to put the cross-reference into the new (bookmarked) entry.

 5. Sort the table by entry (CTRL + F4) to see your new entry in sequence.

You can also set the StartOfTopic bookmark manually in an entry previously created. To do so, put your cursor anywhere in the entry and press CTRL + F9. Then, if you press CTRL + F11, the “See” cross-reference will be placed in the entry you’ve specified with the bookmark.

Inserting a “See also” Cross-Reference
To insert a “See also” cross-reference automatically:

 1. Create a new entry (using any of the “new entry” features, which will automatically set the StartOfTopic bookmark in the new entry.

 2. Sort the table by heading (CTRL + F1) if that will help you locate the heading to which you want a cross-reference.

 3. Place your cursor anywhere in the entry you want to cross-reference.

 4. Press CTRL + F12 to put the cross-reference into the new (bookmarked) entry.

 5. Sort the table by entry (CTRL + F4) to see your new entry in sequence.

You can also set the StartOfTopic bookmark manually in an entry previously created. To do so, put your cursor anywhere in the entry and press CTRL + F9. Then, if you press CTRL + F12, the “See also” cross-reference will be placed in the entry you’ve specified with the bookmark.

Adding Notes

 XE "Notes;Notes:adding;00032-00033adding" \r "ZZZDEXterdocumentationdoc00057" To add a note to your entry, type whatever you like into the column labeled “Note.” This text will not be included in the finished index or affect it in any way. It’s just a way to enter comments or reminders about an entry for your own reference (“Check Latin spelling”).

Later, if you want to review all your notes at one time, you can sort your index by the Note column so that all the notes appear together. To do so, put your cursor in the Note column and press CTRL + F2.

Specifying Page Format

 XE "Page format;Pageformat:specifying;00033-00033specifying" \r "ZZZDEXterdocumentationdoc00059" For some entries, you may want to specify the type style for the page number. This is commonly done to show that an entry refers to a map or illustration, for example. To specify italic, type “i” into the Format column for an entry. If you type “b” you’ll get bold, while “&” will produce bold italic. You can use uppercase or lowercase letters. This formatting will be applied when you generate your final index.

6. Changing Existing Entries
 XE "Modifying;Modifying:entries;00034-00036entries" \r "ZZZDEXterdocumentationdoc00205" 

 XE "Entries;Entries:editing;00034-00036editing" \r "ZZZ00062" 

 XE "Entries;Entries:changing;00034-00036changing" \r "ZZZDEXterdocumentationdoc00061" 

 XE "Editing;Editing:entries;00034-00036entries" \r "ZZZ00063" 

 XE "Changing entries;Changingentries" \r "ZZZDEXterdocumentationdoc00060" Dexter includes special features to help you manipulate existing index entries.

Capitalize or Lowercase a Word

 XE "Words;Words:lowercasing or capitalizing;00034-00034lowercasingorcapitalizing" \r "ZZZDEXterdocumentationdoc00066" 

 XE "Lowercase or capitalize a word;Lowercaseorcapitalizeaword" \r "ZZZDEXterdocumentationdoc00065" 

 XE "Capitalize or lowercase a word;Capitalizeorlowercaseaword" \r "ZZZDEXterdocumentationdoc00064" If you need to capitalize or lowercase words as you work, DEXter provides an easy way to do that. Put your cursor anywhere in the word you want to change and press CTRL + F5. If the word is capitalized, it will be lowercased; if it is lowercased, it will be capitalized. Your cursor will then move to the following word so you can use the feature again.

Transpose Words

 XE "Words;Words:transposing;00034-00034transposing" \r "ZZZ00070" 

 XE "Transposing;Transposing:words;00034-00034words" \r "ZZZDEXterdocumentationdoc00067" If you need to transpose words in one of the cells of your index table, place your cursor anywhere in the second word to be transposed. Then press CTRL + F6. For example, “menu item” becomes “item menu.”

Transpose Parenthetical

 XE "Transposing;Transposing:parenthetical expressions;00034-00034parentheticalexpressions" \r "ZZZ00068" 

 XE "Parenthetical expressions;Parentheticalexpressions:transposing;00034-00034transposing" \r "ZZZ00069" As you index, you may sometimes need to transpose words outside parentheses with those inside parentheses. For example, in a new duplicate entry, you may want to change this—

Hypertext Markup Language (HTML)

—to this:

HTML (Hypertext Markup Language)

To do so, place your cursor anywhere in the table cell that contains those words. Then press CTRL + F7.

Cycle

 XE "Cycle;Cycle" \r "ZZZDEXterdocumentationdoc00071" The Cycle feature allows you to move words one at a time from the back of a phrase to the front of a phrase. For example, if you have a subheading that reads like this—

endures winter at Valley Forge

—you can press CTRL + F8 to cycle through the words of the subheading. In this example, the first time you pressed CTRL + F8, you’d get this:

Forge endures winter at Valley

Press it again to get this:

Valley Forge endures winter at

Put a comma after Valley Forge, and you might have something useful:

Valley Forge, endures winter at

Swap

 XE "Swap;Swap" \r "ZZZDEXterdocumentationdoc00072" 

 XE "Entries;Entries:swapping;00035-00036swapping" \r "ZZZDEXterdocumentationdoc00077" Swap will invert the contents of two adjoining cells in your index entry. To use this feature, place your cursor in the cell to the left of the cell with which you want to swap it. Then press SHIFT + F4. You can use this feature to swap heading and subheading, for example.

The “Swap” feature is used by two other features:

 •  New Entry Duplicate and Swap

 •  New Entry Duplicate and Swap Lowercase

Swap will automatically adjust the placement of words that you specify in a file called Swap.txt, kept in your documents folder. For example, that file might include the following words:

and

the

with

Now let’s say you want to swap heading and subheading in this entry:

	Heading
	Subheading
	Index
	Cross-Reference
	Note
	Format
	Page 
	Entry 

	HTML
	and XML
	
	
	
	
	0119
	00201


After the swap, your entry will look like this:

	Heading
	Subheading
	Index
	Cross-Reference
	Note
	Format
	Page 
	Entry 

	XML
	HTML and
	
	
	
	
	0119
	00201


The specified words will be adjusted both before and after a swapped subheading, and they will be adjusted in multiples if they appear in multiples. For example, let’s say you want to swap heading and subheading in this (nonsensical) entry:

	Heading
	Subheading
	Index
	Cross-Reference
	Note
	Format
	Page 
	Entry 

	XML
	with the Internet and
	
	
	
	
	0119
	00201


After the swap, your entry will look like this:

	Heading
	Subheading
	Index
	Cross-Reference
	Note
	Format
	Page 
	Entry 

	Internet
	and XML with the
	
	
	
	
	0119
	00201


Reassign Entry

 XE "Reassigning;Reassigning:entries;00036-00036entries" \r "ZZZDEXterdocumentationdoc00073" 

 XE "Entries;Entries:reassigning;00036-00036reassigning" \r "ZZZDEXterdocumentationdoc00074" Sometimes you may want to reassign an existing entry to a different text selection:

 1. Select the new text you want to use.

 2. Put your cursor in the index document anywhere in the entry you want to reassign.

 3. Press SHIFT + F2 or ALT + INSERT.

The entry will be removed from the old text selection and reassigned to the new one.

Delete Entry

 XE "Entries;Entries:deleting;00036-00036deleting" \r "ZZZDEXterdocumentationdoc00076" 

 XE "Delete Entry;DeleteEntry" \r "ZZZDEXterdocumentationdoc00075" To delete an entry:

 1. Put your cursor in the index document anywhere in the entry you want to delete.

 2. Press SHIFT + F3 or ALT + DELETE.

The entry will be removed from both the reference document and the index document.

Why can’t you just delete entries by hand? Well, remember that each index entry is recorded in two places and in four ways:

 1. In the reference document (as a bookmark and as highlighting).

 2. In the index document (as a bookmark and as a reference number).

Thus, you shouldn’t try to delete entries manually; it’s too complicated and may lead to errors. Just let the program do it for you.

7. Reviewing Your Index
 XE "Reviewing;Reviewing" \r "ZZZDEXterdocumentationdoc00079" 

 XE "Index;Index:reviewing;00037-00038reviewing" \r "ZZZDEXterdocumentationdoc00080" After you’ve created your index entries, you’ll want to review them and edit them. DEXter includes several features to help you do that.

Sort by Heading

 XE "Sorting;Sorting:by heading;00037-00037byheading" \r "ZZZDEXterdocumentationdoc00081" 

 XE "Headings;Headings:sorting by;00037-00037sortingby" \r "ZZZDEXterdocumentationdoc00082" This feature sorts your index table by heading and then subheading—in other words, by the text in the cells of the first and then second column. Note that this is done with Word’s native sort feature, which means the sort will be done word by word. This has nothing to do with the sorting of your finished index that will later be generated in Word. It simply makes it possible to review all of your entries with the headings in alphabetical order. Press CTRL + F1 to sort by heading and then subheading.

Sort by Current Column

 XE "Sorting;Sorting:by current column;00037-00037bycurrentcolumn" \r "ZZZDEXterdocumentationdoc00085" 

 XE "Current column;Currentcolumn:sorting by;00037-00037sortingby" \r "ZZZDEXterdocumentationdoc00083" 

 XE "Column;Column:sorting by;00037-00037sortingby" \r "ZZZDEXterdocumentationdoc00084" This feature sorts your index table by the column in which your cursor rests. For example, you can use this feature to sort your entries by subheading, cross-reference, or note. Note that this is done with Word’s native sort feature, which means the sort will be done word by word. This has nothing to do with the sorting of your finished index that will later be generated in Word. It simply makes it possible to review all of your entries by a selected element in alphabetical order. Press CTRL + F2 to sort by the current column.

Sort by Page Number

 XE "Sorting;Sorting:by page number;00037-00037z00042-00043bypagenumber" \r "ZZZDEXterdocumentationdoc00087" 

 XE "Page numbers;Pagenumbers:sorting by;00037-00037z00042-00043sortingby" \r "ZZZDEXterdocumentationdoc00086" This feature sorts your index table by page number—the numbers in the next-to-last column. This has nothing to do with the sorting of your finished index that will later be generated in Word. It simply makes it possible to review all of your entries by page order. Press CTRL + F3 to sort by page number.

Sort by Entry Number

 XE "Sorting;Sorting:by entry number;00037-00037byentrynumber" \r "ZZZDEXterdocumentationdoc00089" 

 XE "Entry number;Entrynumber:Sorting by;00037-00037Sortingby" \r "ZZZDEXterdocumentationdoc00088" This feature sorts your index table by entry number—in other words, by the text in the cells of the last column. This has nothing to do with the sorting of your finished index that will later be generated in Word. It simply makes it possible to review all of your entries in the order in which they were made. Press CTRL + F4 to sort by entry number.

Display Bookmarks

 XE "Display;Display:bookmarks;00028-00028z00037-00038bookmarks" \r "ZZZDEXterdocumentationdoc00090" 

 XE "Bookmarks;Bookmarks:displaying;00028-00028z00037-00038displaying" \r "ZZZDEXterdocumentationdoc00091" Display bookmarks by clicking DEXter > DEXter Tools > Display Bookmarks. This is a toggle that will display or hide bookmarks in the document you’re indexing. The bookmarks will be displayed as square, gray [brackets] at the beginning and end of text you’ve selected and indexed. The brackets will help you see where your text selections begin and end.

Display Index Codes

 XE "Index;Index:codes, displaying;00038-00038codes,displaying" \r "ZZZDEXterdocumentationdoc00093" 

 XE "Display;Display:index codes;00038-00038indexcodes" \r "ZZZDEXterdocumentationdoc00092" 

 XE "Codes;Codes:displaying;00038-00038displaying" \r "ZZZDEXterdocumentationdoc00210" If you want to see the XE index codes after marking the entries in your reference document, you can do so by clicking DEXter > DEXter Tools > Display Index Codes. Click it again to hide them. Showing the codes is especially useful if you need to tweak some of them by hand. See “Type of Index” and, in the appendix, “Switches for Word’s INDEX Field” and “Switches for Word’s XE Field” for more information.

8. Checking and Generating Your Index
Check Duplicate Entries

 XE "Index;Index:checking;00039-00040checking" \r "ZZZDEXterdocumentationdoc00095" 

 XE "Checking;Checking:index;00039-00040index" \r "ZZZDEXterdocumentationdoc00094" 

 XE "Duplicate entries;Duplicateentries:checking;00039-00040checking" \r "ZZZDEXterdocumentationdoc00097" 

 XE "Checking;Checking:duplicate entries;00039-00040duplicateentries" \r "ZZZDEXterdocumentationdoc00096" Since your final index will be generated by Microsoft Word, it’s important to make sure that duplicate headings and subheadings are duplicated exactly, with no differences. For example, if in one entry you have this heading—

Bananas

—and in another entry you have this (misspelled) heading—

Bananes

—Microsoft Word will see those as two completely different entries rather than combining them into one entry, which is what you want. To avoid this problem, you can check duplicate entries for typographical errors:

 1. Make sure your index document is open and active on your screen (in other words, if you try to type some text, it will go into the index document).

 2. Click DEXter > Check Duplicate Entries. Duplicate headings will be marked in red, and duplicate subheadings will be marked in blue. (You can watch the program’s progress in the lower left corner of your Word window.)

 3. Check for typographical errors in headings and subheadings. Here’s how:

To check headings:

 1. Sort your index by heading (press CTRL + F1).

 2. Look for black headings that seem to be the same as adjacent red headings. The black ones may have typographical errors.

To check subheadings:

 1. Sort your index by subheading (put your cursor in the subheading column and press CTRL + F2).

 2. Look for black subheadings that seem to be the same as adjacent blue subheadings. The black ones may have typographical errors.

Of course, it’s always possible that the colored entries have a typo and the adjacent black one does not, but that will probably be the exception rather than the rule.

The coloring of the duplicate headings and subheadings is marked with two character styles:

 •  DEXterHeadingMatched (red)

 •  DEXterSubheadingMatched (blue)

After you’ve finished checking for typographical errors, you can delete these two character styles (under Format > Styles) if you want to automatically remove the coloring from your index document. Or, you can leave the coloring in place for future reference. The coloring will have no effect on your final index.

NOTE: If your index is long, this feature may take quite a while to run.

You may also want to run a spell-check (Tools > Check Spelling and Grammar) to root out particularly elusive typos.

Check Cross-References

 XE "Cross-references;Cross-references:checking;00040-00040checking" \r "ZZZDEXterdocumentationdoc00098" 

 XE "Checking;Checking:cross-references;00040-00040cross-references" \r "ZZZDEXterdocumentationdoc00099" Check Cross-References removes spaces, commas, colons, semicolons, and periods at the end of each cell. Then it checks for and warns about:

 •  Empty headings.

 •  Cross-references that have no corresponding heading (orphans).

 •  “See” or “See also” cross-references that are identical with a heading to which they belong.

 •  “See” entries used (somewhere) with subheadings.

 •  Circular “See” cross-references (each pointing to the other’s heading).

 •  Circular “See” and “See also” cross-references (each pointing to the other’s heading).

 •  Headings that have (somewhere) both “See” and “See also” cross-references.

 •  Identical entries with overlapping page numbers, which will sort incorrectly by page (for example, 111–32, 111).

You can watch the program’s progress in the lower left corner of your Word window. After you’ve fixed the problems identified by this feature, the program will display this message: “Everything checks out. Congratulations! You may now mark your index entries. Please save your index document before proceeding.”

Reassign All Page Numbers

 XE "Reassigning;Reassigning:page numbers;00040-00040pagenumbers" \r "ZZZDEXterdocumentationdoc00100" 

 XE "Page numbers;Pagenumbers:reassigning;00040-00040reassigning" \r "ZZZDEXterdocumentationdoc00101" Reassign All Page Numbers reassigns the page numbers in your index document based on the bookmarked selections in your reference document. You should definitely use this feature if you’ve had to change the pagination in your reference document after you’ve created entries in your index document. Otherwise, the feature is not usually needed. Numbers in the Page column are used by the program only if sorting subheads by number.

Make My Index

 XE "Make My Index;MakeMyIndex" \r "ZZZDEXterdocumentationdoc00102" 

 XE "Index;Index:marking, generating, and processing;00041-00042marking,generating,andprocessing" \r "ZZZDEXterdocumentationdoc00103" After you’ve finished entering, editing, and checking index entries, you can have DEXter create your index in a single process, but only if your index will be for a single reference document. To use this feature, open one reference document and its index document. (To generate an index from multiple documents, use “Mark Index Entries.”) Then click DEXter > Make My Index. Several things will happen:

 1. Word’s  XE "Index;Index:dialog box;00041-00041dialogbox" \r "ZZZDEXterdocumentationdoc00104" Index dialog box will be displayed.

Here you can select whether you want your index to be indented or run in, how many columns you want, how to align page numbers, and so on. For more information, press F1 to display Word’s Help feature for the Index dialog. After you’ve selected the options you want, click OK to continue.

 2. DEXter’s  XE "Index Options dialog;IndexOptionsdialog" \r "ZZZDEXterdocumentationdoc00105" Index Options dialog will be displayed, and you can select the options you want to use.

 XE "Sorting;Sorting:options for;00041-00041optionsfor" \r "ZZZDEXterdocumentationdoc00106" 

 XE "Options;Options:for sorting;00041-00041forsorting" \r "ZZZDEXterdocumentationdoc00107" Sorting and other options include:

 •  Sort letter by letter

 •  Sort word by word

 •  Sort subheadings by page number

 •  Adjust sorting with word lists

 •  Embed plain index entries

 XE "Position;Position:of cross-references;00041-00041z00045-00045z00047-00047ofcross-references" \r "ZZZDEXterdocumentationdoc00109" 

 XE "Cross-references;Cross-references:position of;00041-00041z00045-00045z00047-00047positionof" \r "ZZZDEXterdocumentationdoc00108" You can also select the position of cross-references:

 •  Before subheadings.

 •  After subheadings.

 XE "Processing entries;Processingentries" \r "ZZZDEXterdocumentationdoc00115" 

 XE "Mark Entries;MarkEntries" \r "ZZZDEXterdocumentationdoc00110" 

 XE "Index;Index:processing;00041-00041processing" \r "ZZZDEXterdocumentationdoc00114" 

 XE "Index;Index:generating;00041-00041generating" \r "ZZZDEXterdocumentationdoc00112" 

 XE "Generating index;Generatingindex" \r "ZZZDEXterdocumentationdoc00113" 

 XE "Entries;Entries:processing;00041-00041z00047-00047processing" \r "ZZZDEXterdocumentationdoc00116" Click OK to make your index. When the procedure is finished, DEXter will display the message “Your index is finished.”

 XE "Text;Text:converting generated index to;00041-00041z00047-00047convertinggeneratedindexto" \r "ZZZDEXterdocumentationdoc00233" 

 XE "INDEX code;INDEXcode:converting to text;00041-00041z00047-00047convertingtotext" \r "ZZZDEXterdocumentationdoc00234" In Microsoft Word, indexes are created with the INDEX field code. The Make My Index feature converts the field into actual text that can be used in a typesetting program such as QuarkXPress. If that is not what you want, you should create your index by clicking DEXter > DEXter Tools > Manual Marking and Generation, and then, in succession:

 •  Mark Entries

 •  Index . . .

 •  Process Entries

That will do exactly the same thing as Make My Index, but it will leave the index as a field.

 XE "Page numbers;Pagenumbers:form of;00042-00042formof" \r "ZZZDEXterdocumentationdoc00117" 

 XE "Locators;Locators" \t "See Page numbers" In the finished index, page numbers take whatever form they are set to in the Microsoft Word document—Arabic numerals (1, 2, 3), Roman numerals (i, ii, iii), section-page (2-5), and so on.

Word by Word

 XE "Word by word sorting;Wordbywordsorting" \r "ZZZDEXterdocumentationdoc00119" 

 XE "Sorting;Sorting:word by word;00042-00042wordbyword" \r "ZZZDEXterdocumentationdoc00120" If you select this option, DEXter will sort index entries (headings and subheadings) word by word, like this:

New Deal

New World

Newborn

News release

This is Microsoft Word’s default way of sorting index entries.

The sorting in the example above matches the word-by-word sorting in the Chicago Manual of Style. If there are commas or hyphens in the entries, however, Word will not match the sorting in the Chicago Manual of Style, but you can remedy this by telling DEXter how to adjust sorting with the DEXterSortAs.txt and DEXterIgnore.txt word lists. For example, you can tell DEXter to ignore commas in sorting, or to treat them as spaces in sorting. See “Adjust Sorting with Word Lists” for more information.

Letter by Letter

 XE "Sorting;Sorting:letter by letter;00042-00042letterbyletter" \r "ZZZDEXterdocumentationdoc00122" 

 XE "Letter by letter sorting;Letterbylettersorting" \r "ZZZDEXterdocumentationdoc00121" If you select this option, DEXter will sort index entries (headings and subheadings) letter by letter, like this:

New Deal

Newborn

News release

New World

The Chicago Manual of Style recommends this way of sorting. Again, you can adjust the sorting by using DEXter’s word lists.

Sort Subheadings by Page Number

 XE "Sorting;Sorting:by page number;00037-00037z00042-00043bypagenumber" \r "ZZZDEXterdocumentationdoc00124" 

 XE "Page numbers;Pagenumbers:sorting by;00037-00037z00042-00043sortingby" \r "ZZZDEXterdocumentationdoc00123" If you select this option, your subheadings will be sorted by page number after being sorted word by word or letter by letter and after their sorting is adjusted with DEXter’s word lists. A typical index entry might look like this:

Washington, George: and cherry tree, 9–15; at Valley Forge, 45–47; as president, 100–103

 XE "Subheadings;Subheadings:limit on number of identical;00042-00043limitonnumberofidentical" \r "ZZZUsingDEXterdoc00250" 

 XE "Limit;Limit:on number of identical subheadings;00042-00043onnumberofidenticalsubheadings" \r "ZZZUsingDEXterdoc00249" Warning: If you have lots of entries for which the heading and subheading are identical, and you want to sort subheadings by page number, you may run into problems. To sort by page number, DEXter must concatenate all the page numbers from the identical subheadings and add them as a forced sort on each identical subheading; otherwise, Word will think each identical subheading is different, and you’ll get multiple instances of the same subheading, which you don’t want. That’s all well and good, but if too many of those page numbers start to pile up, the forced sort will be too long for Word to handle. Future versions of DEXter will check for this problem, but for now, avoid making lots of duplicate subheadings if you’re going to sort them by page number in your index.

Adjust Sorting with Word Lists

 XE "Word lists;Wordlists:sorting with;00043-00044sortingwith" \r "ZZZDEXterdocumentationdoc00126" 

 XE "Sorting;Sorting:with word lists;00043-00044withwordlists" \r "ZZZDEXterdocumentationdoc00125" 

 XE "\“Stop words\”;Stopwords:sorting with;00043-00044sortingwith" \r "ZZZDEXterdocumentationdoc00127" If you select this option, DEXter will adjust the sorting of your entries based on the contents of three text files in your documents folder:

DEXterLeadingWords.txt

DEXterSortAs.txt

DEXterIgnore.txt

Where is your documents folder? On a Windows computer, it’s probably My Documents. On a Macintosh, it’s probably Documents. You can find out for sure by starting Word from scratch, creating a new document, and clicking File > Save. The folder where Word tries to save the document is your default documents folder.

These three text files come with DEXter, but you should modify them to meet your own needs and then put them into your documents folder.

The lists will be used in the order in which they are listed above: first DEXterLeadingWords.txt, then DEXterSortAs.txt, and finally  XE "DEXterIgnore.txt;DEXterIgnore.txt" \r "ZZZDEXterdocumentationdoc00128" DEXterIgnore.txt.

Leading Words

 XE "Subheadings;Subheadings:ignoring leading words in;00043-00043ignoringleadingwordsin" \r "ZZZDEXterdocumentationdoc00226" 

 XE "Leading words;Leadingwords:ignoring, in subheadings;00043-00043ignoring,insubheadings" \r "ZZZDEXterdocumentationdoc00225" 

 XE "DEXterLeadingWords.txt;DEXterLeadingWords.txt" \r "ZZZDEXterdocumentationdoc00129" DEXterLeadingWords.txt contains a list of leading words that you want DEXter to ignore when sorting subheadings. For example, your list might include these entries:

in

of

and

the

Each entry must be on its own line, followed by a carriage return.

If your list of leading words includes the word “at,” then the subheadings in the following entry will sort in this order:

Washington, George


childhood of, 9


at Valley Forge, 231

The list of leading words is used with subheadings only, not with headings.

Sort As

 XE "Sort as;Sortas:specifying, with word list;00043-00044specifying,withwordlist" \r "ZZZDEXterdocumentationdoc00227" 

 XE "DEXterSortAs.txt;DEXterSortAs.txt" \r "ZZZDEXterdocumentationdoc00130" DEXterSortAs.txt contains a list of characters, words, or phrases that you want to sort as if they were other characters, words, or phrases. For example, many indexers prefer to sort names beginning with “Mc” as if they began with “Mac” (for example, “McDonald” as “MacDonald”). If you want to do that, you can include the following entry in your list:

Mc|Mac

First comes the item you want to sort as something else (Mc).

Next comes a pipe symbol to separate the first item from the second one (|). You’ll find the pipe symbol on the key (shifted) to the left of your backspace key.

Finally comes the item by which you want to sort (Mac).

You could use this list to sort symbols or unusual words alphabetically where they belong. For example, your list might include these entries:

.doc|doc

.exe|exe

.net|net

&|ampersand

Each entry must be on its own line, followed by a carriage return, and the items will be used in the order in which they are listed.

The list of items to be sorted as something else is used with both headings and subheadings.

Ignore

 XE "Ignore;Ignore:words and characters in sorting;00044-00044wordsandcharactersinsorting" \r "ZZZDEXterdocumentationdoc00228" 

 XE "DEXterIgnore.txt;DEXterIgnore.txt" \r "ZZZDEXterdocumentationdoc00131" DEXterIgnore.txt contains a list of characters, words, or phrases that you want to be ignored in sorting. For example, your list might include these entries:

-

,

That’s a hyphen and a comma, which will need to be ignored if you’re sorting entries letter by letter as outlined in the Chicago Manual of Style.
Each entry must be on its own line, followed by a carriage return.

The list of items to ignore is used with both headings and subheadings.

Note that only the lists that actually exist in your documents folder will be used (naturally enough). If none of the lists is present, nothing will happen when you select the option “Adjust Sorting with Word Lists.” If you put only DEXterLeadingWords.txt in your documents folder, that’s the only list that will be used. This gives you a great deal of control over the sorting of your entries, and you can set up different lists for different clients or different kinds of indexes. All of the lists are case sensitive. For example, “Mc” and “mc” are not the same thing.

Plain Index Entries

 XE "Plain index entries;Plainindexentries" \r "ZZZDEXterdocumentationdoc00132" 

 XE "Entries;Entries:plain;00044-00045plain" \r "ZZZDEXterdocumentationdoc00133" If you don’t want any fancy sorting, you can select this option, and DEXter will embed “plain-vanilla” index entries into your reference document. These entries will include only headings, subheadings, and cross-references (which will not be combined or sorted). They will not include forced sorting, type of index, page format, or bookmark range, and they can be used without having DEXter process the index after it’s been generated. You’ll probably use this option if you need to give a document with embedded entries to a client who doesn’t have DEXter.

Position of Cross-References

 XE "Position;Position:of cross-references;00041-00041z00045-00045z00047-00047ofcross-references" \r "ZZZDEXterdocumentationdoc00135" 

 XE "Cross-references;Cross-references:position of;00041-00041z00045-00045z00047-00047positionof" \r "ZZZDEXterdocumentationdoc00134" Select the position you want for your cross-references:

 •  Before subheadings.

 •  After subheadings.

The appearance of cross-references follows the Chicago Manual of Style. For example, in an indented index, “Before subheadings” produces entries like this:

Washington, George. See also Revolutionary War


at Valley Forge, 9–15

“After subheadings” produces entries like this:

Washington, George


at Valley Forge, 9–15


 See also Revolutionary War

If you create a run-in rather than an indented index, you’ll probably want cross-references to follow subheadings. If so, they’ll look like this:

Washington, George: at Valley Forge, 9–15. See also Revolutionary War

But if you elect to have them precede subheadings, they’ll look like this:

Washington, George (see also Revolutionary War): at Valley Forge, 9–15

9. Creating Indexes in Stages
 XE "Stages;Stages:creating index in;00046-00047creatingindexin" \r "ZZZDEXterdocumentationdoc00157" 

 XE "Index;Index:creating, in stages;00046-00047creating,instages" \r "ZZZDEXterdocumentationdoc00156" On occasion, you may need to mark entries, insert an INDEX code, and process entries in three separate stages rather than doing them all at once with Make My Index. For example, for some projects, you might need to mark entries even though pagination isn’t yet final and then correct the pagination later. Or, you might need to index multiple documents at once.

Under DEXter > DEXter Tools > Manual Marking and Generation, you’ll find three features that let you do the three steps separately:

Mark Entries

Index . . .

Process Index

Mark Entries
 XE "Mark Entries;MarkEntries" \r "ZZZDEXterdocumentationdoc00158" 

 XE "Entries;Entries:marking;00046-00046marking" \r "ZZZDEXterdocumentationdoc00159" When you click DEXter > DEXter Tools > Manual Marking and Generation > Mark Entries, you’ll be presented with the following sorting and other options:

 •  Sort letter by letter

 •  Sort word by word

 •  Sort subheads by page number

 •  Adjust sorting with word lists

 •  Embed plain index entries

Select the options you want to use and click OK to mark the index entries in your reference documents. The program will take the information from your index table, create XE index entries, and place them in your reference documents at the bookmarks to which they belong.

Be sure to save your documents after using this feature.

Index . . .

 XE "RD fields;RDfields" \r "ZZZUsingDEXterdoc00237" 

 XE "Master documents;Masterdocuments" \r "ZZZUsingDEXterdoc00236" After you’ve marked your index entries, go to the bottom of your reference document. If you have more than one, go to the bottom of the master document or a document with RD fields for all of the reference documents. (For more information on master documents and RD fields, see Word’s Help feature.) Then click DEXter  Tools > Manual Marking and Generation > Index . . . to open Word’s Index dialog box. Select the options you want to use and click OK to insert the INDEX code. This is the equivalent of clicking Insert > Reference > Index and Tables > Index in Microsoft Word.

Process Index

 XE "Processing entries;Processingentries" \r "ZZZDEXterdocumentationdoc00161" 

 XE "Entries;Entries:processing;00041-00041z00047-00047processing" \r "ZZZDEXterdocumentationdoc00162" 

 XE "Position;Position:of cross-references;00041-00041z00045-00045z00047-00047ofcross-references" \r "ZZZDEXterdocumentationdoc00163" 

 XE "Percent signs;Percentsigns:in generated index;00047-00047ingeneratedindex" \r "ZZZUsingDEXterdoc00253" 

 XE "Index;Index:percent signs in;00047-00047percentsignsin" \r "ZZZUsingDEXterdoc00254" 

 XE "Index;Index:angle brackets in;00047-00047anglebracketsin" \r "ZZZUsingDEXterdoc00256" 

 XE "Headings;Headings:percent signs at beginning of;00047-00047percentsignsatbeginningof" \r "ZZZUsingDEXterdoc00260" 

 XE "Cross-references;Cross-references:position of;00041-00041z00045-00045z00047-00047positionof" \r "ZZZDEXterdocumentationdoc00164" 

 XE "Cross-references;Cross-references:angle brackets around;00047-00047anglebracketsaround" \r "ZZZUsingDEXterdoc00259" 

 XE "Codes;Codes:in generated index;00047-00047ingeneratedindex" \r "ZZZUsingDEXterdoc00258" 

 XE "Codes;Codes:cleaning up;00047-00047cleaningup" \r "ZZZUsingDEXterdoc00252" 

 XE "Brackets;Brackets:in generated index;00047-00047ingeneratedindex" \r "ZZZUsingDEXterdoc00257" 

 XE "Angle brackets;Anglebrackets:in generated index;00047-00047ingeneratedindex" \r "ZZZUsingDEXterdoc00255" After your index has been generated, you’ll notice some pretty strange things, such as percent signs (%) at the beginning of each entry and angle brackets around cross-references. Don’t panic! DEXter needs these to combine, sort, and move cross-references. To make that happen (and to clean up the codes), click DEXter > DEXter Tools > Manual Marking and Generation > Process Index. When you do, you’ll be asked to select the position for your cross-references:

 •  Before subheadings.

 •  After subheadings.

Make your selection and click OK.

When the procedure is finished, DEXter will display the message “Your index is finished.”

In the finished index, page numbers take whatever form they are set to in the Microsoft Word document—Arabic numerals (1, 2, 3), Roman numerals (i, ii, iii), section-page (2-5), and so on.

 XE "Text;Text:converting generated index to;00041-00041z00047-00047convertinggeneratedindexto" \r "ZZZDEXterdocumentationdoc00230" 

 XE "INDEX code;INDEXcode:converting to text;00041-00041z00047-00047convertingtotext" \r "ZZZDEXterdocumentationdoc00232" Note that this feature does not change the INDEX field to actual text, which is what happens when you click DEXter > Make My Index. If you want to manually change the index to text, place your cursor anywhere in the index and press CTRL + 6.

Note, too, that if pagination changes after entries have been embedded, there’s no need to reembed the entries. In fact, you definitely shouldn’t. Just update the existing index (right-click in the index and click Update Field) and then process it again.

10. Specifying a Type of Index

 XE "Type of index;Typeofindex" \r "ZZZDEXterdocumentationdoc00136" 

 XE "Modifying;Modifying:index codes;00048-00049indexcodes" \r "ZZZDEXterdocumentationdoc00139" 

 XE "INDEX code;INDEXcode" \r "ZZZDEXterdocumentationdoc00138" 

 XE "Index;Index:type of;00048-00048typeof" \r "ZZZDEXterdocumentationdoc00137" 

 XE "Index;Index:modifying codes for;00048-00049modifyingcodesfor" \r "ZZZDEXterdocumentationdoc00140" 

 XE "Codes;Codes:modifying;00048-00048z00048-00049modifying" \r "ZZZDEXterdocumentationdoc00141" 

 XE "Codes;Codes:modifying;00048-00048z00048-00049modifying" \r "ZZZDEXterdocumentationdoc00142" If, in your index entries, you’ve specified index types under the “Index” column, you can use that information to generate an index only for the entries marked as a certain type.

For example, let’s say you’ve indexed a poetry anthology, and you’ve entered a “t” for title-index entries (“Tyger, The”), an “a” for author entries (“Blake, William”), and an “f” for first-line entries (“Tyger! Tyger! burning bright”). Now, when generating your index, you can tell Word to create separate indexes for each one of those types (see “Specifying Index Type”):

 1. If your index is displayed as index text, display it as a field by clicking DEXter > Display Index Codes. You should then see a code that looks something like this at the end of your document:

{ INDEX \c "1" \z "1033" }

The code in this form will generate an index based on all your index entries, not just those of a certain type.

 2. Modify the index field (just type in the necessary characters) by adding this—

\f "a"

—so the code looks something like this:

{ INDEX \c "1" \z "1033" \f "a" }

In our example of a poetry anthology, that field would generate an index of authors—in other words, it would include only the entries with an “a” in the “Index” column.

As Microsoft says:

The \f “identifier” creates an index using only the specified entry type. The index generated by { INDEX \f "a" } includes only entries marked with XE fields such as { XE "Selecting Text" \f "a" }.

 3. Display your index as text rather than a code by again clicking DEXter > Display Index Codes.

11. Modifying Index Styles

When Microsoft Word generates an index, it automatically uses paragraph styles to format your index entries. You can modify those styles to make your index look exactly the way you want it to:

 1. Click Format > Styles and Formatting, which will open the Styles and Formatting Task Pane.

 2. In the list of styles in the task pane, locate an index style you want to modify (Index 1, Index 2, and so on).

 3. Click to the right of the style to reveal an arrow.

 4. Click the arrow and then click Modify to display the Modify Style dialog.

 5. Here you can modify several kinds of formatting just as the dialog stands, including font, point size, paragraph alignment, and so on. If you need more advanced formatting options, click the Format button at the bottom of the dialog.

 6. When you’ve finished, click OK until you’re back to your index.

12. Making an Index Table from Embedded Entries

 XE "XE codes;XEcodes:making index table from;00050-00050makingindextablefrom" \r "ZZZUsingDEXterdoc00243" 

 XE "Legacy documents;Legacydocuments" \r "ZZZUsingDEXterdoc00239" 

 XE "Index;Index:table, making from embedded entries;00050-00050table,makingfromembeddedentries" \r "ZZZUsingDEXterdoc00241" 

 XE "Entries;Entries:embedded, making index table from;00050-00050embedded,makingindextablefrom" \r "ZZZUsingDEXterdoc00244" 

 XE "Embedded entries;Embeddedentries:making index table from;00050-00050makingindextablefrom" \r "ZZZUsingDEXterdoc00238" 

 XE "Documents;Documents:legacy;00050-00050legacy" \r "ZZZUsingDEXterdoc00240" If you need to rework an index whose entries have already been embedded, you can use DEXter to pull out those embedded entries and place them in an index table. Then you can edit the entries, add new entries, and so on.

To use this feature, click DEXter > DEXter Tools > Make Table from Embedded Entries. DEXter will create a new index document, bookmark the text for the XE entries in any open reference documents, delete those XE entries, and create corresponding entries in the index table. These entries will include heading, subheading, index type, cross-references, page-number format, page number (including bookmarked spreads), and entry number. They will not include forced entries, but if enough people holler, this may be added as an option in future versions of the program.

This feature is especially useful if you need to revise indexes for legacy documents that were not indexed with DEXter. You can, of course, use it with documents indexed with DEXter as well.

 XE "XE codes;XEcodes:deleting;00050-00050deleting" \r "ZZZUsingDEXterdoc00264" 

 XE "Embedded entries;Embeddedentries:deleting;00050-00050deleting" \r "ZZZUsingDEXterdoc00263" Another way to revise indexes whose entries have already been embedded with DEXter is to open the reference document and click DEXter > DEXter Tools > Remove Embedded Index Entries. This is the equivalent of using Word’s Replace feature to find XE fields and replace them with nothing, which you could do manually like this:

 1. Click Edit > Replace.

 2. In the Find What box, enter this:

^d XE

 3. Make sure the Replace With box is empty.

 4. Click Replace All.

That will remove any existing XE entries but leave bookmarks intact—a very good thing. You can then open the index document for that reference document and continue indexing with DEXter.

13. Other Ways to Index with DEXter
 XE "Standalone indexing programs;Standaloneindexingprograms:using DEXter with;00052-00054usingDEXterwith" \r "ZZZDEXterdocumentationdoc00165" 

 XE "SKY Index;SKY Index" \t "See Standalone indexing programs" 

 XE "Macrex;Macrex" \t "See Standalone indexing programs" 

 XE "Dedicated indexing programs;Dedicatedindexingprograms:using DEXter with;00052-00054usingDEXterwith" \r "ZZZUsingDEXterdoc00274" 

 XE "Cindex;Cindex" \t "See Standalone indexing programs" DEXter is made for indexing Word documents, but you can use it for other kinds of indexing too.

Indexing from Page Proofs

 XE "Page proofs;Pageproofs:indexing from;00052-00052z00055-00055indexingfrom" \r "ZZZDEXterdocumentationdoc00144" 

 XE "Indexing;Indexing:from page proofs;00052-00052z00055-00055frompageproofs" \r "ZZZDEXterdocumentationdoc00143" For example, if you need to, you can use DEXter to index from paper page proofs:

 1. Create a new document in Microsoft Word (CTRL + N).

 2. Click DEXter > DEXter Tools > Insert Page Breaks.

 3. Enter the number of pages in your page proofs.

 4. Click OK. DEXter will insert the page breaks into your Word document.

 5. Save the document.

 6. Click DEXter > Create Index Document.

 7. Create your index just as you would in a regular Word document, selecting the pages for which you want to make an entry while referring to the page proofs.

Indexing from QuarkXPress or Other Typesetting Files

 XE "Typesetting files;Typesettingfiles:indexing from;00052-00052indexingfrom" \r "ZZZDEXterdocumentationdoc00146" 

 XE "QuarkXPress;QuarkXPress:indexing files from;00052-00052indexingfilesfrom" \r "ZZZDEXterdocumentationdoc00147" 

 XE "Portable Document Format (PDF);PortableDocumentFormat(PDF)" \r "ZZZDEXterdocumentationdoc00149" 

 XE "PDF (Portable Document Format);PDF(PortableDocumentFormat)" \r "ZZZDEXterdocumentationdoc00148" 

 XE "Indexing;Indexing:from typesetting files;00052-00052fromtypesettingfiles" \r "ZZZDEXterdocumentationdoc00145" 

 XE "Adobe Acrobat;AdobeAcrobat:indexing files from;00052-00052indexingfilesfrom" \r "ZZZDEXterdocumentationdoc00150" Rather than indexing from paper page proofs, you may be able to export the text of the proofs from the typesetting program and create a Word document for use with DEXter. For example, if the proofs have been typeset in QuarkXPress, you can use Quark to create a PDF (Adobe Acrobat) file of the proofs. Then open the PDF in Adobe Acrobat. From there, you can save it as a Word document, with page breaks intact.

If you don’t have Adobe Acrobat but you do have the free Adobe Reader, you can open the PDF and click File > Save As Text. Formatting will be lost, but page breaks will be exactly where they’re supposed to be, and you can begin indexing.

Another approach is to save the typeset text—from QuarkXPress,  XE "FrameMaker;FrameMaker" \r "ZZZDEXterdocumentationdoc00152" FrameMaker,  XE "Ventura;Ventura" \r "ZZZDEXterdocumentationdoc00153" Ventura, or whatever—as a Postscript file. Change the .prn file extension to .ps ( XE "Postscript;Postscript:creating reference document from;00052-00052creatingreferencedocumentfrom" \r "ZZZDEXterdocumentationdoc00151" Postscript), and you can use the free  XE "Ghostscript;Ghostscript" \r "ZZZDEXterdocumentationdoc00154" Ghostscript and  XE "GSview;GSview" \r "ZZZDEXterdocumentationdoc00155" GSview programs to open the Postscript file:

http://www.cs.wisc.edu/~ghost/

Then, in GSview, click Edit > Text Extract and save the resulting file. XE "Page breaks;Pagebreaks:inserting;00052-00052z00052-00052z00055-00055inserting" \r "ZZZUsingDEXterdoc00245" 

 XE "Page breaks;Pagebreaks:inserting;00052-00052z00052-00052z00055-00055inserting" \r "ZZZDEXterdocumentationdoc00229" 
One other (tedious) approach is to open a PDF of the page proofs—either in Adobe Acrobat or the free Adobe Reader—and copy the text of the proofs from the PDF into a Word document. Then manually insert the page breaks (CTRL + ENTER) so that they match the paper page proofs. You may also be able to insert the page breaks using Word’s Replace feature (Edit > Replace) to find recurring elements (such as running heads) and replace them with page breaks (the code for which is ^m). After the page breaks have been inserted, you can begin indexing.

14. Using DEXter with Dedicated Indexing Programs

Using Your Index Table in a Dedicated Indexing Program

 XE "Index;Index:table, in standalone programs;00053-00053table,instandaloneprograms" \r "ZZZDEXterdocumentationdoc00168" If you like, you can use the table you’ve created in DEXter to generate an index in dedicated indexing programs such as CINDEX, MACREX, or SKY Index. To do so:

 1. Back up your documents!

 2. Click DEXter > DEXter Tools > Convert DEXter Table to Standalone Table.

 3. Save your converted file with a new name.

 4. Import the converted (tab-delimited) file into your dedicated indexing program and generate your index.

Using CINDEX? If, before importing your table, you use DEXter simply to embed the table entries into your reference document (but not generate the index), the result will be the same as if you had created your index in CINDEX and then manually dragged the entries from CINDEX into the reference document. Actually, the result will be better, because the embedded entries will include the precise bookmark ranges you have selected. In effect, this makes it possible to do precise (down to the character) embedded indexing with CINDEX, even though you didn’t write your index in CINDEX.

See the documentation for your dedicated indexing program for more information on how to import a tab-delimited file.

15. DEXter in the Production Process

 XE "Production process;Productionprocess:using DEXter in;00055-00059usingDEXterin" \r "ZZZDEXterdocumentationdoc00175" Since DEXter is a tagging program, you may be able to index a book earlier in the production process than if you were using a more traditional method. How early? That depends on how much the text of the book will change after you create the index and on how desperate and gutsy you are.

Indexing from Page Proofs

 XE "Page proofs;Pageproofs:indexing from;00052-00052z00055-00055indexingfrom" \r "ZZZDEXterdocumentationdoc00177" 

 XE "Indexing;Indexing:from page proofs;00052-00052z00055-00055frompageproofs" \r "ZZZDEXterdocumentationdoc00176" Traditionally, indexers wait until page proofs are finished before starting an index. That’s the safest way to go because you can be fairly confident that pagination won’t change after your index is finished.

Indexing from Galleys

 XE "Indexing;Indexing:from galleys;00055-00055fromgalleys" \r "ZZZDEXterdocumentationdoc00178" 

 XE "Galleys;Galleys:indexing from;00055-00055indexingfrom" \r "ZZZDEXterdocumentationdoc00179" 

 XE "Page breaks;Pagebreaks:inserting;00052-00052z00052-00052z00055-00055inserting" \r "ZZZUsingDEXterdoc00246" Using DEXter, you can be fairly comfortable indexing from galleys rather than page proofs. That means you may be able to index at the same time proofreading is going on. If pagination changes after the proofreading corrections are made, you can adjust the pagination in the reference document (insert manual page breaks as needed: CTRL + ENTER) and reassign the page numbers in the index document (DEXter > DEXter Tools > Reassign All Page Numbers). Then generate the final index. If the proofreaders are finding lots of corrections or the editor is planning to make wholesale changes, you’re probably better off to wait until page proofs are available before beginning the index. (Rather than adjusting pagination manually, you might try the procedure below under “Indexing Before Galleys.”)

Indexing Before Galleys

 XE "Indexing;Indexing:before galleys;00055-00057beforegalleys" \r "ZZZDEXterdocumentationdoc00180" 

 XE "Galleys;Galleys:indexing before;00055-00057indexingbefore" \r "ZZZDEXterdocumentationdoc00181" Here is where things begin to get scary. If you really, really have to, there is a way to index a document while typesetting is going on. Use it at your own risk:

In Word 2002 or Earlier

If you’re using Word 2002 (XP) or earlier, follow this procedure:

 1. Use a copy of the edited document that went to typesetting as your reference document.

 2. After you’ve finished indexing, and after the typesetting, proofreading, and corrections are finished (in other words, final pages are available), get a copy of the typeset text in electronic form. (See “Other Ways to Index with DEXter”).

 3. In Word, merge (compare) the typeset document into the reference document. (See Word’s Help file for information on merge and compare.)

 4. Reject all changes in the reference document. With luck, this will make the text of the reference document identical to that of the typeset document. If it doesn’t, you’ll need to forget the whole thing. (See Word’s Help file for information on rejecting tracked changes.)

 5. With your reference document open, open your index document as well, with the index document being active. Then tag the bookmarks in the reference document (using DEXter > DEXter Tools > Tag Bookmarks).

 6. Merge (compare) the reference document into the typeset document so the tags are now in the typeset document.

 7. Reject all changes in the typeset document, making the tags permanent. This becomes your new reference document.

 8. With your new reference document open, open your index document as well, with the index document being active. Then make bookmarks out of the tags in the reference document (using DEXter > DEXter Tools > Bookmark Tags).

 9. Set page size to 22 by 22 inches, as large as it will go (File > Page Setup > Paper).

10. Make sure the document’s pagination matches that of the typeset galleys. Adjust as needed.

11. Reassign all page numbers in the index table (DEXter > DEXter Tools > Reassign All Page Numbers). Don’t skip this step!

12. Mark the entries.

13. Generate the index.

14. Process the index.

Warning: This procedure depends entirely on the accuracy of Word’s document merge and comparison features, which, frankly, are not always accurate. (You might try other comparison programs, however.) If you’re serious about trying it, please perform several test runs on junk documents until you fully understand how the procedure works and exactly what needs to be done.

In Word 2003 or Later

In Word 2003 or later, the document merge and comparison feature are more accurate than in earlier versions, which means you probably don’t need to tag and untag bookmarks. In other words, you can ue the following procedure, which, in my experience (on more than thirty books), works quite well. Still, please use this procedure with caution, and test it thoroughly before using it on a real book.

 1. Use a copy of the edited document that went to typesetting as your reference document.

 2. After you’ve finished indexing, and after the typesetting, proofreading, and corrections are finished (in other words, final pages are available), get a copy of the typeset text in electronic form, with page breaks where they belong. (See “Indexing from QuarkXPress or Other Typesetting Files” on page 71.)

 3. In Word, merge (compare) the typeset document into the reference document. (See Word’s Help file for information on merge and compare.)

 4. Reject all changes in the reference document. With luck, this will make the text of the reference document identical to that of the typeset document. If it doesn’t, you’ll need to forget the whole thing. (See Word’s Help file for information on rejecting tracked changes.)

 5. Set page size to 22 by 22 inches, as large as it will go (File > Page Setup > Paper).

 6. Make sure the document’s pagination matches that of the typeset galleys (it probably will). Adjust as needed.

 7. Reassign all page numbers in the index table (DEXter > DEXter Tools > Reassign All Page Numbers). Don’t skip this step!

 8. Mark the entries.

 9. Generate the index.

10. Process the index.

Indexing During Editing

 XE "Indexing;Indexing:during editing;00057-00057duringediting" \r "ZZZDEXterdocumentationdoc00182" 

 XE "Editing;Editing:indexing during;00057-00057indexingduring" \r "ZZZDEXterdocumentationdoc00183" If the typesetting will be done in Microsoft Word (yes, it can be done), you may be able to create your index entries for the manuscript while editing is going on. Basically, you use the same procedure outlined above under “Indexing Before Galleys,” but your reference document is a copy of the original manuscript, and you merge (compare) it with the edited manuscript. Again, this procedure is not recommended and should be used only as a last resort. Use it at your own risk.

Indexing Before Editing

 XE "Indexing;Indexing:before editing;00057-00057beforeediting" \r "ZZZDEXterdocumentationdoc00184" 

 XE "Editing;Editing:indexing before;00057-00057indexingbefore" \r "ZZZDEXterdocumentationdoc00185" If the typesetting will be done in Microsoft Word, and if the manuscript is already very clean, and if and the editor is planning to work with tweezers rather than a hatchet, you may be able to create your index entries for the manuscript before editing begins. After you’re finished, you give the bookmarked reference document to the editor, who works on that document as the manuscript. To ensure that no entries are inadvertently deleted, the editor should work with bookmarks and highlighting showing and leave highlighting in place until the editing is finished. After the document has been typset (in Word, remember), the final document (with bookmarks intact) should come back to you so you can reassign the page numbers, mark the entries, and generate the index. But this is not a recommended way to work. Don’t use it unless you’re in a real time crunch and have no alternative.

If the manuscript is not clean and the editor will be cutting a wide swath, you really should wait until later in the production process before indexing. 

Tagging Bookmarks
 XE "Tagging;Tagging:bookmarks;00057-00058bookmarks" \r "ZZZDEXterdocumentationdoc00186" 

 XE "Bookmarks;Bookmarks:tagging;00057-00058tagging" \r "ZZZDEXterdocumentationdoc00187" The Tagging Bookmarks feature can also be used if, for some other reason, you need to tag the bookmarks in your reference document. These tags, along with XE index codes, could serve as the basis for HTML indexing, XML entries, or topic maps:

http://www.ontopia.net/topicmaps/materials/tao.html

You can use Word’s wildcard Replace feature (Edit > Replace > More > Use wildcards) to convert DEXter’s tags and Word’s XE codes to the kind of tags you need. For the secret techniques you’ll need to accomplish this miracle, see http://www.editorium.com/ftp/advancedfind.zip.

To tag bookmarks, open your reference and index documents, with the index document being active. Then click DEXter > DEXter Tools > Tag Bookmarks.

Note that Microsoft Word 2003 and 2004 have the ability to save a Word document in XML, including index entries.

Giving Embedded Entries to a Client

 XE "Entries;Entries:giving, to client;00058-00059giving,toclient" \r "ZZZDEXterdocumentationdoc00207" 

 XE "Embedded entries;Embeddedentries:giving, to client;00058-00059giving,toclient" \r "ZZZDEXterdocumentationdoc00188" 

 XE "Client;Client:giving embedded entries to;00058-00059givingembeddedentriesto" \r "ZZZDEXterdocumentationdoc00189" DEXter provides three ways to give a file with embedded entries to a client:

 •  If your client has DEXter, just give your reference document, with the entries already embedded (DEXter > DEXter Tools > Manual Marking and Generation > Mark Entries), to your client. Your client can then generate the index (DEXter > DEXter Tools > Manual Marking and Generation > Index . . . ) and process the index (DEXter > DEXter Tools > Manual Marking and Generation > Process Index) using any of DEXter’s options.

 •  If your client does not have DEXter, you can still mark your index entries using any of DEXter’s fancy options, such as letter-by-letter sorting. Then click DEXter > DEXter Tools > Prepare Embedded Entries for External Client. This feature finds any occurrences of the percent sign (%) in headings and replaces them with nothing. It also removes angle brackets (<) (>) from cross-references. (DEXter inserts percent signs as anchor points for moving cross-references, and it uses angle brackets to identify, merge, and sort cross-references.) Note, however, that your client may be able to use the forced sorts that DEXter has placed in your embedded entries. If so, your client can generate an index with letter-by-letter sorting, subheadings sorted by page number, and so on—all from the embedded entries you’ve provided, and without having DEXter. Note, however, that multiple cross-references used with identical headings will not work correctly. In addition, cross-references will be positioned in Word’s default location, which is preceding subheadings.

 •  If your client can’t use the forced sorts that DEXter has created, you’ll need to embed the entries using the option to “Embed plain index entries” when you create your index. For more information, see “Embed Plain Index Entries.”

If your client is using Microsoft Word 2003 or 2004 and does not use DEXter to process the index, your client should know that index generation in Word 2003 and 2004 is somewhat broken. For example, headings are followed by commas rather than colons when used with subheadings, and cross-references are separated by commas rather than semicolons. This is true even if you use field switches (see the appendix) to force Word to insert the proper characters. In addition, cross-references used in embedded index entries in footnotes or endnotes will be inserted twice (in other words, doubled) in the generated index. All of this is well worth complaining about to Microsoft, which you can do here:

http://register.microsoft.com/mswish/suggestion.asp?SD=gn&LN=en-us&gssnb=1

16. Appendix

Microsoft Word Features Useful in Indexing
Several of Word’s built-in features are useful in indexing. In particular, you should investigate:

 XE "Microsoft Word;MicrosoftWord:features of, useful in indexing;00060-00060featuresof,usefulinindexing" \r "ZZZDEXterdocumentationdoc00190" 

 XE "Indexing;Indexing:features of Microsoft Word useful in;00060-00060featuresofMicrosoftWordusefulin" \r "ZZZDEXterdocumentationdoc00191"  XE "AutoCorrect;AutoCorrect" \r "ZZZDEXterdocumentationdoc00192"  •  AutoCorrect (Tools > AutoCorrect Options > AutoCorrect), which makes it possible to assign abbreviations to commonly typed items. When you type an abbreviation, it automatically expands to the fully typed item.

 XE "Replace;Replace" \r "ZZZDEXterdocumentationdoc00195" 

 XE "Find;Find:and Replace;00060-00060andReplace" \r "ZZZDEXterdocumentationdoc00194"  •  Find and Replace (Edit > Replace), which makes it possible to find (and replace) almost anything in your index table. This is handy if your client gives you a name change, or if you decide to phrase something differently in your entries after you’ve already made lots of them. Be careful not to change anything in the Page or Entry columns (the last two columns in your index table). If you first select the columns in which you want to search, you shouldn’t run into any problems. To do that, place your cursor in the column you want to search; then click Table > Select > Column.

Other Useful Programs

 XE "Programs;Programs:useful;00060-00060useful" \r "ZZZDEXterdocumentationdoc00197" Other useful programs to help with indexing include:

 •   XE "Flashpeak IntellicompleteProfessional;FlashpeakIntellicompleteProfessional" \r "ZZZDEXterdocumentationdoc00198" Flashpeak IntellicompleteProfessional (http://flashpeak.com/icomp/).

 •   XE "MacroExpress;MacroExpress" \r "ZZZDEXterdocumentationdoc00199" MacroExpress (http://www.macros.com/index.htm).

Switches for Word’s INDEX field

 XE "Switches;Switches:for INDEX code;00060-00062forINDEXcode" \r "ZZZDEXterdocumentationdoc00200" 

 XE "INDEX code;INDEXcode" \r "ZZZDEXterdocumentationdoc00201" Word’s Help file explains the switches you can use with the INDEX field:

\b Bookmark

Builds an index for the portion of the document marked by the specified bookmark. The field { INDEX \b Select } builds an index for the portion of the document marked by the bookmark “Select.”

\c Columns

Creates an index with more than one column on a page. The field { index \c 2 } creates a two-column index. You can specify up to four columns.

\d “Separators”

Used with the \s switch, specifies the characters (up to five) that separate sequence numbers and page numbers. The field { INDEX \s chapter \d ":" } displays page numbers in the format “2:14.” A hyphen (-) is used if you omit the \d switch. Enclose the characters in quotation marks.

\e “Separators”

Specifies the characters (up to five) that separate an index entry and its page number. The { INDEX \e "; " } field displays a result such as “Inserting text; 3” in the index. A comma and space (, ) are used if you omit the \e switch. Enclose the characters in quotation marks.

\f “Identifier”

Creates an index using only the specified entry type. The index generated by { INDEX \f "a" } includes only entries marked with XE fields such as { XE "Selecting Text" \f "a" }. The default entry type is “I.”

\g “Separators”

Specifies the characters (up to five) that separate a range of pages. Enclose the characters in quotation marks. The default is an en dash (–). The field { INDEX \g " to " } displays page ranges as “Finding text, 3 to 4.”

\h “Heading”

Inserts text formatted with the Index Heading style between alphabetic groups in the index. Enclose the text in quotation marks. The field { INDEX \h "—A—" } displays the appropriate letter before each alphabetic group in the index. To insert a blank line between groups, use a space between quotation marks: \h " ".

\k “Separators”

Specifies the characters that separate an index entry and its cross reference. The { INDEX \k ": " } field displays a result such as “Inserting text: See Editing” in the index. A period and space (. ) are used if you omit the \k switch. Enclose the characters in quotation marks.

\l “Separators”

Specifies the characters that separate multiple-page references. The default characters are a comma and a space (, ). You can use up to five characters, which must be enclosed in quotation marks. The field { INDEX \l " or " } displays entries such as “Inserting text, 23 or 45 or 66” in the index.

\p “Range”

Compiles an index for the specified letters. The field { INDEX \p a-m } generates an index for only the letters A through M. To include entries that begin with characters other than letters, use an exclamation point (!). The index generated by { INDEX \p !—t } includes any special characters, as well as the letters A through T.

\r

Runs subentries into the same line as the main entry. Colons (:) separate main entries from subentries; semicolons (;) separate subentries. The field { INDEX \r } displays entries such as “Text: inserting 5, 9; selecting 2; deleting 15.”

\s

When followed by a sequence name, includes the sequence number with the page number. Use the \d switch to specify a separator character other than the default, which is a hyphen (-).

\y

Enables the use of yomi text for index entries.

\z

Defines the language ID that Microsoft Word uses to generate the index.

Switches for Word’s XE Field

 XE "XE codes;XEcodes:switches for;00062-00063switchesfor" \r "ZZZDEXterdocumentationdoc00203" 

 XE "Switches;Switches:for XE codes;00062-00063forXEcodes" \r "ZZZDEXterdocumentationdoc00202" Word’s Help file explains some of the switches you can use with the XE field, if you really need to do so. Note that DEXter will automatically do all but the last of these for you:

\b

Applies bold formatting to the entry’s page number. The field { XE "Highlighting text" \b } displays the entry as “Highlighting text, 23” in the index. The switch removes bold formatting if the index style for the entry is bold.

\f “Type”

Defines an entry type. The entry for the field { XE "Selecting Text" \f "a" } is included only in an index inserted by the field { INDEX \f "a" }. The default entry type is “i.”

\i

Makes the entry’s page number italic. The field { XE "Finding text" \i } displays the entry as “Finding text, 23 “ in the index. The switch removes the italic formatting if the index style for the entry is italic.

\r Bookmark

Inserts as the entry’s page number the range of pages marked by the specified bookmark. The field { XE "Selecting text" \r SelectingText } displays the entry as “Selecting text, 20–25” in the index.

\t “Text”

Inserts the text in place of a page number. Enclose the text in quotation marks. The field { XE "Highlighting" \t "See Selecting" } displays the entry “Highlighting, See Selecting” in the index.

\y

Specifies that the subsequent text defines the yomi (first phonetic character for sorting indexes) for the index entry. Note: This switch can be used if you have at least one East Asian language enabled.

17. Resources

 XE "Resources;Resources" \r "ZZZDEXterdocumentationdoc00204" American Society of Indexers. http://www.asindexing.org/site/index.html

Chicago Manual of Style. http://www.press.uchicago.edu/Misc/Chicago/cmosfaq/about.html

Mauer, Peg. “Embedded Indexing: Pros and Cons for the Indexer.” http://www.stcpgh.org/newslet/bpapr01.pdf

Mulvany, Nancy C. “Embedded Indexing: What is it and why should I want it?” http://www.stc.org/50thConf/Session_ Materials/dataShow.asp?ID=230

———. “Embedded Indexing Software: Users Speak Out.” http://www.bayside-indexing.com/embed.htm

———. Indexing Books. http://www.press.uchicago.edu/cgi-bin/hfs.cgi/00/12271.ctl

———. “Software Tools for Indexing: Revisited.” http://www.bayside-indexing.com/tools.pdf

Scott, Judith. “Embedded Indexing: A Comparative Study of the State of the Art.” http://www.indexingsociety.ca/BULLETIN_Summer_2002.pdf

Wright, Jan C. “An Overview of Indexing Methods.” http://www.wrightinformation.com/indexmethod.pdf

———. “Software Field Trip: Sources of Software.” http://www.wrightinformation.com/software.pdf

———. “The World of Embedded Indexing.” Beyond Book Indexing. American Society of Indexers, 2000.

18. Index

The index for DEXter’s documentation was created, of course, using DEXter. Notice that the index is sorted letter by letter rather than word by word, with subheadings sorted by page and cross-references following the entries. None of this is possible (at least without an enormous amount of work) in native Microsoft Word. DEXter makes it easy
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Cross-reference column, 35
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