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Introduction

Thank you for using WordCounter for Microsoft Word!

WordCounter counts the number of words, pages, and characters in the active document, all open documents, or all documents in a folder. If you’re writing or editing and bill by the word or by the page, you’ll find WordCounter indispensible. After it’s finished counting, WordCounter presents you with a nicely formatted table with the count for each document you specified and totals for the number of words, pages, and characters in your documents.

I strongly recommend that you try WordCounter several times on a variety of test documents until you understand fully how it works and what it can do.

By using WordCounter, you agree to the terms of agreement found at the end of this document.

Global Templates

WordCounter is basically a collection of macros in a template. You don’t use this template as you would an ordinary template by attaching it to a document. If you try to do that, you’ll run into problems. Instead, you “add” it to Microsoft Word as a global template or add-in (see installation instructions below).

Because the template contains macros, some virus-checking programs or even Word itself may warn you that the template could contain Word viruses. Please rest assured that it does not. Our macros have been carefully checked and tested to make sure they are safe and usable. If you have any question about this, you can download the program from our Web site at www.editorium.com. You may need to adjust Word’s macro security settings so that the macros in the program can operate. If Word asks if you want to “enable macros” when using this program, your answer should be yes. Otherwise, the program won’t work. Please see your Word documentation for more information.

Installing WordCounter

Before installing WordCounter, please make sure you have the right version of the program for your version of Microsoft Word. WordCounter is available for

• Word 6 and 7 (95).

• Word 8 and above (97 and above).

The version of WordCounter for one of these will not run correctly in the other, even though at first it may appear to. To check your version of Microsoft Word:

1. Click the Help menu item at the top of your Word window.

2. Click “About Microsoft Word.”

You’ll see the version of Word you are running at the top of the window that appears.

If you need a different version of WordCounter than the one you have now, please download it at www.editorium.com before proceeding.

Once you’ve downloaded and unzipped (or unstuffed) the proper version of the program, you’ll see the WordCounter template, which is named COUNTER.DOT. (If you need software to unzip or unstuff the program, you can download it from www.winzip.com or www.aladdinsys.com.) To use the template, follow this procedure:

1. Open it in Microsoft Word by clicking File > Open, selecting the template, and clicking the Open button. Do not open the template by double-clicking it outside of Microsoft Word. If you do, the program will not be installed correctly, and you’ll run into problems later.

2. Double-click the large button that says “Double-Click here to Install.”

3. Follow the prompts on your screen.

This will install WordCounter as a global template or add-in. If you elected to have the program start automatically when you start Microsoft Word, the program template will be saved to your Templates and Startup folders. If you elected not to have the program start automatically, it will be saved to your Templates folder. If you have trouble installing the program template, you can simply copy it to your Templates and Startup folders by hand.

When the installation is finished, if the WordCounter template is still open on your screen, close it. You can now discard the installation template or save it as a backup.

If you elected to have WordCounter start automatically when you start Word, you’ll need to follow a simple procedure to make it available during the same Word session as the one in which you installed it:

1. Click the Tools menu. (In Word  6 or 7 [95], click File.)

2. Click Templates and Add-ins. (In Word 6 or 7 [95], click Templates.)

3. Put a check in the checkbox next to Counter.dot.

4. Click the OK button.

If you didn’t elect to have WordCounter start automatically when you start Word, you’ll need to activate it each time you start Word:

1. Click the Tools menu. (In Word  6 or 7 [95], click File.)

2. Click Templates and Add-ins. (In Word 6 or 7 [95], click Templates.)

3. Put a check in the checkbox next to Counter.dot.

4. Click the OK button.

Please do not rename any of the WordCounter macros, copy them to another template, or remove them from the WordCounter template. WordCounter uses these macros in combination and will not work properly if they have been copied to another template or renamed or if some of the macros are no longer present.

Other WordCounter Files
WordCounter comes with two other files, COUNTER.DOC (a Word document) and COUNTER.CHM (a Windows Help document), both of which contain the documentation for WordCounter. If you're using Microsoft Windows, COUNTER.CHM should go in your Windows/Help folder. If you're using a Macintosh, you can delete COUNTER.CHM.

Uninstalling WordCounter

To uninstall WordCounter, remove the WordCounter template (COUNTER.DOT) from your Templates and Startup folders. If you don’t know where these folders are, you can find out like this:

1. Click the Tools menu.

2. Click the Options menu.

3. Click the File Locations tab.

4. Click the line that says “User Templates” or “Startup.”

5. Click the Modify button.

You’ll see the full path to your folder. Click Cancel and then Close to put the dialog away. Close Microsoft Word. Then navigate to the folder and remove the Counter.dot template.
Using WordCounter 
To use WordCounter, follow these steps:

1. Back up your documents—just in case.

2. Click the WordCounter menu at the top of your Word window.

3. Click Count Words. (The first time you run WordCounter, you will see the terms of agreement for using the program. Please read them carefully. If you agree with the terms, you will be able to use the program. If not, you will not be able to use it.)

5. Select the options you want to use. (See “WordCounter Options,” below.)

6. Click “OK” to continue. (To quit, click "Cancel.")

WordCounter Options

Documents to Work On

You can select whether to run your macro on:

1. The active document.

2. All open documents.

3. All documents in a folder.

If you want to use WordCounter on all the documents in a folder, first make sure only the documents you want it to work on are in the folder. Show all documents (*.*) to be sure.

If you would like WordCounter to work on all documents in a folder, use the dialog box to carefully select the folder. (Don’t get the wrong one!) Then click “OK.” I recommend using a new folder called “Copy” into which you copy your documents so that your original documents remain intact.

WordCounter turns off all automacros while it runs.

Registering WordCounter

If you like WordCounter and plan to continue using it, you should purchase a license to do so. If you don't, your copy of the program is for evaluation purposes only, and it will stop working after 30 days or 1,000 uses, whichever comes first. After you purchase a license to use the program, we'll send you a password that will unlock the program to run without limitation on time or use.

The terms of your license prohibit you from giving your program password to someone else or using it on someone else's computer. However, you may use the password on up to three of your own computers. For example, you could install WordCounter and use your password on your computer at work, your computer at home, and your laptop. However, you may run the program on only one of your computers at a time. If you need to run the program on more than one computer at a time (for example, for use by a family member or employee), you must purchase another license and get another password for the program. This is the honest and legal thing to do. Besides that, we’re a small company and need your support. Thanks for your cooperation.

Here are the prices for a program license, but these are subject to change without notice:

1 user: $19.95

2-10 users: $14.95

11-49 users: $13.95

50+ users: $12.95

Getting a Password

Here’s how to purchase a program license so you can get your password:

1. Click the WordCounter menu item at the top of your Word window.

2. Click the “Register WordCounter” menu item.

You’ll be presented with two options:

1. Get a password for this computer.

2. Enter the password for this computer.

Click option 1, “Get a password for this computer.” Then click “OK.”

You’ll be presented with two more options:

1. Register on the Internet (at www.editorium.com).

2. Register by mail.

Click the option that meets your needs and follow the instructions on your screen. Registering on the Internet offers some distinct advantages:

1. You’ll receive your password automatically by return email as soon as your payment is processed. If you’re paying by credit card, you’ll receive your password almost immediately. Just check your email as soon as your online registration is complete.

2. You can make your payment in several different forms: credit card, check, or money order. If you don’t pay with a credit card, however, you won’t receive your password until after we receive your payment.

3. You can make your payment in several different ways: on our secure online order form, by fax, or over the phone.

If you're interested in using a purchase order, please let us know by emailing sales@editorium.com.

If you don’t have access to the Internet, you can still register by postal mail. In that case, we’ll send your password by email (if you have it) or postal mail after we receive your check or money order and your registration form. If you’re registering by mail, the program will create a registration form in Microsoft Word. Please fill out the form, using your cursor keys to move from item to item. Then print the form and mail it to the address at the top of the form.

Using Your Password

Once you’ve received your password from the Editorium, you’ll need to enter it into the WordCounter program. To do so:

1. Click the “WordCounter” menu item at the top of the Word screen.

2. Click the “Register” menu item.

3. Click “Enter the password for this computer.” Then click “OK.”

The password entry box will appear on your screen. Carefully type the password into the box labeled “Enter your password.”

If you have a valid password and type it correctly, the program will tell you that your registration was successful. After that, the program will run without limitation on time or use.

Thanks for your support!

Troubleshooting

Problem: When you try to open the template to install the program, Microsoft Word tells you that “The macros in this project are disabled . . .”

Solution: Microsoft Word’s macro virus protection is enabled or set to a high level of security. To change this:

In Word 2002 (XP):

1. Click the “Tools” menu.

2. Click “Options”.

3. Click the “Security” tab.

4. Click the “Macro Security” button (on the lower right).

5. Click the “Security Level” tab if it’s not already active.

6. Set your security level to medium and click the OK button.

7. Click the next OK button to close the Options dialog.

In Word 2000 or 2001:

1. Click the “Tools” menu.

2. Click “Macro.”

3. Click “Security.”

4. Click the “Security Level” tab if it’s not already active.

5. Set your security level to medium and click the OK button.

In Word 97 or 98:

1. Click the “Tools” menu.

2. Click “Options”.

3. Click the “General” tab.

4. Uncheck the box labeled “Macro virus protection.”

5. Click the “OK” button.

In Word 95:

1. Click the “Tools” menu.

2. Click “Options.”

3. Click the “General” tab.

4. Uncheck the box labeled “Enable Macro Virus Protection.”

5. Click the “OK” button.

Now, in Word 2000 or higher, any time you open a document or template that includes macros, Word will give you the choice of whether to disable or enable macros. If the document or template isn’t supposed to have macros in it, you should click the “Disable Macros” button, because the macros could be a virus. If the document or template is supposed to have macros and comes from a source you know is reliable, click the “Enable Macros” button so you can run the macros.

In Word 95, 97, or 98, you don’t have these options. Macro virus protection is either on or off. Before turning it off permanently you may want to read more about it in Word’s Help file or check with your system administrator.

Problem: You’ve installed the program, but you can’t see or find the program menu. In addition, Word may have crashed after you finished the installation.

Solution: Delete any existing versions of the progam template that are in Word’s Startup and Templates folders. Then, to install the program, open the newly downloaded program template in Microsoft Word by clicking File > Open, selecting the template, and clicking the Open button. Do not open the template by double-clicking it outside of Microsoft Word. If you do, the program will not be installed correctly. After opening the template in the proper manner, follow the installation instructions in this documentation.

If you still have problems after this, once again delete any existing versions of the program template that are in Word’s Startup and Templates folders. Then simply copy the template into Word’s Startup folder and restart Microsoft Word.

If you don’t know the location of the Startup or Templates folder, you can find it like this:

1. Click the Tools menu.

2. Click the Options menu.

3. Click the File Locations tab.

4. Click the line that says “User Templates” or “Startup.”

5. Click the Modify button.

You’ll see the full path to your folder. Write it down. Click Cancel and then Close to put the dialog away. 

Problem: WordCounter has been running for hours on just a few short documents.

Solution: Press the Escape key to stop the program. Look at the cursor position in the open document to see if you can figure out what may be causing the problem. If you can, fix the problem before running WordCounter again. Also, check the documents after the problem document to see if they have the same problem.

Problem: You get weird error messages while running WordCounter.

Solution: See the solution to the problem above.

Problem: When you try to load WordCounter as a global template or add-in, you get the Convert File dialog, asking you to select a kind of text for conversion.

Solution: You’re trying to load the wrong version of WordCounter for your version of Microsoft Word. To get the correct version, please download it from the Editorium at www.editorium.com.

Problem: When you try to load WordCounter as a global template or add-in, the status bar says, “Translating macros” and shows Word’s progress as it translates the macros in WordCounter. When it’s finished, the program’s toolbars are all messed up.

Solution: You’re trying to load the wrong version of WordCounter for your version of Microsoft Word. To get the correct version, please download it from the Editorium at www.editorium.com.

Problem: Microsoft Word crashes at some point when you’re running macros on all open documents or all documents in a folder.

Solution: Some of your documents may be corrupt. You can identify a document that caused the crash by reading its name in the bar at the top of the Word window when the program crashes. If possible, open the document, copy all of its text but the last carriage return, and paste the text into a new document.

Any Questions?

We hope you find WordCounter to be immensely useful. If you have any questions or comments, please let us know.

support@editorium.com

www.editorium.com

The Editorium

P.O. Box 702601

Salt Lake City, UT 84170  USA

The Editorium provides word-processing tools for editors, writers, and other publishing professionals. If you like WordCounter, you may be interested in these other products from the Editorium:

Editor’s ToolKit Plus includes Editor’s ToolKit, FileCleaner, NoteStripper, and QuarkConverter.

Editor’s ToolKit provides a variety of powerful tools for editing with Microsoft Word.

FileCleaner cleans up common typographical and editorial problems in electronic manuscripts.

NoteStripper converts automatically numbered notes into text notes or vice versa.

QuarkConverter converts Word documents into XPressTag files that can be imported into QuarkXPress.

MegaReplacer finds and replaces multiple words, phrases, and even styles in multiple documents.

You can download fully functioning evaluation copies of these programs free of charge from the Editorium's site on the World Wide Web at www.editorium.com.

This documentation and the WordCounter software are copyright © 1996, 2000, 2001 by the Editorium. All rights are reserved. WordCounter, Editor’s ToolKit, FileCleaner, QuarkConverter, NoteStripper, MegaReplacer, and Editorium are trademarks of the Editorium.

All trademarks mentioned in this documentation or the program are acknowledged as trademarks of their owners.

Terms of Agreement

By using WordCounter, you agree to these terms:

LICENSE AGREEMENT

The WordCounter software and its documentation (collectively the Software) are protected by the United States copyright laws and international treaties and are owned solely and entirely by the Editorium.

You (the licensee) may run the Software on up to three computers (but only on one at a time) during its evaluation period and (if you purchase a license to do so) after that. You may not copy or sell the Software for commercial gain.

You may freely transfer copies of the Software to others for evaluation. You may NOT let someone else use your password for the Software or rent or lease your license to run it, but you may transfer the license to someone else who accepts this agreement.

You may not modify, reverse engineer, decompile, disassemble, unencrypt, or create derivative works from the Software. You may not use the Software in any manner that infringes the intellectual property or other rights of another party.

DISCLAIMER OF WARRANTY AND LIABILITY

The Editorium disclaims all warranties on the Software, expressed or implied, including but not limited to warranties of merchantability and fitness for any particular application, use, or purpose. You use it at your own risk.
Under no circumstances, including its own negligence, shall the Editorium or its suppliers be liable for any special, incidental, or consequential damages or loss that result from the use of, or the inability to use, the Software.

This agreement shall be construed, interpreted, and governed by the laws of the State of Utah in the United States of America.

October 20, 2001

